I am so sick of trying to figure out why my smart apps aren't working


(Ron) #1

I have a smart app which checks my homes temperature and if hotter then 80 degrees turns on the AC some my Dogs don’t suffer. It doesn’t work 80% of the time.
I have another smart app trying to fix the broken polling, it subscribes to my power meter and calls poll when it gets an update. It almost never works even though I see power meter events.

I am sick of clicking on update in the ide, editing the smart app making no changes and hoping that when I select “Done” it will update., deleting the smart app and re-adding it in the hopes it will start working.

Subscriptions was one of the only things that used to work with my SmartThings hub. Now it doesn’t. Believe it or not my timed events are working better then my subscriptions now. It is frustrating trying to guess what works and doesn’t work each day.


(Steve Jackson) #2

Have you tried pollster?

I used that to update my Honeywell thermostat before the official device handler was introduced. I worked well for me.

Steve


#3

How do you setup? Which app / hardware etc. contacted the support?


(Jody) #4

Can you unpack this a scenario a bit more? Not every device can be polled. I would be happy to go over the logs and take a look at your specific issue.


(Ron) #5

Yes I have. It works sometimes. But like everything else not always.

Yes I have contacted support. On and off for 2 years. Not interested in dealing with them anymore.

Sure I have smart apps and devices that have worked for months on and off. They work one week and fail the next. So clearly it’s not a matter of the device not being supported. Seriously are you not aware that things are breaking all the time ?

The smart app is very simple.

Configure

  1. select Temp sensor
  2. select temp reading to trigger action
  3. select thermostat
  4. select setting (AC/Heat)

It’s simple subscribe to temp sensor.
When triggered if temp over or under reading (over for ac, under for heat)
Then call cool or heat on thermostat

The codes here feel free to have a look but the point is I have used this for over a year and it worked fine. Now it doesn’t but nothing has changed.
I have other subscription based smart apps failing so I am sure the issue is the platform. Not to mention I get an email every day from support stating “we are investigating issues, we solved the issues but will keep monitoring”.

The first step in solving an issue is admitting you have one !!!


(Jody) #6

Ron,

Apologies that you are experiencing difficulties on the platform, I want to do whatever I can to get you back up and running. If you will PM me your account email address, I will look through the logs. It would also help to know of any times you know that the mode should have changed but it didn’t.

I did notice that in your preferences you have “HeatOff” and “CoolOff”. Later in the code, you evaluate for “heatOff” and “coolOff”. As you said, it was working for while, but this might be worth a shot.


(Ron) #7

@jody.albritton I appreciate you trying to help. You are correct about HeatOff and CoolOff, I don’t use the off option so I didn’t catch that. But this isn’t the cause of my issue because like you mentioned the setting I have been using do work at times. My issue is with the unreliability of SmartThings not the specific smart app.

Are you aware of issues with Subscribed events lately?
About a week ago I posted that ALL my subscribed events were failing. When I visited my ide to watch the logs there was no subscription activity at all in the logs then while working on this issue I suddenly saw every subscription I had register new. It was clear that something was being done on the server side that lost all subscriptions and then updated them back on. When I saw these events I started testing again and things started working.

However since that time these smart apps have not been firing. I tried updating them but still not working. Now suddenly this morning they started showing activity in the logs.

For now the smart app is working again.

On a side note I fixed the HeatOff/CoolOff error but the ide is not working with github integration right now, just one more example of how randomly SmartThings works.

Again thanks for trying to help Jody, I am just frustrated with SmartThings not being reliable for such a long time. There is nothing you can do about this it needs to be fixed at a much higher level.


(Jody) #8

I am not aware of any systemic problem with subscriptions.

I can find an issue in your logs, verify, and then get engineering involved.


(Jason "The Enabler" as deemed so by @Smart) #9

@Ron

Hi Ron!
Sorry about your frustration, I know I hate it when things don’t work right.

But hey, I thought I would throw in my two cents.

I use two Honeywell 8320 zwave thermostats. They are fully programmable at the device and they do not have to be controlled via a zwave controller. So, that means they work even if the network is not working. That could possibly be an option for you.

Or, there are other options as well.

Ice I’ve been using the smartapp “keep me cozy” to control my thermostats. I’ve been using it for several months now and honestly, the only problem I have had came from the thermostat deciding to just stop working.

The smartapp has done everything is programmed to do without a single glitch.

There’s also a bunch of other options out there too.

What kind of thermostat are you using?


(John) #10

I noticed an issue today with subscriptions. I subscribe to a switch. The Off always works - code executes as expected. The On never works - nothing executes, even the debug statement that is first. I can make On work if all it does is execute a debug statement. No errors are generated in live logging. It worked yesterday, but not today.


(Ron) #11

I have a split system. It doesn’t use thermostats on the wall. It has a remote control and the thermostat is built in. This is my I use the ZXT-120 which is an IR blaster to send the signals I need to send. It has a built in temperature sensor but it doesn’t send events it waits to be polled. SmartThings polling sucks ! Sorry no other way to say it. I have been dealing with ST polling issues since the first day I bought it and they should really remove the capability from their list because it doesn’t work at all and I have no hope that it every will. I know about all the hacks, pollster being the most popular but nothing works.

Thanks for helping me fell like I am not crazy…well ok…less crazy…


(John) #12

Same here. This has been driving me nuts too. Short drive, but journey is excruciating.


(Jody) #13

@bago can you tell me the name of the smartapp that is not working with subscriptions? I have brought this up with or engineers and we need more data to troubleshoot. If all subscriptions were failing, it would be pretty easy to spot the failure. We are also not seeing an increase of trouble tickets about this.


(John) #14

I got it working. Deleting and re-adding via the SmartApp didn’t work. BUT… Deleting and re-adding in the IDE did work.

Thanks for the help.


(Ron) #15

Mine isn’t working again. It’s 80.8 degrees in my home.
I wish the logs were available for debugging events that aren’t working but they only work when you select live logging and often they don’t even work then. So there is one thing that could be fixed that would help report and diagnose these issues !

So I am left with showing you the current condition of my things and it is clear this isn’t working.

The SmartApp mentioned above is installed as “LivingRoomAConTemp80”.
It is configured as display in these two images


Now lets see what the current temperature is on UpstairsPads Sensor.

Now lets look for the event to turn on the AC

NOPE not there. Smart app is not working again.


(Keith Croshaw) #16

I feel your pain. I know CoRE is on beta but rules that worked for weeks just stop working…

I can’t really keep up with it anymore. I do enough of that at work…


(Ron) #17

EXACTLY, I really which there was another platform that worked with Amazon Echo. I would switch in a heartbeat !!! I want to get rid if SmartThings SOOO bad but I rely on it for so much at this point…no wait rely is really the wrong word. I hope on it for so much at this point…yea that’s better.


(Keith Croshaw) #18

Yea I’m in the same boat. If there were another open platform that most of my devices worked with and didn’t require understanding of complicated configuration files I’d jump ship immediately.


(Ron) #19

I just closed my log tab while working on an issue so of course I lost my log now…I really hate that they don’t have logs that persist !!!

WHY DO I KEEP TRYING…definition of crazy to keep trying the same thing over hoping for better result…


(Ron) #20

When this device is released you will hear an enormous sucking sounds as everyone leaves this community :wink: