HVAC Condensate Pump Alarm?

I recently had the condensate pump on my AC unit fail and ended up with a bunch of water in my basement. The new pump I put in has 2 wires on it that are meant to hook up to either an alarm or a shutoff for the HVAC system. What device would folks recommend I could attach to those wires and integrate with ST instead? I could be wrong, but that seems more reliable to me than just putting one of the water sensors down and hoping it is in the path of a future water overflow.

This is the pump: https://www.homedepot.com/p/Everbilt-115-Volt-Condensate-Removal-Pump-CSP010/204480032

those two wires are usually attached to a float switch i believe. I don’t know of any smart float switches, but you may be able to use a z-wave sensor with remote leads.

I’m not looking to replace the switch, just something I can connect to the two leads that will alert me.

ah, in that case and z-wave or zigbee device with dry contacts will work. GoControl made a door sensor that has them, and others like Quibino have dedicated dry contact devices. You may have luck googling “z-wave dry contact sensor”

2 Likes

Assuming the two wires coming out of your condensate pump/resevoir are simply connected to a float-switch (i.e. no power coming from those two wires), you can simply use the following Z-Wave sensor which has screw terminal internally for an external switch input.

Just verify with the vendor, before buying, that the current shipping model still has ‘external contacts’. I am not sure if this feature has been kept or eliminated on newer revisions.

2 Likes

Thank you very much for your help!

1 Like

Post pictures or let us know how this works out. Because this is something I might be interested in doing too.

The Ecolink sensor is great. I use it for other applications where I connect to the ports. However, it will not give you battery status information. You need to test it periodically to make sure it still works and is not out of battery. Mine usually lasts about 9-12 month…

How about using a water sensor like this? I use it for my sump pit - yes that is bigger but may work for you, too.

1 Like

I just got a mail: Arotec has a new device with external ports. This may have battery reporting. It’s a bit more expensive though:

https://www.amazon.com/dp/B07PDDX3K6/ref=as_li_ss_tl?ref=myi_title_dp&linkCode=sl1&tag=sso0e-20&linkId=07857678651265399caadcb6acea6466&language=en_US

I got the Aeotec Door/Window Sensor 7 and it certainly does have spots for wires, so that’s good! The holes in the case are too small for the wires on my condensate pump, so I just drilled them larger into a slot to fit.

However, I’m not sure how to change the parameters to detect the wires as opposed to the magnet sensor. According to their website, I need to change Parameter 1, but I have no idea how to do that. Any tips?

https://aeotec.freshdesk.com/support/solutions/articles/6000223859

EDIT: I forgot to mention that it also appears to be showing battery level, so that’s another plus!

can see if Aeotec has a smartthings handler with that setting or use this [BETA] Z-Wave Tweaker

Couldn’t find a specific handler designed to allow those changes, but the Z-Wake Tweaker you posted let me change the parameter. Seems to be working now. Thanks everyone for all the help!

3 Likes


@bytemyfoot Is this the correct configuration? I put Parameter ID = 1 and then Parameter Value = 1

I then changed the device type handler back to the original “Z-wave Door/Window Sensor” and there’s a settings option now in the 3 dot menu (upper right hand corner in the app). Which shows these parameters: ZwtParamId = 1, ZwtParamValue = 1, ZwtAssocGroupCc = 0

that last one, ZwtAssocGroupCc, was maybe because I selected Configuration Class and selected Auto when I tapped it. There was a choice for single channel or multichannel and I wasn’t sure.

I tapped the tamper switch on the side like the instructions stated.

I even tried removing the battery and replacing. But nothing changed, the sensor still reacts to the magnet.

Any help would be appreciated.

So my settings were correct.
The ZwtAssocGroupCc setting is irrelevant; Aeotec support confirmed:

ZwtAssocGroupCC has no value in the setting, but it doesn’t really matter if it is set or not.

1. From the SmartThings IDE Press Save
2. You must immediately tap the button on the Door Window Sensor 7, i would suggest tapping the button in intervals of 2 seconds.

I had to do that repeatedly before it took. 5 attemtps, multiple tapping of the button.
I think you can do all this from the app interface as well, but I stuck to the IDE.
After making the changes using the Z-wave tweaker v2, I changed the handler back to the original “Z-wave Door/Window Sensor”.

But the sensor is in the open position constantly now. The sensor is hooked up to a condensate pump safety switch. I setup my automation to shut off my a/c when the switch gets activated and the Aeotec sensor (now dry contact) goes into the closed position.

But in the SmartThings app I get a constant notification that the Aeotec sensor is in the open position. Is there anyway to disable that? It seems that SmartThings won’t notify if the switch is in the closed position. Can I switch the current state to be in closed position?

1 Like

I figured I’d just paste my convo with Aeotec tech support; maybe it will help others out.

=================================================================================

Aeotec

Using Z-Wave Tweaker, you have the settings correct.

ZwtAssocGroupCC has no value in the setting, but it doesn’t really matter if it is set or not.

  1. From the SmartThings IDE

  2. Press Save

  3. You must immediately tap the button on the Door Window Sensor 7, i would suggest tapping the button in intervals of 2 seconds.

I would highly recommend keeping “Live Logging” page open so you can see if it is programmed appropriately or not. The logging should be able to tell you if the parameter setting got pushed.

If it did not, try re-doing the steps a few times.

Squash22

Thank you. It took many tries (many taps) but it finally took.

Squash22

I changed the handler for the Aeotec sensor back to “Z-wave Door/Window Sensor” and it works. But the sensor is in the open position constantly now. The sensor is hooked up to a condensate pump safety switch. I setup my automation to shut off my a/c when the switch gets activated and the Aeotec sensor (now dry contact) goes into the closed position. But in the SmartThings app I get a constant notification that the Aeotec sensor is in the open position. Is there anyway to disable that? It seems that SmartThings won’t notify if the switch is in the closed position. Can I switch the current state to be in closed position?

Aeotec

Its another parameter setting to adjust the status output positions.

Parameter Setting to adjust reverse state:

Parameter 2 [1 byte] = 1 //set NC toggle / follow state which will follow the input of dry contact terminals where ON is CLOSED and OFF is OPEN (the default value is 0 which is the reversed state you have currently).


Just in case, you can set the door window state to be reversed also:

Parameter 3 [1 byte] = 1

Squash22

How do I edit other/multiple parameters at the same time? In the box for " Parameter ID: - Tap to set" Can I put in more than one number? Do I separate them by an distinct comma/semicolon/dash? And then how do I set multiple parameter values (Parameter Value: - Tap to set) for each of these parameter ID’s?

Aeotec

With Z-Wave Tweaker, you just need to change Parameter ID and value​ and you can program one parameter at a time. Each time a parameter setting is sent, it should be stored in the unit, allow you to change the Parameter ID and value to change a different setting.

Squash22

So I set it, then press the save, then tap the button (until it takes), then set another one. Ok thank you.

=================================================================================

I set an automation to set the AC to OFF mode if the dry contact sensor is in the OPEN position for more than 1 minute.