Hue Bulb Factory Reset: SOLVED if your Hue Bulb is on a ZLL Channel

Excellent. The gift that keeps on giving…

I want to give a SHOUTOUT to ZONOMO for this solution. It works!

I have a Hue Lightstrip that I added to a ceiling fixture. To do this, I removed the plastic cover so that it could fit in the fixture, without realizing that I might need the “serial number” (AKA DeviceID) later. I’ve been trying to move this to a new hub, without success. I interrogated the hub, and captured the “uniqueid”, but you can’t use this field to search for a connection. Multiple inquiries to Philips Hue for how to connect this lightstrip to a new hub went unaswered.

This worked in about 10 minutes.
I’ll repeat the steps outlined by ZONOMO for clarity:

  1. Get the IP address. I did this from my main router. The hub clearly identifies itself in the device ID list kept by the router.

  2. Launch a web browser to http://192.168.11.164/debug/clip.html (obviously, replace “192.168.11.164” with whatever your local IP address is).

  3. You will get the CLIP API Debugger screen shown above. Enter:
    URL: /api
    Message Body: {“devicetype”:“my_hue_app#iphone peter”}
    (It doesn’t matter if you don’t have an iphone and your name is not peter. This is just a placeholder so you can get access to the hub - you won’t use the name again. I’ve just copied this from the Hue website.)
    PUSH THE LINK BUTTON ON THE HUB (the big button in center of the hub. This authorizes the next step)
    WITHIN 30 seconds of pushing the link button on the hub, press “POST” on the CLIP API Debugger.
    You will get a message saying username: 1028d66426293e821ecfd9ef1a0731df. The text is randomly created. COPY THIS. You will use it to access the hub in all future steps.
    The Hue website that describes this in more detail: https://developers.meethue.com/documentation/getting-started (also noted above).

  4. Turn off electrical power to all HUE lights except the one you are trying to reach. That way only it can respond.

  5. Return to the CLIP API Debugger:
    URL: /api/1028d66426293e821ecfd9ef1a0731df/config
    (again, the ID is the random sequence generated. This is the example from the Hue website)
    Message Body: {“touchlink”:true}
    Press the “Put” button.
    The light will blink when the Hub sees it, and it will appear in your Hue app. I did a search right after, but I don’t know if that step was necessary.

Again, this works! I would have saved hours of work if I had found this posting a few days ago.

THANKS, ZONOMO!

1 Like

You’re very welcome Steven. Glad it helped.

Worked first time Thank you so much - very easy if you read the instructions…

1 Like

And if you’re lucky enough to have a smartthings hub running on one of the channels which is also used by ZLL. :wink: As we’ve already discussed up thread, but I just wanted to call it out again.

If, say, your smartthings hub is on zigbee channel 14, you won’t be able to use this method no matter what you try, because “when the hub sees it” in step 5 will never happen.

So easy for some, impossible for others.

Also, I know no one cares about this but me, but the Hue device is a bridge, not a hub. There is no “hue hub.”

@JDRoberts

I wrote this up and put it in the wiki with a little more detail and device specific.

http://thingsthataresmart.wiki/index.php?title=How_to_Reset_Philips_Hue_Bulbs

Hi @JDRoberts - I found something interesting in your write up on thingsthataresmart. You mention:

verify that the coordinator that the bulbs were previously associated with was using zigbee channel 11, 15, 20, or 25.

But in my case, I think I am on Channel 24. I am not sure why but apparently channel 24 works too.

2017-11-20_9-25-36

1 Like

Yes, 24 is also a ZLL channel, and it should work. That’s my bad, I just left it off by mistake. :disappointed_relieved:

All good JDR. :slight_smile:

1 Like

I registered just to say THANK YOU! I had a bulb I thought had died but figured I’d try this first. When turning the bulb on I’d see a small white flash but the light would not turn out - not reachable etc. The reset seems to have done the trick. Thanks!!!

2 Likes

Monte my man… you rock sir. This resolved my issue. Thx again.

1 Like

Excelled! Glad to hear.

Just bought a white bulb from Amazon bundled with the Philips Hue Smart Dimming Kit that would not connect at all. This saved the day. Thanks so much!

2 Likes

Everytime I see that this helps someone, It makes me happy I’m helping spare some frustration. Thanks everyone.

2 Likes

Hi @zonomo zonomo And @JDRoberts
I have read through this thread but want to check; will this help me if i have a hue bulb previously paired directly to my smartthings hub which is now ‘unavailable’ in my smartthings app ? I dont have a lutron remote or a hue bridge . My amartthings hub is on channel 19.

The “unavailable” is likely an entirely different issue due to either range or the device health feature in SmartThings. It can affect all kinds of devices, including many of those that are officially supported like the Sylvania bulbs. I don’t think it’s likely to be the Hue-specific issues discussed in this thread.

Thanks jd any idea how I can resolve ?

For clarity: the devices that say ‘unavailable’ have not been moved or relocated in anyway so their range is exactly the same.

The only thing I have added to my setup is a tado thermostat which, as far as I understand, operates on wifi, not zigbee, anyway, so i dont think woul impact my zigbee lights.

Also for clarity: i can not control through smartthings- when i click on them it says ‘the device is unavailable at the moment’ even if i press the cross at top right to get to the usual controls for it, nothing works.

For some reason, this process did not work for me…at least not at first. Quick story. Power went out for about 15 minutes one Sunday morning. When it came back on all 10 of our Hue lights were unavailable. After attempting to power on and power off, recycle the network, recycle the bridge, still nothing. So I reset the bridge to factory settings after reading a blog post somewhere else (big mistake).

Once I got the bridge back-up and running, the lights could not longer be found. Just like Zonomo, I quickly discovered all the historical ways of resetting a bulb proved fruitless. Telnet didn’t work, LampStealer was gone, and even HueLights app Touchlink command wouldn’t work. So I tried Zonomo’s method, but still no luck.

Looking for all possible scenarios, I discovered the Lutron Connected Bulb Remote, but it’s no longer available. So surfing Amazon, I see the Philips dimmer switch and find a YouTube video that explains how one can use the dimmer switch to reset the lights. Ordered away and a day later, it arrived.

Here’s the weird part. The dimmer switch does work as advertised in the video. The lights have to be away from your bridge, or you bridge needs to be disconnected and unplugged. Also, while it “resets” the lights, it then immediately pairs them to the dimmer switch. So to pair them to your bridge, you still have to reset them. Once I paired them to the dimmer switch, I tried Zonomo’s solution, and it worked! The Touchlink command would blink/reset the bulbs, and I could then pair them to the bridge.

Good grief. About 5 days of trial and error, but finally got all our lights working again. Just thought I’d post this in case anyone’s trying this solution to no avail. Dimmer switch plus this solution and it worked.

2 Likes