Hub V2 - Hot Fix - 09/15/16 (15.8)

I wholeheartedly agree, that supported features should work as advertised and that customers don’t need to find work arounds to overcome shortcomings. But we are talking about ST here and you know the reality.

And what can be more supportive of each other than one person suggesting a workaround that may alleviate someone’s angst against the current state of things. I know I was very appreciative to suggestions I received when I was dealing with broken ST features…

4 Likes

My modes are changed by ST routines. That is their only function, change the mode at a certain time. Rock solid for many months.

My CoRE routines are triggered by the mode actually changing. No mode change, no routine.

Ice nite designed a piston that will know if the mode has not changed, send me a text, and attempt to initiate a manual mode change every 15 minutes until it is correct.

1 Like

Did you get notification that your mode changed but it didn’t? I’ve had pistons that didn’t fire this morning, but I thought something pooped with the piston. They are triggered by mode changes…my home was acting like the mode was changed, but didn’t actually check. I’ll keep an eye on it…

I received the push message that the mode has changed, but none of the actions had occurred. I checked the app and it still said sleep mode, it should have been in morning mode. It also showed that the piston had fired, but none of its actions were completed. It took the attempts to actually change the mode and the piston never works right.

The second mode failure, nothing happened. It just completely missed the scheduling.

I’ve seen this happen to me once before, about six months ago I think.

If anyone is interested, this piston will alert you to a mode change failure and attempt to imitate the mode.
It’s tough right now and I’m refining it, but here you go.

2 Likes

I spent time with support on this. They told me this is a known error already. Routines are being stuck and the only current suggestion from support was to go into IDE, create a new mode, then a new routine then run it. This is just a temp fix. I have this issue on both a v1 and as of this morning my v2.

1 Like

So I guess it’s a really good thing that they made creating a new mode so much easier with this update. Oh, wait… :speak_no_evil:

2 Likes

This reminds me of the Buick that my wife was so in love. We purched one brand new and in just couple of months the transmission went bad. We took it to the dealership for repairs and they told us it’s a know issue. And when we asked them if it’s fixable, they said is not a permanent fix, as it is something wrong with the design. Well they fixed it and then few months later it was broken again. We fixed it again, but as soon as the vehicle was ready, we drove it straight to another dealership and traded the Buick. Not only that we will ever buy a Buick again, but most likely none of our friends will either…

I’ve had little things happening since the update. Nothing major just things that make you go huh??

But today I get a call at work that says pretty much everything in the house connected to the hub is on. I looked back in the activity log on my phone and around 12:59 ish looks like it all turned on?

Soo I guess my question is, when I get home tonight, where do I start looking to try and figure out the cause? Or do I just turn everything off and shrug it off to the JOY’S of having this system?

That same thing happened to me a couple of months ago…
I put inn a trouble ticket.
They told me that the command didn’t come from the hub but from the devices.
So assistant I’m able to be in 20 different places in my house all at once to turn on all of the devices that came on.

Follow-ups resulted in, we’re working on it.

No forget contact about it since then…

That’s what I figured.

I found one thing unusual in my activity feed:
Every 10 to 15 minutes one of the ceiling fans would report.
Fan current speed is medium
Fan current state is medium
Fan current speed is high
Fan current state is high

It is the only fan that was reporting over and over. Then after they turned everything back off like it should be. The above reports stopped.

So maybe the switch or DTH for the switch was the start? Or a solar flair directly on MY house caused network comm’s to freak out. I thought I felt a tremor in the force about then and heard my hub squealing in pain!!

Mine has been done this for a week now, before update. It seems the everything is firing it’s just reflecting correct mode in app or ide. Tried changing in ide and it would always stay as away now it’s been stuck on home for 4 days. Emailed support.

Support told me they turned over to devs and I would be notified when a fix was found.

Was this just Hue lights that were on? Did you lose power to your house for a brief moment?

Nope everything was on. Fans, lights controlled by switches, osram lights, only things off were 2 lights that smart lighting turned off like it’s supposed to.

Nope no power loss that I could see. In activity log on my phone you can see where everything turned on at 12:59pm. Nobody was home found out when I got called later asking why I turned everything on, what did I do, change in the house.

Wonder why they always assume it’s me? Hehehe

Edit: now that I think about it. I know the power didn’t go off (unless it was short) cause I have Tasker monitoring my tablet Power connection. I didn’t get an alert to that or see it in the activity log.

I just realized too that none of the virtual Switches / dwvices changed. Only the physical. I’m sure it’s like @bamarayne had earlier. I cycled them ALL at once. :slight_smile:

2 Likes

So my ST thinks my Hue hub went offline again last night so i rebooted. All good. then this morning no control of any Hue bulb at all!
this is what i get in the log too… did somebody break something at about 11pm GMT last night??


Looks like it cant parse the info coming back.
Also WTF has happened to tjhe Hue Connect smart app?? its vanished from the marketplace so even if i wanted to I couldn’t try removing and re adding Hue connect to fix this.

For the last six months i have put up with an intermittent Hue control, but this is beginning to try my patience… Come on guys get it together and fix one of THE MOST IMPORTANT integrations outside of ST devices.

@HughB there’s a decent amount of info in this thread about users experiencing Hue issues since the last update.

There’s a fix posted by ST (which requires removal of Hue and then manually re-creation via the IDE. We’re waiting on ST to confirm when they are going to deploy the fix.

I was getting the delay in hue control only via ST. The Hue app on my iOS device has always been near instant, both internal and external of my network.

To install the hue connect, go to marketplace, add new devices, bulbs, Phillips, and add a bulb. Even if you’re not actually adding one. That how you install it.

Hang tight… support is experiencing an increase in volume with the updates

3 Likes

Maybe that’s why a beta testing group should be created? Just saying.

6 Likes