Hub shows up on app but not on web page

Hi all, couple of weeks ago, when I installed the hub, the app saw the hub as did the web page panel. ( But haven’t used it since I don’t have any devices yet, but it now doesn’t show on the web page. Still fine on the app. Says "You don’t have any hubs yet. Please use the SmartThings mobile app to claim your hub."
Is there a ‘refresh’ on the app to update the web?


Found a solution. Apparently you have to go to ‘Location’, click on your ‘Home’, log in again, and the hub shows up. Not sure why it doesn’t show up in the first time I logged in?



It means you are not initially logging into the correct URL for your shard.

I just wanted to say thanks for posting your own solution. I was having the exact same issue, and following this helped. Why on earth that was necessary when I’m already logged in is beyond me.


This worked!

Thank you for your post and finding. I just bought a ST hub and also got this issue.
Glad I found this post. I went to FAQ but did not see it. Asked Support and they said they will get back to me in 1-2 days?!?@#!

Well… Thank me, please.

My FAQ has had over 7 thousand views… and only 6 likes? :laughing: :crying_cat_face:

1 Like

That’s pretty funny and a huge offset! Maybe they are just too exhausted after reading. What’s even funnier is most of those folks that Liked are community members that probably didn’t need it. I added a Like to get the count up to 7. I’m sure the 6,993 people are still grateful for your FAQ :grinning:

1 Like

It really works! I can now see my hub too! Just click on home, log out and log in!

1 Like

Thanks for that you saved me.

WHY do Samsung have to screw with things without documenting it properly ??
I just tried logging in to IDE & couldn’t coz it said wrong email & password… crap. Had to re-set password back to original. Then no devices listed.

Sorted now, but talk about stressful !!!

I am honestly lost. I have been trying to get my hub to work after having to replace my phone. I can’t get my hub to link. It asks for some kind of code to enter to connect a hub…

Thank you so much!!! One more question. In the Smartthings Classic, one had to define the phone as a presence sensor. I could actually see it in ‘things’ showing if I am present or away. How do I have the New Smartthings do that?