Hub not showing up on graph.api.smartthings.com

Good point, I will update and say the fast hub does not have GitHub enabled and the slow hub has 15 “Update From Repo” GitHub connects.

1 Like

Damn I have 20+ maybe.

I’m having the exact problem as the original post. I can’t see my hub. I’ve tried the location thing and it didn’t help. What can I do? This seems overly complicated. I’ve also seen multiple posts on this with no response/help. Please help!!!

Please use this URL to log into SmartThings via the WEB IDE. This will automatically connect you with the correct “Shard” that your hub is hosted on.

https://account.smartthings.com

2 Likes

That is the link I have been using. I just tried again. It still does not see my hub. Any other suggestions on things to try?

Are you in the USA or elsewhere?

Try the older manual method

1 Like

I’m in the USA. Not sure what the manual method is? This is the link I’m going to when logging in: https://graph.api.smartthings.com/ When I log in there – no hub. I go to my location and see something like the below:
Locations
Name Events Notifications Devices Installed SmartApps
Wes Silotti events notifications devices smartapps

But, my device is not showing up nor is my hub. I can see both just fine on the Smartthings app on my phone. (I’m logging in to https://graph.api.smartthings.com/ from my laptop but get the same results of no devices when logging onto the above link with my phone.)

Do NOT use https://graph.api.smartthings.com to log into the ST IDE. That is only for users who happen to have their account running on that Shard. The thread I posted included all of the NA shards individual links (i.e. the manual method of figuring out which server your account is really on.)

The new way of logging in, via https://account.smartthings.com, should automatically take you to the correct shard.

If you recently created your SmartThings account, you probably have a “Samsung Account” and should select that option (if presented) as such.

Samsung/SmartThings has recently started to have all new users create a “Samsung Account” to use SmartThings, whereas old users still have “SmartThings Accounts” from back before Samsung bought SmartThings. This may be causing some confusion as well.

2 Likes

Dan, your my hero! I selected “Samsung Account” rather than Smartthings Account and it worked. I did have to select location and the “hub” and it was there. I’m trying to figure this all out and I’m sure I’ll have more questions to follow but your assistance in getting me over this hurdle is appreciated!

2 Likes

Glad to hear that it is working for you now. Have fun with the custom code! It really is the best part about SmartThings, IMHO (and this Community, of course!)

Dan’s suggestion worked for me as well. Seems very counter intuitive to go that route but it is correct.

Just my luck, it didn’t work for me. I have no idea what happened. It’s been months since I’ve logged in but now I see no Hub. My location shows up but no hub and no devices. This whole mess is rather frustrating and I have a significant number of years of systems and application development under my belt. You’re asked to choose from either of 2 accounts to log in with then you’re asked again which of 2 accounts you wish to log in with only to be finally presented with an actual login screen with both a username and password field. And if that doesn’t get your blood boiling, they hit you with one more log in screen that says “One Account, Enjoy All!” Well I’m definitely not enjoying this one bit. 4 screens just to log in??? Seems very excessive. Then under hubs (where the hub I added a long time ago should be) it says I should use the app to claim my hub yet I see nowhere in this app to do such a thing. Is calling them up my only option at this point?

When did you purchase/create an account with the SmartThings Hub? If was before May it was created using a SmartThings account. If it was after, then you created your account with Samsung. I ask this because you joined community in September.

They are in the process of converting everyone over who had a previously created ST account.

Anyway, if you only created one account, then only one of the links will work.

You need to log off any and all browsers that you are logged in with whatever account you saw no location or hub on, then goto

https://account.smartthings.com

And log in from there. It will redirect you to the appropriate shard (ie: graph.api, graph-na02-useast01, etc…) that your account was created to use.

Your location and hub are not lost.

If you can’t figure it out, then simply give support a call.

2 Likes

I’m fairly certain it was before May. I remember there never being the option to sign in with other accounts. But I’ve already tried what you suggested and even removed my stored credentials just to be sure (even though I created both the same). I can see a location in both but no hub or devices in either. Selecting Samsung account, I do not get a 4th login screen like I do under Smartthings account but on that 4th login. The only thing I can think of is that somehow my accounts are in some kind of awkward state and they’re getting crossed, thus logging me into the wrong one every time. I’ll just give them a call. Thanks though.

1 Like

What happens when you login to the SmartThings Mobile app?

“This” definitely happens. An ActionTiles customer reported it… But a few days later said it all cleared or synced up.

Hopefully Support can confirm there’s no serious issue or hurry the process along…

1 Like

@WB70 The mobile app works just fine.

@tgauchat This is actually good news then… that I’m not an isolated case anyway. Searching for this issue seems to bring up a great many hits; frustrating that they are dealing with it in this way but I’m sure there’s some sort of logic behind it. I’m going to try and give them a call today if I get some free time.

2 Likes

Ok. You will be just fine then. If you are able to see all of your devices from the app, I guarantee support will be able to get you synced back up from the IDE side.

1 Like

I haven’t read through all of this thread but have you tried the following.
Log in at https://graph.api.smartthings.com/
Then click on My Locations at the top and then on HOME in the next screen.
This should take you to the shard that your account is on.
Make a note of the new address and use this for future logons to your hub.

Like I said, not sure if you have tried this but if not, give it a try.

It looks like ST is messing with a lot of this in their consolidation effort. In the past, I have never been able to use this to allow me to redirect and have always used the other page and would be directed to my shard that was useastxx. Now if I click in the link above and it redirects, it keeps me directly on the main shard, no more na02-useast01.

That’s pretty bizarre. Have a feeling this is all part of the account migration and storage of everyone and trying to consolidate everyone into the same place, which comes at a pain for some folks.

Thanks for posting. That might fix the few above having issues. Enlightening.

1 Like