How to test signal strength of a device?

I just got a Aeotec Smart Switch 6. Plugs into the wall and when i’m within a few feet, works perfect. When I bring it upstairs to the second floor, I can no longer issue an on/off. So It seems to be a signal issue right?
Well, siting right beside it is a Smart Things motion sensor that works perfectly.

Is there a difference in the “powerfull-ness” of these devices?
I’ve attempt a network repair but that does nothing.

Is there any way to see the signal strength?

This device is zwave

This device is zigbee


Depending on your setup all of this is normal. zwave and zigbee devices use to separate frequencies, so depending on your environment one my work better than the other. As far as getting the signal strength from your devices, only a few zigbee devices support this with ST. IDK of any zwave devices that report signal strength to ST. Ultimately the devicetype handles what devices report what, so it not like it can’t be added if you chose.

If you have other zwave devices in your house, you can try moving the Smart Switch to its final location, and issuing a zwave mesh repair command to your hub.

Here is some information about how to repair your mesh after you’ve moved the switch:

Here is some information about zwave signal strength:

The short answer is that adding more mains powered zwave devices to your system can help get signal to far away corners of your house. Battery powered devices do not act as repeaters.

Thank you all for the insight. Indeed I had mistake which devices were zigbee and which were zwave. I was just suprirsed by a battery powered zigbee could make it but the mains powered z-wave couldn’t.

The actual distance is only about 50 feet (14 meters or so) but it has to go through a concrete (with reinforced steel) and a ceiling with the same.

I tried moving it closer, so that it’s basically directly above the hub but the same issue exists (with both) of the same plug type.

Should I assume that I can expect to atleast go through one wall with z-wave otherwise I may have to scratch this idea as I cannot put 4-5 plugs just to get to the spot I want.

Going to try and pair with my V1 hub and see if it’s any better

These things are supposed to be z-wave plus.
I tried about 10 times yesterday to do a repair just with the Smart Things V2 hub and the Aeotec Smart Switch 6 in the same room and always received the same message. Also tried with two sensors, one about 10 feet, the other about 25 feet (just out of normal distance) and still the same.
I’m not sure if it has something to do with secure/unsecure mode but I’ve opened a case with Smartthings Support and also Aeotec.

Frankly I’m about 1 more day to returning all of the Smart Switch 6 sensors that I just purchased (3 at $52 each)