How to fix relays?

Does anyone know what I need to do to get my relays working again?
I haven’t touched any of my configuration in 3+ years, other than installing the new SmartThings app when I was forced to. Otherwise, it’s been left alone.
I have a couple of these relays:

They’re running with this Device Handler Monoprice 11990 Dual Relay Adapter - GitHub - justintime/ST-Monoprice-Dual-Relay-Module: SmartThings device type and SmartApp for the Monoprice 11990 Dual Relay Adapter

The relays have stopped responding to any action from the SmartThings App, Alexa Devices, and my ActionTiles panel.
Has anyone else ran into this and can help point me in the right direction?

1 Like

We’re you using them with any SmartApps? All but 2 groovy SmartApps were shut down last week and that would be a problem.

Another possibility is that they may have been migrated over to an Edge Driver from the old Groovy DTH you were using. You can check by opening up the device tile, click on 3 dots, and see if Driver is a choice. If Driver is listed it was migrated over to an Edge Driver. And that driver may not work properly with your relay.

1 Like

Yes, my pool lights are controlled with the same relay and they stopped working. I tried removing the device and then re adding. It set it up with the multi channel controlled, but no joy. Didn’t work.

I set the driver to Inovelli 2 channel smartplug MCD. It appears to work.

Not sure how I will do that when they shut down the dev site. But it appears to work, and allow control through smart lighting.

Hi Dave, would you mind sharing how did you do it.? Man I haven’t gotten into the IDE in so long that I completely forgot how to deal with this stuff. I have about 6 old monoprice 11990 dual relay switch around the house, which I’m sure is the same as the Vision, with the same device handler as OP. All have been working fine, until a few weeks ago all the relays went rouge lol…appreciate the help.

This worked for me

Click on a device
Click Edit at the bottom
Device Type drop down - change it to Zooz Zen52

let see if i’m doing it right.

My Devices
Search relay under “display name”
Select device
click on Edit
Under “type” select Zooz Zen52 dual relay switch
Click update

Do I need to update the device handler or still the one from “justintime” is good.

thanks in advance

The steps above is all I did and mine started working again.

The groovy platform and all DTH devices are now dead or will be dead soon, those connections have been superseded by edge drivers

Please read the announcement section of the forum for details

It is probable you will get your devices running again but you will need edge drivers that match your devices, there is a community request driver thread where you can ask a community member to add your devices to an edge driver

Please have a good read around the forum, there is plenty of info to help

I remember to have read something about it from the smartthings app notification a few months ago. I have a mix of devices around my house, but those dual relay are key for some lights we use daily.

Awesome, I was able to get one online, beside your steps, which I really appreciate, I had to change the devices name to the one already assigned to the old virtual switches, then select the new devices for automation. I got at least the dining light back in business. =D

I went to and signed on.

Go to Locations, then devices. Click on the Device for the relay. The edit, You’ll see a dropdown for Type *

Select Inovelli 2-Channel Smart plug MCD, Then hit Update.

You will have to change your routines, as it doesn’t use the Simulated switches, but that explicit support for Multi Channel switches. I found that Smart Lighting and other Automations didn’t work, but New Routines worked great.