How does SmartThings pair devices?


(Brian) #1

Ok - general question. I’ve had a few switches that I just could never get to pair correctly. Given they are switches they are not close to the hub, and all directions say to be close to the hub. Every other device has paired flawlessly. These just wouldn’t. Tried everything. Finally tonight I moved the hub from the basement to my bathroom (thanks Google Wifi for adding a Cat5 out on your box) and low and behold it paired perfectly.

So - my question. Can ZWave/Zigbee devices not pair through the mesh network? Do they first pair directly to the hub then become active on the mesh? I have two active switches 10’ from the two that would never pair and they worked great, though paired 3 levels away from the hub.


#2

It varies by the particular device. The general answer is that every unsecured zwave or zigbee device should pair when it’s within one hop of the hub.

Devices which require secure pairing, including zwave locks, May need to be “whisper distance” which is within 4 or 5 feet when the encryption code is exchanged.

The newest zwave devices, Z wave plus, if they do not require secure pairing, can probably be paired a couple of hops away.

But let’s say this isn’t an unsecured Z wave plus device, and it is a mains powered zwave light switch. You have several choices for how to get it paired.

A) wire it up to A power source which is close to the hub, pair it, then move it to its desired location, install it, and then run a Z wave repair utility to fix the neighbor tables. ( this method is called “bench Pairing.”)

B) install it in its desired location, put the hub on a really long ethernet cable, move the hub near the device, pair it, take the hub back to its usual location, run a Z wave repair utility to fix the neighbor tables.

C) (my favorite) install the switch in its desired location, use a minimote to pair it, and you’re done. :sunglasses: You don’t need to run the repair utility because the neighbor tables will already be correct. But you do have to own a minimote and this will probably not work if secure pairing is required.

image

I hope that answered the question. :sunglasses: See the following FAQ for more information. Read post 11 first and then go back and read the whole thread.

And here’s how to run the repair utility: