How do you *easily* restore connectivity to GE Link bulbs after power outage?


#1

My power went out yesterday for about 1/2 a second and when it came back on, I had no way of turning off my lights (literally…there’s no switch). The only way I could get them to respond again was to delete them from SmartThings, reset them (turn them on/off three times with three second delay as described in the manual) and re-add them. Talk about a PITA; In order to delete them from the system, I needed to remove them from every single place where they exist, including Hello, Home actions, SmartApps, Virtual Devices, Button Controllers, etc and then had to add them all back once they worked again. Has anyone else come across a similar problem (I searched and found issues with Hue bulbs, but nothing specific to GE Link) and come up with a solution?


#2

@reickler, are you using ST’s default device type, or the custom one developed here?:

Updated : GE Link Bulbs - FINALLY getting ON status after manually turning on!

We had power drop a few times with the ice/snowstorm here in the Carolinas, and even though I could use a physical switch, I just used the phone app to turn them off.

I also use the Pollster app (with the custom device type) for all my GE bulbs. Helps a lot!


#3

Zigbee devices, including smart bulbs, are supposed to be OK after a power outage. So the first thing would be to unplug the hub for 15 minutes, then turn it back on, then let the network rebuild the routing table. After about 30 minutes depending on the number of devices everything should be working again.

It’s inconvenient, but a lot easier than re pairing each bulb.


#4

It’s the default device type. I’ll try the pollster app, but it’s not that it’s not seeing the correct state, the device simply doesn’t respond to commands and shows “Inactive” in the web interface.


(Greg) #5

I had this issue happen to me several times, most recently I fixed it today. Over the weekend my ST went bonkers. I couldn’t even turn off my GE links. So I ended up turning them off at the switch. today I had time to play with it to try to fix it. Reboot the hub etc. Nothing. GE links didn’t work at all from the ST app. I reset them by turning off/on until they dim and blink. Then I pressed + on the ST app. The GE links then blinked as if they were paired for the first time. However, ST recognized them as their correct bulb and I didn’t have to do anything else!

So while it’s not fun that they lose their connection. They seemed to reconnect with minimal effort.


#6

I saw (and have used) the z-wave network rebuild but didn’t see anything similar for zigbee. I did try rebooting the hub, but didn’t leave it powered off for any period of time; I’ll give that a try next time if that’s what it takes to rebuild the zigbee routes/network.

I also decided to drop $60 for a smartthings outlet hoping maybe it will extend the zigbee range incase the bulbs are bordering on being too far away or something along those lines.

Thanks for the input.


#7

The unfortunate part, is that I have multiple lights on that circuit that I wanted to work separate from each other. To achieve that, shorted the wires that went to the switch and put a battery powered Cooper RF9500 there instead. Literally the only way to turn them on and off is with zigbee, and that’s another pain point in that I need to take the bulbs out and put them in a lamp to reset them). In retrospect, there’s probably a better way, but when it worked it worked well. Thanks for the input.


#8

Zigbee doesn’t need a specific repair utility, it always repairs the network if the hub is lost for at least 15 minutes. (That’s good and bad compared to zwave-- there’s no way to fool a zigbee network into using particular routings the way you can with zwave.)

Adding a repeater can only help so hopefully it’s within your budget. :blush:


#9

@reickler, do you have the latest zigbee firmware on your hub? It should be “zigbeeFirmware: 1.5.4”, if not please email support asking to get the update.

Pollster doesn’t work with ST’s default device type because Polling is not a configured capability. It’s only available and works with the custom device type in the link above.

I do recommend the custom device type as it will help with getting the right status, and paired with Pollster, it’s even better. I have 8 of these bulbs working flawlessly for a long time set up this way.


#10

Good read. I noticed “For ZigBee devices, things have to get worse before they get better. The device has to completely lose communication with its parent (the Hub in the example above) for it to look for a new, better parent. Fortunately, this is easy to do: turn off the Hub.” which is inline with what was said about powering down the hub for a while.

@johnconstantelo, I do have the latest firmware. I’ll surely check out the custom device type. Sounds like it’ll address some of the other annoyances I’ve come across.


(Eric) #11

Great link, April, thanks.

Also pretty psyched I added it to my device types, and updated my devices, all from 37,000 in the air. Something cool about modding your house from the sky.


(Ron S) #12

@ehoffman73 just curious… which airlines? Haven’t taken a flight due to heart condition the past few months (go figure…) but are phones allowed now?


#13

I was just on Southwest Airlines and surfed the Web and Smartthing’d while in the air to Atlanta. Pretty cool. WiFi costs were reasonable, so I splurged.


(April Wong) #14

yes. Most will allow it on airplane mode :slight_smile: for phones.

Tmobile even allow texting with flightgogo .


(Eric) #15

I modified via the IDE via the web browser on my laptop. Swapped out the device types. Was pretty fun. (oh, and United Airlines)


(Tristan Needham) #16

Thank you! I had all 13 of my GE bulbs lose their connection after an unusual (flickering) power outage, and although it took some time, it was great not to have to completely start from scratch. Pressing + in the ST app did indeed rejoin each bulb with its previous name, room, and automation intact. WHEW!


#17

(Martin P) #18

The technique for resetting above (3 second on/off interval 5x) didn’t work for me (perhaps different firmware). I found a youtube video for a different model but technique worked for me. Turn on for 5-8 seconds, turn off. Turn on and off rapidly (<3 secs) 3 times, then turn on for 5-8 seconds and turn off for 1-2 seconds. Turn on. Bulb dims for a few seconds, goes bright and then after 10-15 seconds, enters pairing mode as indicated by flashing. Hit + on ST app to add.