How do I wire 3-way using 2 GE 45857GE zigbee masters, no add-on?

I have 2 GE In-Wall Smart Dimmers (45857GE) and I want to use them both in a 3-way setup. I don’t have an add-on switch. I’ve read this is possible here, but not sure how to do the wiring. If either dimmer is turned on/off, I want the other dimmer to reflect the same status in SmartThings. My current 3-way wiring looks like this.

Do I need to connect the travel wire?

How do I wire the slave dimmer?


curious why you wouldn’t just use the add-on?

the post that you linked to is for a different brand and model. Remember the first rule of home automation: “the model number matters.” So the fact that it can be done with A zooz doesn’t necessarily mean it can be done with another brand.

In any case, You don’t use the traveler wire. And you don’t have the second master, the one in the auxiliary position, wired to the light, either. You just put it in so it has power and then you use it as a virtual three-way. The auxiliary will send a message to the hub and the hub will send a message to the Master. You can set this up using the “mirror” feature in smartlighting.

To be honest, I’m not sure if that wiring can be done with the GE model, but hopefully someone else will come along who will know.

Also note that if you do set it up this way, it will only be able to operate when the smartthings hub is operating.

One of the reasons that people will select the GE switches is because when you use the master and the normal auxiliary switch you do use a physical traveler wire and they will continue to work just fine even if your hub fails together. But a virtual three-way requires the hub to be working. So that’s just something to be aware of if you choose to use two masters.


Your 3-way wiring is wrong and really don’t know why it’s working now…

In normal 3-way wiring:

Left side:
The source wire (coming into the box) Black should be going to top left contact. White goes to light.

Black, Red and White wire connecting boxes:

Red and white goes to traveler connections on right side of both switches.

Right side:
Black goes to top left contact. This goes back to the left side and connects to light.

For your purpose:

From source:

Tie the Black and White to both Smart Switches. You don’t need the red. The switch on the left will control the light. Wire accordingly with white to the switch and light and black to the line and black to the light for load. The switch on the right will just be powered so you can use it programmatically for whatever in SmartThings for rules. (Mirror left Switch)

However, probably best to just by the compatible GE add on. You can get them for $15 all day…


I bought these dimmers on clearance, paid only $10 ea, and they didn’t have any add-on switches marked down.

Is it possible to somehow configure one of the dimmers to act like an add-on, and wire it as such?


I don’t believe so with that model, but ask the manufacturer.

They also have an 800 number for tech support

(GE licenses their name to Jasco for their smart switches)

really don’t know why it’s working now…

Since wire color is not mandated by code in most places in the US, it’s always possible that the wiring is correct, but the wire colors are “wrong” and that’s why it’s working. There’s no way to know without mapping the circuit. :wink:

1 Like

Wire like I described and program like @JDRoberts described.

You will just have 2 Smart Switches controlling the same light. Will work though.


Ok, I got it working. Thanks for your help.

You were right about my wiring, that image in my original post was not right. Once I figured that out, I was able to wire both smart dimmers like you said, then I setup two mirror automations using the SmartLighting app. It’s working exactly the way I want. I guess the only problem I may run into is if my hub goes offline then each dimmer will just work independently, and not be able to stay in sync with each other, but I can live with that.

1 Like

If Hub goes offline then the left switch will work like a dumb dimmer, the right side will be useless as it doesn’t have a load.

I’m glad you got it working! This community is awesome!

1 Like

It may still work when the hub is offline. Don’t the devices run local? And smart lighting runs local? You can check the automation in the ide to see if it’s marked local or cloud.

1 Like

Hot dog! You are absolutely correct.

“Hub offline” is not the same as “hub not working.“ :wink:

As long as the smartthings hub is still working, then, yes, smart lighting can run locally. But my earlier reference was to the fact that if using the GE add on switch, both switches will continue to work even if you remove the hub altogether (because of the physical traveler wire, which cannot be used between two masters).

But if using two masters in a “virtual three-way“ set up, the hub will be required.

1 Like

If you are saying that dimming from one to the other switch works in real time than these zigbee light switch dimmers do something that almost none of the zwave and zwave plus dimmers do. Almost none of the zwave plus dimmers send dim status back to the hub in real time.

They only send dim level back to hub once they fully dim up or dim down.

Using zwave associations some of the zwave plus switch dimmers will send dim status to each other in real time but not back to the hub.

I may have to get some zigbee dimmers to try.

I need to clarify how I did my wiring because it’s not exactly as @rontalley instructed. In the slave box I found a hot wire from another switch and used that for my Line. So both dimmers have their own separate power, but share the same light.

The sync between the dimmers and the app is near real-time for sure. When I manually turn on one dimmer, the blue indicator light immediately goes off on both. Also, both devices in the SmartThings (legacy) app update immediately. Same when manually adjust dimming, the device status in the app updates the percentage real-time.

One thing that’s a little wonky is if I hold increase/decrease down too long on either dimmer, the lights start to blink as they adjust and it takes a few seconds before they settle to the new dim setting.

By the way, I contacted Jasco support about configuring the dimmer as an add-on, but they said it’s not possible.

I’m happy with this setup and I really appreciate everyone’s help in getting it working.