How do I change the length of delay on "Z-Wave Virtual Momentary Contact Switch"

I basically just need a momentary switch that stays on for like 5 seconds. Can someone point me in the right direction?
I’m using a MIMOlite if that is relevant.
Thank you!

Have you tried “Z-Wave Virtual Momentary Contract Switch”?

I think that will work for my purposes. I’ll try CORE for a few other things later.
Can someone help me figure out where in the code the length of the delay is?

 *  Copyright 2015 SmartThings
 *  Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except
 *  in compliance with the License. You may obtain a copy of the License at:
 *  Unless required by applicable law or agreed to in writing, software distributed under the License is distributed
 *  on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License
 *  for the specific language governing permissions and limitations under the License.
 *  SmartSense Virtual Momentary Contact Switch
 *  Author: SmartThings
 *  Date: 2013-03-07
metadata {
	definition (name: "Z-Wave Virtual Momentary Contact Switch", namespace: "smartthings", author: "SmartThings") {
		capability "Actuator"
		capability "Switch"
		capability "Refresh"
		capability "Momentary"
		capability "Sensor"
		capability "Relay Switch"

	// simulator metadata
	simulator {
		status "on":  "command: 2003, payload: FF"
		status "off": "command: 2003, payload: 00"

		// reply messages
		reply "2001FF,2502,delay 2000,200100,2502": "command: 2503, payload: FF"
		reply "200100,2502": "command: 2503, payload: 00"

	// tile definitions
	tiles {
		standardTile("switch", "device.switch", width: 2, height: 2, canChangeIcon: true) {
			state "off", label: '${name}', action: "momentary.push", icon: "", backgroundColor: "#ffffff"
			state "on", label: '${name}', action: "", icon: "st.switches.switch.on", backgroundColor: "#79b821"
		standardTile("refresh", "device.switch", inactiveLabel: false, decoration: "flat") {
			state "default", label:'', action:"refresh.refresh", icon:"st.secondary.refresh"

		main "switch"

def parse(String description) {
	def result = null
	def cmd = zwave.parse(description, [0x20: 1])
	if (cmd) {
		result = createEvent(zwaveEvent(cmd))
	log.debug "Parse returned ${result?.descriptionText}"
	return result

def zwaveEvent(physicalgraph.zwave.commands.basicv1.BasicReport cmd) {
	[name: "switch", value: cmd.value ? "on" : "off", type: "physical"]

def zwaveEvent(physicalgraph.zwave.commands.switchbinaryv1.SwitchBinaryReport cmd) {
	[name: "switch", value: cmd.value ? "on" : "off", type: "digital"]

def zwaveEvent(physicalgraph.zwave.commands.manufacturerspecificv2.ManufacturerSpecificReport cmd) {
	if (state.manufacturer != cmd.manufacturerName) {
		updateDataValue("manufacturer", cmd.manufacturerName)

	final relays = [
	    [manufacturerId:0x0113, productTypeId: 0x5246, productId: 0x3133, productName: "Evolve LFM-20"],
		[manufacturerId:0x5254, productTypeId: 0x8000, productId: 0x0002, productName: "Remotec ZFM-80"]

	def productName  = null
	for (it in relays) {
		if (it.manufacturerId == cmd.manufacturerId && it.productTypeId == cmd.productTypeId && it.productId == cmd.productId) {
			productName = it.productName

	if (productName) {
		log.debug "Relay found: $productName"
		updateDataValue("productName", productName)
	[name: "manufacturer", value: cmd.manufacturerName]

def zwaveEvent(physicalgraph.zwave.Command cmd) {
	// Handles all Z-Wave commands we aren't interested in

def push() {
	def cmds = [
		zwave.basicV1.basicSet(value: 0xFF).format(),
		"delay 2000",
		zwave.basicV1.basicSet(value: 0x00).format(),

def on() {

def off() {
		zwave.basicV1.basicSet(value: 0x00).format(),

def refresh() {

I tried changing that number to 5000, and 10000. Didn’t have any effect.

“delay 2000” is the variable to change.
My bad. I had the wrong device handler assigned to the relay I’m trying to control.

This is a silly question, but where do I go to edit the “Z-wave virtual momentary contact switch”? I’ve looked on the IDE under my devices (even under edit on the switch itself), my smartapps, and my device handlers, and couldn’t find anything.

Due to delays in cloud processing, I would change to
turn on z wave switch
if z wave switch is on
wait 5 seconds
turn off z wave switch

Mine are both equal :joy: