Honeywell thermostat not responding to ST

I have a Honeywell Lyric T6 Pro that I added to my SmartThings hub. But I’m finding out that ST is not actually doing anything now. I can manually control it with ST, but the automations don’t seem to be working, though it has before.

I like the keep the house at 74, and I set up two automations in ST, one that when the outside temp is 74 or above, it turns on the AC, and one that when it gets down to 60 outside, it turns on the heat. The house is able to keep it warm enough in that gap, and I can open the windows.

The other night it got down into the 50’s, and I noticed the house seemed a bit cool. Sure enough, it was 72 inside, and the thermostat was still on AC. But, what’s odd is I had originally set it up to kick on the heat at 65 outside, and had set it to be 76 inside. It got to 65 out and kicked on the heat, and I found that I didn’t need the heater on quite yet, and 74 would be just fine, so I adjusted it. It did switch back to AC the next day when it got over 74. But now, ST just doesn’t seem to be giving the order to switch over.

The mesh may be losing packets. Why not set it to Auto and let it handle the switch over?

1 Like

I don’t understand at all what you’re asking. What is mesh? And set what to auto?

The mesh is the Z-Wave mesh that the thermostat uses to communicate with the hub. If the mesh is weak it can lose packets and if the SmartApp isn’t aware that it’s losing packets then assume that the command succeeded and wont’ sent it again. Some SmartApps are specifically designed to have a closed loop and verify that commands aren’t lost the in the mesh, such as [RELEASE] Mode Based Thermostat - Control Multiple Thermostats Temperature / Remote Temperature Sensors when Changing Modes and [RELEASE] 5-2 Day Programmable Thermostat Scheduler (Weekday, Weekend) with Remote Temperature Sensor for each Schedule

The auto mode is the auto changeover option. The Honeywell T6 thermostat supports Auto Changeover. This makes the thermostat switch between Heat and Cool modes automatically so you don’t need to do it manually or through an app. It’s disabled by default but you can use a enhanced thermostat device handler which support this model to enable Auto change over and then it should automatically switch between heating and cooling based on the setpoints: [RELEASE] Enhanced Z-Wave Thermostat Device Handler with Z-Wave Plus

You’re right about the auto changeover, and I guess in my situation, that would be the way to go. But I’m still trying to figure out the original question for tow reasons. First, I’m helping someone set up their smart home system, and the situation there is that if two of them are home, then they tend to want the temperature set one way, but if the kids are home (divorced couple, kids are there part time) then it would keep the house a bit warmer.

But aside from that, it’s also the fact that this is a function in ST that is not working properly.

I just ripped out all 4 of my Honeywell Lyrics after a year of poor user experience.

  1. Native app losing thermostats constantly (and no it’s not my ubiquiti commercial grade wireless internet). I’ve tweeted them at least 30 times in a year. They always respond and press a button to refresh my signal or whatever but it was a constant issue and if the device isn’t connected, no automations can run.

  2. Thermostats in the new ST app don’t refresh regularly, so they constantly appear offline until you refresh them.

  3. Because of the above mentioned issue, you can’t run scenes for Thermostats in ST without manually “waking the thermostat” first which defeats the purpose of having a 1 click scene if you have to wake the thermostats up before it will successfully communicate the routine.

  4. You can forget any kind of frequent automation in ST. It will fail all or parts of the automation every time. Automations based on motion sensors/window contact sensors proved to be just too much to accurately keep the thermostats in the correct modes at least 75% of the time.

If I wanted just straight scheduling, I could get that in the native app. I switched all 4 to ecobee 2 weeks ago and the user experience has been much better. When I press to play a scene in ST to turn all thermostats off, switch them all to fan only, or switch them back to Auto ; automations fire every single time. Automations based on motion/window contact sensors are much more reliable.

I had given up on this for a while, and now I’m back to it, and it looks like I’ve gotten it to work, so far. I deleted the thermostat from ST, and started over, and when I added it again, I found that under brands, there is Honeywell, and Honeywell Home. The app that the thermostat uses normally is Honeywell Home, so I selected that in ST, and it works. I think before I had selected Honeywell, and while I found the thermostat listed, something must have gotten lost in translation. When I did Home, it found the thermostat right off.

Right now, I’ve been able to verify that it works for turning on the heat. Tomorrow it’s supposed to get hot enough out that it should switch over to AC according to the automation I have set up.

1 Like

Would not the thermostat turn on the A/C based on internal thermostat logic, if you select “Auto switch over”? Why an Automation?
I also did play with ST on my HT9320 and created an Automation, with my phone’s app. Switch over to Aux Heating when outdoor temp and humidity are prone to deep freeze the coil.

Weather changed before I can really test it.

My TH9320 doesn’t loose connection, and doesn’t need to be waken up. It’s connected over WiFi, not other kind of networks. TCC app on phone, appears in ST app too.

Apparently, my thermostat doesn’t have auto changeover. At least, not in any option I can find anywhere on it or on the phone app.

Mine has in setup the option to select from “Auto Changeover” from “on” to “off” - that is “Manual” change over.
If I select “Manual” then, on the main screen, and in the app, the “Auto” will be hidden.

Check this, from your installation manual:

I finally found it. The way the text shows up, I went right past it. I found it using those ISU numbers.