Home Assistant can now control Smartthings


(Different Computers. So happy with Indigo.) #1

I’m NOT the coder, and i’m not associated with the project. I have no experience with it either.

But I really hope that HASS might be able to treat my hub like a dumb device, using the hub as a gateway to my existing Z-wave and (most importantly) Zigbee devices, allowing LOCAL PROCESSING at last.


My kingdom for a
#2

Bump. Did someone try this? What exactly is it supposed to do?


(Different Computers. So happy with Indigo.) #3

I have not tried it. But as has been explained to me and as my reading suggests, it allows the ST hub to act as a dumb gateway to your devices, while all rule execution occurs locally via HASS.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #4

Correct… Except that the SmartThings MQTT Bridge SmartApp and Device Type Handler still run in the SmartThings Cloud until these are supported for local execution…


(Andy Hume) #5

I have this working at home on RPi.

I like it for the flexibility of hass and ease of creating dashboards for switch control, etc… But what I think I’m realising is that I wish I could just take SmartThings out of the picture altogether and interface with the zigbee devices directly. The cloud just introduces too much latency and fragility.


(Kevin) #6

How can we tell (or configure) what smart apps run local versus in the ST cloud? What software do you run on RPi?


(Andy Hume) #7

On the RPi I’m running hass, Mosca (MQTT broker), and the smartthings-mqtt-bridge.

Basically as described here: https://home-assistant.io/blog/2016/02/09/smarter-smart-things-with-mqtt-and-home-assistant/

If I understand correctly, this approach will always rely on the cloud because you need to create a SmartApp to pass events to the MQTT broker, and it’s currently not possible to have that app run locally.

So, although this approach gives you access to your ST devices in hass, it doesn’t solve the fundamental reliance on ST’s cloud.


(Kevin) #8

Seeing hass more and more; but it seems like it is really new. I am/was using HomeGenie for a couple years but zwave support/reliability is not what I hoped; so just bought SmartThings hub. Zwave setup, speed and reliability is way better… so far.


#9

Does anyone have communication run both way?

Here’s my setup:
Home Assistant running on a Pi
MQTT and MQTT Bridge running inside a Docker on my NAS

SmartThings actions (lights on/off) reflect on the Home Assistant page but Home Assistant actions don’t reflect in SmartThings and the lights don’t turn on/off.

Is this part related to ST recieving the commands?
MQTT Bridge IP Address:
MQTT Bridge Port: <8080 if you have changed nothing in the previous commands>
MQTT Bridge MAC Address:

If so, I tried both the actual IP and mac address of my NAS as well as the IP and mac address of the Bridge docker.


#10

This is where I am at. I have HA reading everything from SmartThings properly - but do not have HA passing anything to Smartthings it seems. Not sure what is wrong.


(Bdudle1) #11

Did either of you ever figure this out? I’ve got the same issue.


(Andy Newman) #12

You need to make sure you have set your raspberry pi or whatever machines MAC Address in the MQTT device on smartthings in the Device Network id field. take out the : so it looks something like b827eb23f0a1 that should then sort the two way communication problem.


(Bdudle1) #13

The network ID and the mac address are set the same… I mean, i’m fairly certain I must be doing something wrong, but I just have no idea what it is. Here’s a screenshot of my device in the ST IDE:

screenshot

I’m running hass, mqtt, and mqtt-bridge all in docker containers as per the article here.


(Andy Newman) #14

What is it installed on? Raspberry pi or something else, also what operating system and is it in a virtual machine like windows virtual PC?

I am no expert but have in the last week got it all up and running on a raspberry pi 3 on the raspbian OS, so it is still all quite fresh in my mind.

The mac address in your screenshot looks like it is a Microsoft device.


(Bdudle1) #15

home assistant, mqtt, and mqtt-bridge are all running in docker containers on an Ubuntu 16.04 VM with Hyper-V as the host.

home assistant is accurately showing the status of the switch… I just can’t seem the control it from home assistant. So, like someone else said… it seems like ST is just dropping the request to change the status. I appear to have everything setup correctly, but I’m sure it is something simple I didn’t do or messed up. I’m happy to share any config or logs.


(Andy Newman) #16

Just a thought, it might be worth entering your physical MAC address from the host into the device network id instead of the virtual MAC address that the vm will have assigned.

Andy.


(Bdudle1) #17

I’ve now tried my host mac address, the mac address of the docker container, and the mac address of the VM running the docker container. None works :frowning:

Can you verify the format of the mac address? It doesn’t really seem to matter, but I just want to make sure I’m doing it right.


#18

I’m running into the same issue as bdudle1. Has anyone resolved this?


#19

I had this same problem. It was caused by running part of my configuration (MQTT and the MQTT bridge) in a docker container while running Home Assistant in a standalone daemon. After moving MQTT and the bridge to standalone daemons, the problem was fixed. Alternatively, you could probably move Home Assistant to a docker container too.


#20

Can you explain this in more detail? I tried to move HA to a docker container, but still can’t get HA to push to ST.