Hive Connect not Working


Yes use ctrl A and then deleted all the code but still the app wont go, before that I zeroed out all the settings in the app as well… still no good usual cannot remove as in use by another user error. I also have another app that I cant remove and an orphan device so I logged a call with ST to ask them to remove.

decided to ditch Hive but I still need the app to allow the heating and hot water devices to be shown as devices in ST as I use Actiontiles dashboards to display those tiles.

So once ST remove the old stuff I will try a new setup of Hive Connect just for that.

Thank you all for doing the hard work for me! I’ve updated the authentication URL and published to GitHub.

1 Like

Now resolved

Thank you for looking at it but I stil get an error that says Something went wrong please try to reinstall the app. I tried a clean install and that didnt work either. Any ideas?

Worked when I updated IDE but then stopped again. Trying to reenter credentials is giving a 400 error but then seemed to work. I will see if it keeps going this time.

After issues with two different log in errors I’ve deleted and pasted the updated github code (thanks for providing that) … and i can now log in and see the TRVs in the Hive Connect smartapp in ST but only the main thermostat shows up… none of the actual TRVs show up in the ST devices list. Any idea why or how to fix?

Update … I removed all the device handlers and any no longer used apps … one of which was hive related.

Also removed any ifttt and action tiles connections to the hive devices and finally I was able to remove the Hive connect app.
Left it a while then did a fresh install but only used the hot water and heating device handlers and this time it all worked and as for approx 48 hours now.

Reinstated the ifttt and action tiles connections and so far all look s well.

Hopefully nobody else as this problem but if they do try the steps I had to do.

FYI I updated my version of this to now have the new Auth URL (and a bit of code tidy up). thanks

I found that if you remove the group (e.g. room) from each Hive device in the ST API, they then re-appear on the ST devices list in the new ST app and can the be re-assigned rooms. (Thanks to everyone who worked on Hive Integration)

I just had 2FA forced on me when I changed phones and installed the hive app and can’t seem to turn it off. How did you achieve this?
was it Menu > Account > My Details > Two factor authentication as that appears to have been removed :frowning:

I was looking on the hive webpage control panel not my phone, I am an idiot.

1 Like

Am I alone in having lost connectivity between Hive and ST this morning? Authentication error seems to have returned between ST and Hive.



Reading the HomeAssistant forums it seems Hive have moved the API goal posts again

It’s the same for me. Hive in smartthings completely doesn’t work.

Same here … mines stopped again … last time it was the api url … does anyone have the old one so we can try and see if they moved it back ?

My Hive Connect has stopped working HELP

So tried to change back the Hive Connect app to its original settings which was to change the word cognito on line 1253 to global . Didnt work , so not sure what the fix is ?

Anyone have any ideas please ?

See: [RELEASE] - Hive (Connect) V3.2c (British Gas Hive)

( Hive have disabled username and password authentication for the Hive API and instead you must use Hive tokens pasted into the app.)

Yeh a lot of work as gone in to get it working again … see this thread

I’m a complete novice and all the stuff ur talking about seems alien to me. My question is…I have HIVE central heating and want to integrate it into Smart Things app. Can anyone talk me through an “idiots guide” on how to do this…or is it just too complicated. Please help🤷‍♀️