Help with RFXCOM Binding (for Somfy blinds)

Can anyone help me with the RFXCOM binding?
I have a problem using Alexa to give commands to my Somfy blinds.
The binding gets the commands but fails to execute.

Any help would be really appreciated and I will be eternally grateful.

Hi Emre,

I have an RFXCOM linked to my Domoticz Server which then interfaces with SmartThings/Alexa/HomeBridge, is that how you have yours configured or is it straight from ST Hub to RFXCOM?


1 Like

Hi Guy,

Thanks so much for reaching out to me. You know what? i literally just
realized that i posted this in the wrong forum! I wanted to post this in
the OpenHAB forum but ended up in the ST forum :slight_smile: So if you can still help
me, I would be really eternally grateful.

My RFXCOM is directly connected to my OpenHAB server via USB (running on a
Raspi hub i built myself) and connected to Alexa thru the OpenHAB cloud.
Actually its not connected to my SmartThings account at all. So this is
more a problem between the openHAB RFXCOM binding and Alexa.

Alexa sees the RFXCOM and understands my commands and sends them to OpenHAB
RFXCOM binding. But then the binding is somehow not sending the command to
the RFXCOM device. Or perhaps it is sending it but the command does not get
executed. Let me give you an example. When i click the up/down buttons on
the OpenHAB app, the commands are executed and my blinds open/close. But
when i enter a value of say 80% and then click up/down nothing happens. And
i think this is the way Alexa sends a command to the binding, i mean in
numbers (probably 0 or 100) and not a up/down command.

If you say this is nothing to do with ST so you cant help, I’d totally
understand :slight_smile:
Thanks for your time :slight_smile:


Vielen Dank im Voraus.

Mit freundlichen Grüßen
Emre Evinc

1 Like

Hi Emre,

Unfortunately I don’t know OpenHAB, but this information may help - especially around percentage closed/open.

The device handler that I use for SmartThings and the Blinds has the following capabilities:

Open (On)
Closed (Off)
Partially Open/Closed (based on %age after calibrating the blind closing time)

There was once a time when Alexa would understand the term Open and Close, by responding with the relevant command - however, this stopped working about 6 months ago and I now have to use the command ‘Turn On’ and ‘Turn Off’.

If I try and use a %age, Alexa acknowledges the command but the blinds stay put.

So I think the issue you have is that your Device Handler is working on Percentages rather than just open/closed. In Domoticz there are several device types, and I have to pick the one which only gives open and closed.

Not sure if that makes sense, given that I don’t know how this is reflected in OpenHAB but it might help you.


1 Like

Thanks Guy. I tried all sorts of commands, percentage, just numbers, just on/off and many other variations. Alexa understands them and says OK but then nothing happens. I am totally convinced that there is an error with the binding. Anyway, thanks again.

1 Like