Help needed- Fire tablet integration

Hi - Two months ago, I integrated a Fire HD7 & a Fire HD8 tablet with SmartThings & ActionTiles using Gavin Campbell’s DTH and the instructions by @arnb. This went well and I have been evaluating the two tablets which have worked reliably with Fully Kiosk. It took a while to get all the FKB settings where I needed them but it works well.

Having evaluated both tablets I decided to get another two Fire HD8 tablets. I went through the same procedures with these two tablets that I had been through with the first one to remove all the Amazon bloatware and added them to SmartThings using the same DTH in the ST IDE. They show online in the IDE.

However when I go to the ST app they show as offline and I cannot get them to show online. The tablets work and sontrol the devices OK which is strange.

Why would they show as offline in the ST App? Is this one of the SmartThings anomalies I have read about and it takes days for the app to update?

I have rebooted the hub and the tablets as well as shut down and restarted the hub.


Open a ticket with Smartthings support Paul, yes it sure sounds like ‘one of those anomalies’

-Specifically one that’s popped up a few times in the last few weeks.

@garrett.kranz - take a peek.

1 Like

Since this is a custom DTH, you are going to be a little on your own as far as troubleshooting. Best guess I could make is that these are being incorrectly associated to your Hub, and being marked as “Offline” as a result of that, since nothing will mark these as “Online” in the eyes of the Hub.

If you look at the device in the IDE, check the “Hub” section after clicking “Edit” on the device itself. If the Hub is selected, click the empty space instead and save the changes.

I have worked for over a year trying to get one of my HD 8 connected and gave up. The others connected easily. I considered replacing it.

1 Like

Thanks Garrett. Itried as you suggested and I get an error ‘Access Denied We’re sorry, but you are not authorized to perform the requested operation’.

I also tried deleting the device and re-creating it but the result is the same. I have five tablets of various types but only the Fire_HD8_Kitchen tablet shows as online in the app. I have also tried the app running on the phone and an iPad with the same results.

Am I correct in thinking that only one DTH is needed? I am thinking about recreating the DTH five times and having one DTH per device to see if that will resolve the issue.

Where do these devices ultimately get created? Via the IDE, the App, elsewhere? I’ve seen plenty of custom stuff in my time, but I can’t say I’ve ever worked on something like this. They are being associated to the Hub, so my question then becomes why? If it’s automatic as part of the DTH then that may have worked better pre-LDW (Local Device Watch) which is in use by all V2/V3/ST WiFi/SCH Hubs at this point.

I’ve never heard of this being necessary. I don’t think this would help.

Thanks for the response. The devices were created in the IDE using a custom DTH for the Fully Kiosk Browser. The instructions were posted here by @arnb
Here is a link: [RELEASE] Fully Kiosk Browser Controller (DTH)