Help me with Aeotec by Aeon Labs DSC14104 Micro Motor Controller

Please, is someone able to help me with Aeotec by Aeon Labs DSC14104 Micro Motor Controller and the new app?
The classic version dosen’t work and I can’t control blinds with the new version. I’m quite desperate.
Thank you for the help

Are you using a custom device handler? If so do you have the link to it so I can take a look?


Hi Tim! I’m using this configuration but it doesn’t work with new smartthings app

Have you tried this one?

1 Like

Thanks! Finally I can do something, but I still have a problem that I can’t solve: the commands are reversed.
The “open” button closes the shutter and the “close” button opens it. Can you tell me how I can solve it? Thanks for the help

Good, glad it works.

Reverse should be an easy fix since there is an option in settings. From the device, click the 3 dots at the top right to get the sub menu. Then click settings. Then toggle the setting to reverse direction.



OMG!! I did it! Thanks! Thanks so much for the help! I’m so happy!


1 Like

Hi, I need your help.
Until yesterday the devices worked very well, the up, down and pause controls never gave me problems, until this morning.
The pause key no longer responds, the shutter goes down instead of stopping and I cannot find a solution. At the moment I can only open - close the shutters completely without being able to stop them halfway for example. Even in programmed automations, instead of stopping, the pause command reverses the motor in the closing command (and vice versa).

I tried to rewrite the code in my handler devices and two devices have returned to work correctly, one instead no longer responds to any command, the shutter no longer goes up or down and does not respond even from the wall controls, it is completely blocked . Ideas and suggestions on what I can do to get it back to work (at least manually)?

It’s odd that thet all just stopped working.

I would temporarily assign all devices to another stock device handler, like zwave switch generic. Then, totally delete the custom handler, add it back from scratch, then assign devices back.

If that doesn’t work, its possible some zwave parameter got messed up, and you’ll need to exclude and re-add devices again.

I did as you suggested and the 3 shutters work well, the wall controls work again too. I don’t really understand what happened. Thanks for the help, you are precious

1 Like

Glad it worked. Sometimes the code just gets corrupted somehow and this usually cleans it up.

Someone has changed the code for aeon DSC14104 and now the micro motor controller no longer works, the pause function is disabled (if I press the pause key the shutter reverses the running function but doesn’t stop). Who modified the code made it work for nanon shutter. Please resolve for dsc14104