Help in running custom command after removing rule machine

devicetype
smartapp
command
rulemachine

(Gil) #1

Hi Everyone,

Is there a way to associate a custom command to a virtual device?
So when I turn the virtual device on it send the command to the actual device…

Recently I deleted rule machine in order to organize everything from scratch.
I didn’t realized that the app is no longer available :frowning:

I used custom command to run my fibaro RGBW deepfade() and police(), but now I don’t know how to do this without rule machine.

I did tried to install the rule machine (Version 1.9.0aX) and rule (Version 1.2.3a) found in Github’s Commit History but the ‘run custom commend’ section seems to be gone. :pensive:
Github - bravenel commits

Any solution / example / advice will be grate!

thanks,
Gil :slight_smile:


(Ben Lebson) #2

Did you delete it from your IDE or just remove the installed instance?

In order to assign custom commands to a virtual switch you need to have a SmartApp which associates the two.


(Gil) #3

yes I removed all the rules from the app, and removed the app complitly from the IDE…

Usually I used the rule app as a way to associate the two…

any suggestion?

thanks,
Gil. :slight_smile:


(Ben Lebson) #4

Well, you won’t be able to get Rule Machine back so it looks like you’ll have to create a custom SmartApp…


(Gil) #5

My coding skills are not that good…
:sob:


(Patrick DiLeonardo) #6

I’ve written a Smart App to just this. If you (or anyone else) would like a copy of it to test, please let me know.

I plan to publish it on github, but want to get a few miles on it first. I wrote it over the Memorial Day weekend and it’s been working fine since.


(Patrick DiLeonardo) #7

I’ve published the first version of this on github:

I’ll get a proper release notice out in the next week.


(Gil) #8

Thanks for sharing man.
This is exactly what I needed!

So far works grate!

Gil :slight_smile:


(Patrick DiLeonardo) #9

Thanks. You’re the first person other than me to use it, so please let me know if you find any bugs or have suggestions.


(Gil) #10

If I’ll find something… but for now It works perfectly!

Thanks again.
Gil :slight_smile:


(George) #11

The need for this was discussed under Smart Rules, since it doesn’t have a custom command functionality.

Thank you!


(Patrick DiLeonardo) #12

George,

I’m a Smart Rules user and did this app specifically to provide a way for Smart Rules to trigger custom commands. I set up a set of virtual momentaries to use as trigger devices in my app and then use Smart Rules to turn on the momentaries as appropriate.

If you want to post a pointer to this thread in the discussions you reference, that would be great.

My next step is to restructure this app as a Parent-Child Smartapp to improve the usability a little, but the core functionality will stay the same.


(James Yeo) #13

There’s also CoRE :smiley:

Insanely powerful… still in Alpha, but many RM users have switched everything over, it’s doing amazing things

Custom commands are sorted out very well in the app as of recently