Having trouble understanding how to set rule machine for lights


(Troy) #1

Since the dimmer level of smartthings app only goes to 10% I have taken the advice of others to use rule machine. Trouble is, I am not smart enough to figure it out. There are so many different options within rule machine, I feel like I am trying to read Chinese. I have tried to search and figure it out, but I am not doing something right and lights are not doing what I would like.
I have several exterior accent lights and for now, until I learn more about using the machine, I would just like to set the lights to come on at sunset + 10 mins at a level of 1% and shut off at 1 am.
Could someone point me to directions to accomplish this? Please and thanks.


(Kevin) #2

No problem. You want to create a rule. Follow my screen shots & you’ll be fine.


(Troy) #3

Thank you for that. I was able to follow that and set like you have show (of course with my lights of choice).
I will see how things work tonight.

Things are starting to make more sense to me now.
One thing I still am not sure of is, what exactly does “true” and “false” mean? Does “true” basically mean when within the time the rule is set for?
I am having a hard time wrapping my brain around that part.


(Kevin) #4

Than read this it might explain a lot.

Creating Your First Rule


(Troy) #5

Now I am getting somewhere. Thanks.


(Troy) #6

Kevin,
I have been using my newly set up rule for my lights based on the example you provided to me.
Something weird is happening and I cannot figure out any certain pattern. For the first few days, I only had one set of lights in the rule (these are connected to a GE zwave dimming switch, if it matters), the lights seemed to always come on fine, but a couple of days they were still on in the morning. When I checked the “recently” tab, when they actually turned off at 1 am, it showed that and when they were still on it would show nothing for the off command, so it is not an issue of signal not getting to the switch I am assuming.
Then I added 2 more sets of lights (all link bulbs with no zwave switch). Some nights the link bulbs would be off and the switch bulbs would not be off and other nights the opposite. They only all worked correctly 1 time out of 5 nights. The lights connected to the zwave switch only worked correctly 2 times out of about 7 when it was just those in the rule.
I believe I successfully deleted any smartapps associated with the link bulbs. Maybe I missed something there, but I cannot find any smartapps still associated with them.
One other strange thing is the link bulbs still say they are coming on at a dim level of 10 when my rule shows they should be 1.
Any suggestions?


(Kevin) #7

A couple of issues here.

  1. Schedules have been messed up & it has nothing to do with rule machine, I have the same issue currently bug supposedly ST will have it fixed by tonight.

  2. Again this is a ST issue with not refreshing the status of devices. I have this issue with ZigBee bulbs, so I installed pollster to help alleviate the trouble. ST is also working to correct this issue.

  3. Not sure on your bulb levels specs, it might be a limitation & the lowest setting is 10%. Or if maybe an ST issue like I have where the Hub isn’t configure like the Manufactures specs should be so my lights colors are a little off when using the ST hub but are fine when using the manufactures hub.

Also there is an issue where if your not clicking done in rule machine but instead you are using the back button after a whom it will create issues with that rule. And you will have to delete it and build the rule again. Always click done!

Post pics of your current rules so I can see what’s going on.


(Troy) #8

I figured out the issue. Somehow when I first started trying to set up rule machine I must have created a rule that was not correct. When you posted the pics of how to do it, I set it up like you showed but still had the other rule in there and it was not letting me/giving permission to remove the other rule. After research I figured out how to get it out ( had to do it from IDE). Once it showed only 1 rule (the one you showed me how to set up) all was working correctly.
Until now, I added a switch for another light and my dumbass screwed something up and one of the lights set up on my rule machine rule got overlapped with a smartthings app. So I figured I would just remove the rule machine app and re do it. Well, I think the newest update of rule machine must have change something and now I cannot follow the example you posted above on how to create a rule. I am stuck at select conditions-condition #1 , I selected capability (time of day) but now instead of during a certain time, I get “between two times”.
Did I do something incorrect? or is there a new way of doing things?
When I do between 2 times, and pick sunrise +10 and 1 am, my conditions and rule are now [True].

again, thanks for the help.