Having issues with Alexa Helper


(Senn246@gmail.com) #1

I am trying to create an Echo command of “Alexa turn on food channel” and every time I try this, I get the low beep after my command. I am using a Harmony Hub to achieve this command, and when I run the routine, it works fine. I have multiple other Harmony routines working with Amazon Helper, but for the life of me, I cannot figure out why this specific command will not work. I have deleted the virtual switch, routine, scenarios, unlinked from ST, and everything else I can think of. Does anyone have any ideas for me?


#2

You may have run into an Amazon reserved word. The first thing to do is see if the echo will accept that word at all, independent of SmartThings. The easiest way to do that is just to create a new group using the Amazon app ( not the smartthings app) and give it the name you want to use and put any of your existing working devices into that group. (A device can belong to more than one group so there’s no problem with your existing set up.)

If you still get the chime when you then try to use that phrase, it’s an Amazon issue. Report it to their support, but you may just have to work around it.

If on the other hand just setting up an echo group with that name works fine, then it’s something in the SmartThings integration. So check to make sure that you did authorize that device using the SmartThings app, and that you asked echo to discover new devices after you did the authorization. If it still doesn’t work then, report it to SmartThings support.

Tagging @MichaelS


(Micheal ) #3

That sounds exactly like what is happening (Echo is not understanding you). If you go into the Alexa phone app (outside of SmartThings) it should register what it thought you said. As JD mentioned, it would be good to go into ST itself and simple click your ‘Food Channel’ virtual switch…is that works and saying it doesn’t, then the name of the device is your issue.

Let us know if this helps…

Michael