Harmony Home Control

i still have problems with it refreshing properly. I deleted and reinstalled the harmony st app, and it authourizes and finds all hubs and scenes but won’t save properly, meanwhile from within harmony it will authorize but never refresh the things properly. If i change anything i have to unauthorize smartthings in harmony and then re-add it to get all the items to properly populate.

Just picked one of these up today on amazon to integrate into my smarthome setup, and i’d like to use it for an easy way for my wife to turn the alarm on or off. I’ll probably get a multi-button switch eventually, but for now, i’d like her to hit a button on the remote to change between disarmed, armed away, and armed home. is that possible?

Which button remote model did you get?

The harmony home companion button remote has four separate buttons used just to toggle home automation devices that don’t require you to change the current harmony activity. Those can easily be tied to a virtual switch which in turn does the arm/disarm.

If you got one of the other Harmony remote models, you would have to change to an activity to trigger the virtual switch. It’s certainly possible, but it’s a little more clunky.

I got this one: https://www.amazon.com/gp/product/B00N3RFC4G/ref=od_aui_detailpages00?ie=UTF8&psc=1

it looks like the picture you shared. so just use the plug and light buttons for example to trigger a virtual button that is tied to a routine? sounds good, i’ll have to play around with it when it gets here.

Yes, that would be the simplest way if you want to use the Harmony for this use case. :sunglasses: Although if you use rule machine already, you wouldn’t need to use a routine. It can arm/disarm based on switch activity.

is that a smart app? I’m just really getting started with automation, despite having this for over a year now…

Yes, very popular and sophisticated rules engine smartapp. But a routine will work fine, too.

Wow, thank you so much for mentioning that. I was looking for a way to do something like that with smartthings, but it was always specific smartapps or routines had to be run. I’m going to be playing with this for hours…

2 Likes

I am so frustrated by this. I can control ST via my Harmony Remote but I can not get the ST app to find my hub so I can not get it installed inside of ST. I’m on the latest firmware of both hubs… argh!

May I ask what happens when you try to add your hubs to SmartThings? Are you receiving any errors? I just went through a long battle between ST and my Harmony hubs and finally got everything working.

I log in with my credentials but the ST app never finds my Harmony Hub… it just shows 0 hubs discovered. I have the Harmony Home Ultimate if that helps.

Any assistance would be great!

Did (or do) you have other Harmony Hubs? If so, and if they are on your account but inaccessible, it will fail to find any hubs (without deleting them from your account or connecting them again).

Just a thought - a common issue.

1 Like

YES! I do have some old hubs on there. My husband moved the one I used to use to his account so I can safely delete… I didn’t even think that would be an issue! I’ll go delete now and see what happens. Thanks!

I also realize I’m still on a beta build from Logitech… wonder if that could be a problem too. When I launch the MyHarmony app I can not delete any of my old hubs. I have 2 I need to delete. Hmmm…

You are the best!!! I downloaded the non-beta version of the MyHarmony desktop app, was able to delete the two old hubs and now my Harmony Ultimate Home is setup with ST!!! So thrilled!!! Thank you!

You’re welcome. I’m glad it worked. Have a great day.

1 Like

Hmm I added a smart control hub to my setup in another room and since then I could not connect my home control hub. Any ideas on how to fix this? The logs say to reboot the hub and I have but no luck on my end.

i recently had issues with mine. I tried to delete it and it wouldnt let me. it said a smartapp was using it but i couldnt delete the smartapp because it said the device integration required it. It took tech support to delete it. I’m also having a similar issue with the sami scale. I can’t delete it.

You need to go in the harmony app and remove or relogin to smartthings. You should also login to the MyHarmony desktop app and make sure you don’t have any orphaned hubs or devices too.

I’m not new to this. I tried that twice beforee emailing support