Harmony Elite stoped seeing ST v2 connected outlet

I have a Harmony Elite remote and a Smartthings V2 hub. I have an activity that amongst other things turns on/ off a z-wave outlet (not sure if it's a Leviton or GE at this point but believe it is a GE). 

A while back the outlet stopped working. I reinstalled it in ST and it works with Smartthings and Alexa. At first Harmony didn’t see it at all. I refreshed Harmony via Samsung account and it started seeing it. Unfortunatky, when I tried to add it back to the activity I’d get a message saying Harmony could not determine the status of the plug. So I deleted the Smartthings hub from Harmony and reinstalled it. Now it lists the plug but says “no connection”.
On Harmony I have three plugs. Two say no connection and on works normally. I also have two light switches that work fine on the Harmony as well. The one difference I notice between the plugs that work and don’t is that if I look at information the two that don’t work list driver named “z-wave switch” version 2022-12-06T19:32:44.342984474 while the outlet that works with Harmony doesn’t admit to a driver at all. looking at other outlets in the house (that are not connected to the Harmony Hub) it looks like the Leviton outlets don’t have a driver while the GE outlets do.
Anyone familiar with this problem?

Can I start by asking a question - how long ago did you set up the Harmony integration with ST? I only ask because if you are using the old groovy one then it will end in a coupe of weeks. There is an Edge Harmony integration you should look at if you do have the older version.

if you have already switched to a newer integration… sorry for wasting your time.

1 Like

I don’t know from Groovy Vs Edge. I did delete the hub from Harmony and the re added it if that makes a difference.

I would recommend switching to the Community Developed Edge Driver linked above. If you are linking to ST from the Harmony app… that will cease in a couple of weeks. Harmony is a discontinued product and Logitech is not going to put in the effort to build an integration to ST’s new architecture for it.

Since my original post I did some digging in the web API https://graph-na02-useast1.api.smartthings.com . So I’m noticing that the two outlets that are not working with Harmony are listed with an Execution Location of “Cloud” and there is no Device Network ID. I’m wondering if by trying to re-connect these while they were still linked to the Harmony is the problem.

No. ST is currently migrating devices over to Edge from Groovy so you will be noticing more Placeholder, no hub listed, no IDs and Cloud for those devices.

Fun fact: IDE will cease in two weeks (according to the recent posted dates). Groovy will lose support. The Harmony integration you are using will stop working. If you wish to continue using Harmony, you will need to use the Edge driver linked to above.

1 Like

I have the same issue, and some people say harmony integration will stop soon, some claim we dont know what will happen.

Anyway harmony asked me to reset my hub to factory and do a restore, I was to scared to do that, is that what you tried? I am not sure what you meant delete the hub from harmony.

If you did do a restore, please let me and harmony know, small chance they will do anything, but its nice to let them know people are invested in this like us, as they are continuing to support the remote anyway.

My solution might be to switch over to lutron sadly, but for my room thats a 300 dollar bill just to get my functionality back.