Google Home Assistance - problems with ST - KNOWN issue to Google

Basically, I have the same problems as everyone else: delete out ST from GH, and phantom ST devices still show up in the list of Home control devices, but ST doesn’t show up in the account list.

If you go to GH->Account->Settings->Services->Explore and type in SmartThings, no matter how many times you click “Unlink” and it says “Unlink successful,” every time you restart the Google Assistant app, it has the button as “Unlink” because IT ALWAYS THINKS ITS LINKED.

I’ve learned a few things:

A. Having two accounts using ST and being a pre-Samsung acct user would describe me. My wife has her own Google and own ST account, and she has zero issues linking things and making them work, but I still see phantom devices no matter what in the “Assistant->Home control” area.

B. It’s definitely related to my Google account, not to ST.

C. Google end-user support is not capable/talented enough to fix this.

D. It’s some sort of server-side cache issue. No amount of deleting/restarting/etc. issues will cause it to flip.

E. Even turning off “SmartThings remembering me” or deleting SmartThings out of at the linked accounts section has zero effect on the legacy Home control devices showing up in Google Assistant.

If you are both using the same hub and Google homes, there is no need for you both to link your individual ST accounts. There are 3 of us in my house that all use the same Google Homes, all have our personallized setting for Google itself, but I am the only ST account linked. It works fine for them when they give commands even though their google accounts do not have ST linked.

I found that when I tried to link more than one ST account, that is when we had issues as well. This may be because linking the Google home account creates a smart app called “Google”. Once it is there for one ST User, it is there on the hub. In order to totally unlink the account, that app has to be removed and it probably cannot do that since you have multiple users linked.

I’m also having the same issue and after much digging was referenced to this post. I can’t seem to see how to PM someone here though.

HI all, for you who are seeing ghost devices. Can you try unlinking and remain unlinked for 24h before linking again? If that does not work, please PM me your Google account and I will forward to Google.


I appear to be having this problem as well. I set up my account and I wasn’t able to connect Google Home with my hub and my door lock. So I disconnected everything, and tried reconnecting and nothing. So I deleted my Samsung account, removed Google permissions, and started from scratch using my Google account as my initial login. I can see the permissions back in my Google Account, but I can’t get the hub added to my Google home and I am getting the “Couldn’t Update Settings” message.

This is frustrating.

ive found the best thing with this is to link and waite at least 12/24 hours befor making another change. link them and leave it, you can keep checking to see anthing apears, but give it time to refelect accross.

Locks are not yet supported. So if the lock is the only device you have then linking will always fail.

1 Like

I also have Arlo cameras and have added a Honeywell switch. The functions work fine within the Smartthings app. But I’d like to have the voice control for the lights.

Add another user with this problem to the list – Me.

I am an original pre-Samsung user (and original backer!). We have multiple accounts account to Google Home, but a single SmartThings account (as far as I’m aware).

Encountered this problem today, as I finally retired my v1 hub and replaced with a v2…And have unfortunately spent most of the day (4+ hours) re-setting up all my zwave/zigbee devices on the v2 hub – What a nightmare.

Finally got everything done and thought I was finished…until I found all the ghost devices in Google Home. Ugh.

Did you try the Can you try “remain unlinked for 24h before linking again” trick?

1 Like

Hi, @Lars.
I also cannot relink SmartThings to Google Home/Assistant after unlinking it (I have waited 48h). I am getting “cannot update setting” toast message. Would you mind contacting me via PM to diagnose and fix the issue? Thanks in advance!

Same problem here. Just moved to a new house and unlinked ST and GH.

Now when I try to link them I get a “Cant update settings, please check connection”. I built the new home with that in mynd that I cant control all lighting trough my GH but now nothing works and I’ve tried everything I have read to try and fix it with no luck…


I am struggling to connect my smarthings to google home. I am getting the following "Cant update settings, please check connection”
So far i have tried

Changing the default browser
uninstalling both google home and Smarthings
clearing cookies and cache
Leaving smarthings unconnected for 24hrs

Another suggestions welcomed

Please PM me to sort this out.

OK i managed to fix it. It appears that while the Home App was un-linked my google account was not. I had to remove it manually here’s how

  1. Go to
  2. Click on the security tab
  3. Near the bottom find: click linked accoutns
  4. Find Smartthings and click on the unlink icon
  5. Now connect in google home using the normal Google connection steps.

Mine worked after that.
Hope this helps someone


OMFG!! I cant believe this worked. I knew it had something to do with the account being linked to google somewhere but I just couldn’t fine it in the app. You are a beautiful beautiful man!



I was also having trouble linking my Smartthings account to Google Home. I also noticed ghost devices in Google Home app. I was not able to unlink Smartthings as it did not appear. I would get the a messaged saying Account Linked immediately after trying to add it, then shortly after it would say something went wrong, try again. A google support agent guided me through setting up another Gmail account and building a new Home with that login and i was successfully able to add my smartthings account to that new one and when i logged back into my previous Gmail account, i was able to then add it succesfully. However, it does not appear in the ‘Linked’ list under Home Control/Manage Accounts in Google Home.

I’m using the latest version of iOS on my iPhone X.

I could not see Smarthings in the Google Accounts Security Page during the fault finding steps.

Hi @Lars Thanks, I can’t seem to get this done, I am using the new smartthings app. connecting with google assistant still loads all devices and no option to deselect any devices can you help?

@A_J Not sure where exactly your issue happens, but just in case here are the instructions to get to the settings in the app. If you already knew that, please describe your issue in more detail and Ill try to help further.

You deselect devices from the SmartThings app (new one)

  1. Open the left side menu
  2. Click Settings icon in top right of menu
  3. Select “Connected services”
  4. Wait for a few seconds for Google to appear and then click it
  5. Click “Allow Google assistant to access all devices…”

From here you should be able to specify which ones to expose.

Thanks Figured it out, the instructions at the beginning of this thread said smartapps, all sorted now thank you :slight_smile:

Same problem here, ‘sorry google home cant reach smartthings at the moment.’

Haven’t changed anything, just stopped working this week.
I’m on the old smartthings app
Google home has access to all devices
all devices show in home app
Smartthings account is linked in home app
Tried the hey google sync but says I have to do it with the account that added the device in the first place…which was me.