GoControl WADWAZ-1 contact sensor doesn't report battery level?

I’m new to SmartThings community. I managed to migrate all my devices from Wink to ST. And I notice something interesting.

I have multiple Door/Window sensors (WADWAZ-1) from both GoControl WNK01-21KIT “Essential” kit and GoControl WNK01-311KIT “Premium” Kit.

The ones from “Essential” kit report battery level, but the ones from “Premium” kit don’t.

I tried both generic Z-wave device handler and @krlaframboise device handler. Both have the same results.

Does anyone have similar issue? Is there any way to make it report battery levels?

Yes, mine show 100% all the time, after more than 8 months of use. I’ve tried the same 2 device types as well. Not sure what, if anything can be done. Other than reporting battery the work great.

I have 5 of them and same boat. Just installed 3 2 days ago from the same kit. 1 or 2 don’t report. Same DTH.

These devices report their battery level every 4 hours, but they either report 100 or a code indicating the battery is low.

Are you saying that the battery level doesn’t show up as 100% or are you just not seeing anything in the logs?

NADA - nothing for a couple.

some of them, the battery level show “–” on mobile apps. And there is no battery in the capacities section in IDE. I can take some screenshots after I get home.

BTW, I have one sensor gave me 68% battery sometime before, but now shows 100%.

I just paired a contact sensor from one of my premium kits and it initially diplayed closed even though it was open and the battery level was “–”.

The battery level changed to 100% automatically about 4 hours later and after closing and opening the contact sensor a couple of times it started displaying the correct state.

I just released a new version that should prevent both of those issues going forward.

While testing the fix mentioned above, I was able to see a percentage less than 100% a few times, but it only happened after re-inserting the batteries and the next value it returned was always 100% again.

Unfortunately if the DTH asks the device for the battery level and the device doesn’t return the actual percentage, there’s no way to fix this.

I’m pretty sure that if the battery drops below 5-10% it will report a low battery warning, but I don’t have a battery low enough to test it.

Thanks Kevin.

I think the problem is the generic Z-wave device handler never asks for battery info. When I got home, I found all sensor have battery level information with a new status “lastPoll”. So I guess the sensor doesn’t even report battery level unless there is a value change (100% to 99%), or the device handler needs to actively poll the information, which you do every 4 hours.

The battery level could drop 20% and the device still won’t report it automatically. The “lastPoll” attribute gets updated every 4 hours so that I could monitor if the device is still online and if you haven’t changed the battery setting it will also update the battery level, but it doesn’t display the battery event in the logs unless the battery is low.

I just made the same migration in two locations and none of my GoControl sensors show the battery level even though they all show up as local devices.

Any more information on this?

If they show up as local devices then you must be using the default device handler and I’m pretty sure others have discovered that it doesn’t report the battery level.

The device handler below should solve the problem, but it will prevent them from running locally. FYI, the only SmartApps that run locally are Smart Home Monitor and Smart Lighting so if you plan on using them with other SmartApps, local execution is a moot point.

Thank you. Yes, I installed with all the standard drivers. I did email support and request that they add these features from the community.

I do have one (kinda one) question. If I use the lights with a routine that needs cloud computing, they should still show up as local devices, correct? It would be nice to have some basic functionality if the network went down.

I have DSL at my cabin with a UPS that that keeps my internet up for a good 3-4 hours. But, I have to admit that in my experience, power goes out way more often than just the internet, so most of the time, cloud is not a problem.

I don’t think routines run locally, but I’m really not sure. The easiest way to determine what will work is to unplug the network cable and try it.

Your handlers work great. Now I want to benchmark local versus cloud. I changed them back to the default handler and they show up in my local devices list now, but I can tell from the app that they have not changed back to the original as they still show the temp. That was yesterday. Do I need to open the case and take the battery out for that to happen?