Get ready to make the switch!

So you make an account for the region where the feature you want is and then add it as a member to your main account? Is this correct?
I want to try this with Korea…


I will try !!..thanks !

I tried this method but it did not work. When I tried to join using the QR code it said that it couldn’t join because the accounts are not from the same region.

1 Like

Ufff…nice try, I do not get what all this about silly region restriction stuff…

hi all, looks like I’ve got to do this as my app is nagging me to . are there any gotchas? does webcore still work in the new app? etc

WebCoRE works in the new app but there are a couple of areas to be aware of.

  1. webCoRE can not manage and/or use the STHM state directly in the new app as it did with SHM in the Classic. You will need to use virtual devices as a workaround or use automations/scenes to manage STHM.
  1. there is a known display bug when you go to select available devices to webCoRE. Basically you are presented with the cancel button are selecting devices but it still saves them.

thank you! that’s really kind to help, I’ll give the upgrade a go! :grimacing:

1 Like

I had an odd issues happen yesterday, in that my Aeotec MultiSensor 6 just disappeared from the app and all associated webCore pistons did not execute. I had to repair the device and go through every piston and re-enable… Has anyone seen this before? New app btw… I also did a complete inventory to see what else happened that I was not aware of and it looks like it was just this one device… Obviously not cool…

So I have to say my experience with the migration is not pleasant. Hardly anything migrated and what did hardly any of it works. I had to recreate routines as most didn’t migrate and the ones that did were corrupt and I was unable to edit them. So far it is almost as bad as setting up from scratch.

Now my biggest issue is losing all control of everything within the app. Last night for example I kept getting unable to connect or network error when trying to do anything. All other connected to wireless devices worked without issue on my network. My only issue was ST. I could run a scene, pull up or control a device, nothing. Restarted the hub, restarted the app then my phone but nothing worked. I left the ceiling fan on, turned the lights off with the HUE app then went to bed.

There is also a lot more work needed before this is usable and missing functionality I would call logical choices just isn’t available yet. One of those logical choices that isn’t there is something simple like sorting of items in a scene or automation when I’m looking to see if I missed something or if it is set to turn on or off. If I select a bunch of lights for a scene why does the app choose which should be turned on and which turned off. I have to review an entire list to change which gets turned on or off. The Classic app was so much better, a list for on then a list for off. When I change a light to say turn on instead of off then it changes position in the list but doesn’t even group all on or all off together. This adds so much more time creating a larger list.

If I am missing something or if there is a better way please let me know, it’s frustrating.

So far the migration and the new app is horrible.


Yes the axact same thing happened to one of my two sensors.
Seems like I also had a hard time getting it to reconnect at all.

1 week so far post-migration, and, while I notice things are a bit snappier (less delay), I am dealing with 3 major annoyances:

  • WebCore scripts that turn off a bunch of lights (say 6 lights in a bathroom room after 3 minutes of no motion) often result in 1 or 2 lights staying on. This used to happen 1 out of 40 times pre-migration, but it happens 1 out of 10 times now (maybe more often than that even).
  • I absolutely hate the process for “Scan nearby” to add devices, when I need to reconnect a device that got disconnected. It’s incredibly finicky, and 3 out of 4 times, even if the devices shows up in the found list, it fails to be properly added and controllable, so I have to reset the light and rescan again and again.
  • The truncation of device names on the tiles is absolutely moronic. I have Master Vanity Mirror Light 1, 2, 3, and 4, yet they all look like “Master Vanity Mirror Lig…”. There is plenty of screen real estate, so wrap the damn text.

New app broke mobile presence automations for us. No matter what I have tried they won’t work for us. Deleted from the IDE, deleted the automations, added them back…and nothing. IDE shows the presence is updating correctly but Automations will not fire.

Called support and they had no suggestions.


Try creating an automation that triggers for one person, and does one simple thing, like turn on a specific light. That will tell you if presence is working at all for you.

I had a lot of trouble with presence-based automation, and it came down to two things:

  • Conditions involving multiple people, particularly the condition “Anyone is at (location)”. As far as I can tell, this only fires when you go from nobody->somebody and not if someone is already at the location.
  • Automations that run a scene that changes modes and have a mode as a precondition. Annoyingly, these scenes can fail silently when run by an automation, even if the scene runs correctly when run manually.

That said, I now have all my presence-based automation working, though I has to create individual arrival automations for each family member.

1 Like

Tried this yesterday. No go. Set an automation to send a notification when I am back. Didn’t work. Same for my spouses phone. Won’t work. Well, sometimes works once, but won’t work again unless I delete the automation and add it back. But that isn’t even consistent.

Just plain broken. ST’s customer service couldn’t help either. They also show our phones presence is updating correctly but not sure why automations are working, even simple ones like a notification or light coming on.


Honestly, why oh why are we being forced on to this app when some of the most basic functionality like this is broken…



Some venting after switching to the new App a couple weeks ago…

Is anyone else finding the lack of debugging tools an issue? If automations and scenes are not doing what I intend it’s a struggle to know why, especially related to presence sensing. When using iPhones for presence isn’t there a way to check it’s status? I’ve resorted to creating virtual switches to know if automations why automations are not working. I’m having flashbacks from writing Fortran code 30 years ago. :wink:

And why does Life360 only apply to STHM? Why isn’t it showing as a presence option for automations?

I started using ST several years ago because of it’s ability to develop (and trouble shoot) complex automations. I feel like this new app has dumbed ST down to the point where it isn’t much better than the most basic platforms, like Alexa and Apple Home Kit.


Life 360 is under the “Device status” option.

1 Like

Yep. Even if presence is working, automations that use presence are super flaky. I’ve tried recreating them ten times. Just had my alarm go off this morning, because this simple automation below almost never works. @Lars or @blake.arnold, who do we have to beg to get this basic, core functionality fixed? I’ve had ticket 1046818 open for weeks. Support is beyond useless.


After some digging I see that Life360 is now completely missing from both the new app and the classic app. I guess that’s why I couldn’t find it under devices in the new app. After the migration it was available, as members, when setting up the STHM but I never saw it in my list of devices. I guess it was a casualty of the migration. I was able to add Life360 again in the classic app and now it is listed in my devices in the new app. Thanks for the hint. It lead me down the path to remedy.

1 Like

Converted a couple of weeks back and have not had any issues.
Good job!
Sometimes it asks if I want to upgrade device handlers, not sure why that isn’t automatic?