GE Link Bulbs vs TCP Bulbs

Zigbee firmware 1.5.4 was a manual update by special request to support?

Maybe ST hub is too close to router.

zigbeeChannel: 19
zigbeeFirmware: 1.5.4
zigbeeNodeID: 0000
zigbeePanID: 090D
zigbeePowerLevel: 254
zwaveHomeID: E236C1C3
zwaveNodeID: 01
zwavePowerLevel: 00
zwaveSerialVersion: 0
zwaveVersion: 0

I have reset the bulb to where it fades then goes back to bright while the hub is scanning for new devices. I just don’t think my hub or my router is able to communicate with this particular bulb. The bulb doesn’t even show up on my IP tables for “Wireless devices” connected (I do find my LIFX bulbs though)

The router shouldn’t communicate with the bulb as it is Zigbee, only the hub should. The LIFX bulbs use wifi, which is why they show up under the IP table.

Have you tried initiating the new device scan after the reset (your comment says while, so I wasn’t sure)? I wonder if it’s a zigbee channel issue causing interference. I thought the hub purposely chooses a channel with low interference, but maybe ST support could change it for you. My hub uses channel 14 for instance. The Zigbee documentation for the HA profile recommends (11, 14, 15, 19, 20, 24, 25), so your channel is listed, but maybe one of the others would work better for you.

I’m having a lot of trouble with bulbs either not turning on when directed or not turning off. The hub and the app seem to think their state has changed, but it doesn’t. I have about 7 bulbs in my house and each one malfunctions about once a day. This is most annoying when bulbs are commanded to turn off at night or after I leave the house and then I return to see they have been on all day, mitigating the benefits of having smart control of them to save energy.

I have a ticket open with the SmartThings support and they have said the GE bulbs aren’t officially supported right now. They suggested I reset my bulbs. I did that but that did not solve the issue. I would think this could be resolved with more two way communication between the hub and the bulbs.

I’ve been thinking about either of these options, but I’ve personally decided on the 3rd option, which is to rather replace my wall switches with Z-Wave connectivity.

For one thing it’s always a problem having a wall switch that ends up being switched off. then you can also control multiple lights with a single switch. Lastly you can also switch brands and get cheaper simpler lights while still maintaining automation.

Just my 2c. Sorry that it does not answer the question asked… I hate it when people do that. :wink:

2 Likes

I’ve had similar problems at times with the GE bulbs, in particular getting all bulbs to respond to mass on/off commands. I think that issue lies with ST as TCP and Hue owners have had similar problems with single bulbs being missed.

From all the commentary, it does seem like the GE bulbs are particularly susceptible to interference from wifi and other 2.4 GHZ products, so maybe take a look at the Home Networking thread to see if you can better align the channels that your ST hub and wifi router use to minimize interference.

For improving the status updates, check out the device type code in this thread: Updated : GE Link Bulbs - FINALLY getting ON status after manually turning on!

It has enhancements to better update the on/off state and adds polling capability to be used with pollster. It might not fix the bulbs turning off all at once, but if you add polling, at least the app will update to show the actual status and you can remotely fix the bulbs that didn’t respond at first.

Thanks. I updated the device types. Do I also need to use Pollster for this to be effective? I don’t currently use pollster and, in looking through the pollster thread, I couldn’t determine the use cases for it.

ST approach is to send a command and assume it worked approach, so the ‘on’ status is set as part of the ‘on’ command. It doesn’t wait for a response from the device. This causes the sync problem when commands aren’t received due to interference or some other issue.

You don’t have to use Pollster, but the state will only update when refresh() or poll() is called and since refresh() is usually manually triggered, Pollster is a good option for automatic periodic updates to status, particularly for devices that don’t report in occasionally.

It’s unfortunately a flawed approach with any kind of wireless network. I will say that the GE Link bulbs definitely tend to work better with the Hue Bridge (despite being listed as unreachable) than when connected to the SmartThings hub.

I really only seem to have problems when sending large groups of commands (3 or more bulbs). I’m wondering if it’s an issue of timing between commands not being consistent. In that case utilizing the groups cluster might help to address some of the problems we are seeing.

Same thing for me, but sometimes after a large group command, the individual bulbs take a few tries to get the communication flowing again.

I do have a question out to @urman to see if we can send Zigbee commands using group addressing because I thought the same thing. Fewer commands would hopefully result in less interference.

I tested the bulbs and was able to assign them to groups, remove from groups and get their group assignments. They can handle 8 groups. Only groupIDs though (numeric), not group names (string) like some devices. I’ve already started a version of Dim with Me to separate out GE bulbs (or any Zigbee dimmer accepting groups) and use group assignment to control that portion.

Fantastic! Mind sharing? Throw it up on GitHub and let’s collaborate on it.

Are there any Zigbee remotes that can be used to control the GE Link Bulbs? I have a GE Z-Wave remote paired with my Hub for my GE w-wave switches and outlets, but my understanding is that there is no way to use this connection to control the GE Link bulbs.

I was wondering if there is a Zigbee type remotes that would work similarly.

I thought you could use the button controller app for this. I don’t have one so i don’t know, but my Dad does and it think that’s what he uses.

@tslagle13 Is your Dad using the GE remote or the Minimote from Aeon Labs? It looks like there may be more support with this with the Aeon Labs remote.

If he has the GE remote though, could you find out how he set it up with the GE Link Bulbs?

He’s using the GE Remote. I’ll ask when I see him next

The GE Remote is just a zwave controller. It acts as a secondary controller to your smart things hub. Commands go from the remote directly to compatible zwave devices. It cannot be used to control the GE Link bulb.

As a kid i always knew my dad was magic.

For those of you having issues with GE Link bulbs acting up, i may have just found a quick fix.

I was haivng trouble with two of mine and was doing everything not to have to remove and re-add them. I was doing every trci in the book. Power cycling things that didn’t even make sense to power cycle lol. Then i noticed that the icon for the device changed back to default.

I thought hmmmm thats weird. Thinking it could be a DB thing that could cause this i renamed the bulb. Boom it worked again immediately. Thought this was too good to be true… so i tried it on the next bulb… boom worked immediately.

Hopefully it works as well for you as it did me!

3 Likes

@tslagle13 Just wanted to check in if you heard anything more about how to get the remote to work with these lights… :slight_smile:

I ordered the GE remote thinking surely it would work with the GE Link bulbs! I have 5 of them and they work great with the ST hub, but as I only have 1 z-wave device, and it’s a motion sensor, if I can’t get the remote working with the Link bulbs, i’ll be pretty frustrated. I’ll let you know my experience once I receive it and play with it a bit.