Ge Link bulbs not working. Customer Support can't help. Can you?

GE link bulbs were working beautifully.
Then a new firmware and ios app were available and automatically downloaded.
That’s fine I didn’t care. Got home and not a single GE link bulb worked.
I deleted the bulb from the app. But I can’t add them back anymore.
Customer Support is telling me to buy new bulbs!
These bulbs were working beautifully prior to the firmware update.

What should I do?

These are the GE Link BR30. I bought a bunch from HD for 99 cents. They are paired with motion sensors throughout the house by stairs leading in and out of different levels of house.

Have you tried resetting the bulb? If I recall correctly you have to turn it off/on 5ish times. It will then dim to show it is reset.

Once that is done you can re add through the app. In the future - don’t delete it from the app - just do the reset and it will re pair and be recognized as the existing device.

1 Like

I used to use a few GE link A19 bulbs but gave up on them because they randomly drop off the network. It’s a known issue for them, not 100% sure if that applies to the BR30s. I think a firmware update through Wink was supposed to fix this, but AFAIK the bulbs still can’t receive updates from a ST hub.

@greg’s suggestion usually worked for me (ie just do the physical reset process without unpairing from the hub and they’ll start working again). But if it keeps happening, is it worth your time? Especially if you got them for so cheap. There are other BR30 smart bulbs.


Mine were working “pretty well” (via Hue Bridge) until a few days ago when two variables changed on my network:

  1. Added a Sengled bulb directly to SmartThings Hub (i.e., shouldn’t direct affect the Hue mesh, but could be RF interference).

  2. Updated the firmware on the Hue Bridge.

Now all my Hue & GE Link bulbs are an inconsistent mess.

Still does not work.
It seems like Smartthings has pulled support for GE link bulbs maybe?
I dont know. None of my bulbs are working.
They were working before though.

You reset the bulbs? You have to see the bulb dim after the reset procedure or it didn’t work (the timing of on/off can be annoying to get perfectly right).

Anything is possible, but I doubt that. If resetting doesn’t help then maybe there is something about a recent update that broke the functionality of GE link bulbs. But that doesn’t mean ST permanently stopped supporting them.

1 Like

I’m also having “new” issues with my GE Link Bulbs. I’ve been using these bulbs with very little issue for over a year. They were falling off the network on occasion, but something changed and they now seem to be on the network, but not working. I see them getting stuck in the Turning on/off phase - sometimes they change state after several minutes, rather than instantly and sometimes the state never changes. I’m also seeing that sometimes they work with my Alexa voice commands, but it doesn’t report the change in state back to the Smartthings app.

I recently added a couple of Sengled bulbs and liked how they actually worked properly so I decided to replace all the Links with Sengled bulbs, but those don’t function as repeaters, so while they work great when they’re in range, I have a couple bulbs that drop off. However, I’m now wondering if the Sengleds might be triggering some of the problems after reading tgauchat’s comments.

I contacted GE and they sent me two replacement bulbs, but I’m seeing the same issues with all of the bulbs - both new and old.

I agree with you guys, something is up. I’ve chatted twice with Smartthings support and was told that everything looks fine, but I feel nothing but frustrated with the state of my setup.

AND this is happening yet again.
Firmware update and now ALL my GE Link bulbs are not working. They don’t even want to be recognized by the hub anymore.
Not only that but my samsung motion sensor does not want to pair as well.
THIS is ridiculous. Why update the firmware to kill devices? Don’t you guys test it before making it public on a FORCED update?

I really am starting to hate this company as a whole.
Christmas Lights paired to a switch has become unresponsive.
GE Link Light to automatically turn on when the door sensor is activated is no longer working.
Door sensor showed the same error as “unavailable”. I had to pair it again only to find out it pairs but DOESNT WORK.

EVERYTHING was once again working perfectly but after the stupid update, it stopped working!!

This is by far the biggest waste of money to date. This product is GARBAGE

You do know the problem is not ST on this one right? I have 10+ GE link bulbs and they drop offline weekly on both ST and Wink 2. It’s a known issue for a while now.

When their own sensors are pairing and then becoming “unavailable”, then is that GE Link Bulb problem, too?

No it’s not but do we know what caused it? Possible interference, battery… Etc… I am not defending ST. I have lots of their sensors and the batteries are terrible but other than that I hardly have any issue after having many more zigbee repeaters for my mesh.

Turn off Device Health.

A recent change this week re-enabled it for everyone without warning or notice.

I find everything works better without it.

It’s easy to tell.
Firmware updated on its own.
Sensors started having the “unavailable” icon next to it.
GE Link bulbs are not working anymore.

Trying to pair them again:

  • Door Sensor pairs and exclamation icon disappears. Then after a few mins, they don’t work.
  • Motion sensor pairs and exclamation icon disappears. Then after a few mins, they stop working as well.
  • Outlet Plug sensor pairs and exclamation icon disappears. Pairs but same problem as above.
  • Ge Link bulbs are not seen by the ST Hub. I cannot pair them anymore as of 9:50PM EST.

Before the firmware update:

  • EVERYTHING worked flawlessly.

Thank You!
But that did not work either. I tried pairing a new Philips hue bulb and the hub doesn’t even see it.
This device is barely over a year old.

SmartThings only “supports” Hue Bulbs via the Hue Bridge.

I am not claiming that it’s the root of your issue, but I gotta agree with @Navat604 that the GE link bulbs are total crapware.

1 Like

Crapware or not, they’re not the only devices not working.
Samsung’s own crap such as their sensors are not working either.

Yes but it should be able to see them.
But it doesn’t.
It sees samsung’s ST sensors but it does not connect to them.
This is obviously a software issue and not a hardware issue.