SmartThings Community

GE Ceiling Fan Switch Custom Device Type - Low, Med, High buttons w/no slider!

fan
dth_hvac

(Eric) #176

Here is an update of the original jscgs350 dth code that supports Health Check


#177

FYI, I’ve also updated mine (as well as a few other DH’s):

01-08-2017 : Added code for Health Check capabilities/functions, and cleaned up code.

https://raw.githubusercontent.com/constjs/jcdevhandlers/master/devicetypes/jscgs350/my-ge-fan-control-switch.src/my-ge-fan-control-switch.groovy


Is GE fan controller 14287 suppose to come up as a dimmer?
(Charles) #178

So, I updated, and just to pretend that I’m not totally ignorant, I searched on “health check”. What I read didn’t mean a whole lot to me. Can someone explain what the DTH does now that it didn’t before? Thanks!


#179

Sure! Once you refresh preferences (tap the gear and then tap on Done), or change to a device type with this in the code, it configures a back end ST process called Health Check (HC) that will some day be used to let you know when a device goes offline. There is no change in the mobile app in terms of what you see today, or in terms of added functionality you can do.

I can only assume that it’s something the mobile app will do someday, but for now the IDE will show ONLINE or OFFLINE for devices with HC enabled:

It’s not uncommon for developers to update their code, especially when ST adds new stuff/fixes. In the the case of this fan device handler, it was based on ST’s dimmer switch, and over time ST modified their code for the dimmer. The updates reflect some of ST’s updates. So long story short, we’re just keeping up with changes ST is making.


(Michael Stroh) #180

Are there system requirements for the health check features? I’m not sure if there is a problem with the new code or my system not supporting it but the new code didn’t work for me. I start with the fan off, any press of the low, med, or high buttons changes the speed indicated, but does not turn the fan on. Sometimes hitting the various speed buttons doesn’t actually show the speed change until the refresh button is pressed. Also the light behavior button is missing. I’ve reverted back to the old code for now.


(Michael Stroh) #181

Never mind! My apologies!

I tried again. I republished the new code and this time hit the gear icon and then done and now it works correctly. I also found the light behavior in the gear settings screen.

It appears that if you update to this new code you must enter and save the settings on each and every fan that uses it. Not a big deal for such an awesome DTH.


GE Z-Wave Wireless Smart Fan Speed Control, 3-Speed, In-Wall
#182

Thanks for this device handler! Works great for me.

However I’m not having any success getting a CORE piston to turn it on and/or adjust the speed. I have a super simple piston that says if temp is >= 75, then turn on fan. It’s showing the condition is evaluated to true when it should but doesn’t seem to be able to control the fan. I know someone has written a SmartApp to do this but I will need more sophisticated conditions so really want to get this working.

Anyone have CORE controlling their fan with this device handler?


(Chris) #183

Yep. No problems here.


#184

Thanks for confirming. I’ll keep at it.


(Peter) #185

I just came upon this code. It’s great because I much prefer the buttons and no slider.
I’m using revision 03-11-2017. Created a new device handler - and change existing GE fan control switch to the new device handler.

What works -
I can turn it on and off. Alexa (Amazon Echo) will respond to turning ceiling fan to on and off, and set fan to low and high speed.

What doesn’t work.
The buttons (low, medium, high) inside of Smartthings app for ceiling will not work.
Alexa is unable to set the fan to medium speed. Her response is she doesn’t know how to set ceiling fan to that setting.

What I am doing wrong? Will I need to remove ceiling fan from smartthings hub and add it back again? I was under the impression that by changing device type to this custom type - it would work.

FWIW, I disable and re-enable smartthings skill from within Alexa app. No luck on the medium fan speed.

Thank you.


#186

Not sure why that is happening for you but it is unrelated to the Alexa ‘issue’ you are reporting, Perhaps try just refreshing on the Thing screen in the app.

Alexa is not really setting the fan to high and low per the device handler. It is interpreting ‘high’ as set higher and low as set lower, as if it were a dimmer. It does not have a medium equivalent it can recognize thus what you are seeing.

With Alexa you can tell it to set to a percentage. Different fans have different thresholds at which they run for low, med and high. In my case, all my fans run at low at a 33% setting, medium with 67% and high at 99%. So I can tell Alexa to set to 67% and it will set the fan to it’s medium speed.


Z-Wave Smart Fan Control Custom Device Type
(Peter) #187

Nezmo - Thank you. Yes, this issue is not related to Amazon Echo. It still responds to set ceiling fan to 60% as medium speed. I just wish that I can tell it to set to medium since it responds to high and low speed.

While inside of Smartthing app - I hit refresh several times. Log in and out of Smartthing IDE. The buttons, low, medium, and high just won’t work. Only on and off button works. Not sure why this happens and how to go about troubleshoot this custom device handler that is working for everyone else.


#188

Yes, unfortunately Alexa does not have the capability yet to do true low, med and high with respect to the actual fan speeds. What it does do for low and high is just kind of a luck thing as it lowers and highers the ‘dimmer’ setting which Alexa does handle.

What’s even more frustrating is SmartThings does not have a stock handler like the custom one. They claim compatibility yet their handler just has a slider which is not the best.

I wish I could help on that one. I have not had that issue. I set the custom device handler for my first fan install and all I have done since picked-up the same custom handler and do not have issues either. Hopefully the device handler author can offer some troubleshooting tips.


(John C) #189

It may not “be the best,” but it has other favorable attributes. For example, in my second home, we use SmartThings to run ceiling fans twice a day for an hour each time while we aren’t in residence. With the “stock” DTH, it runs locally on my v2 hub – meaning it “should” run even in the absence of an internet connection (even though I have no way to remotely verify this, LOL).

That being said, a three-button fan implementation officially supported by ST – and available for local execution on a v2 hub – would be highly desirable :sunglasses:


#190

Hi @peterlin71,

When you tap on any of the speed tiles it takes just a second or 2 for the main tile to update, and that’s because the device adjusts to that speed like any other dimmer. If you notice how those work, you can actually see the slider move to the desire value. In my DTH, the main tile will change once that value it met.

After you tap on any of the speed tiles, what does the IDE show for the details? You should see something like this:




(Peter) #191

Hi @johnconstantelo
When I press low, med, or high button within Smartthing app - I see changes in CurrentState. However, level remains at 60%. Also I see that “Fan speed is set to HIGH” within the app - right under the On - stays the same.

And if I press Low button, I see no change in fan speed. I would press the off button. Fan will turn off. I press the on button, Fan will turn on. It would briefly read “Fan speed is set to Low” - but changed to “Fan speed is set to HIGH”

Somehow it is stuck at 60% or revert to HIGH speed. Since I no longer have the slider, I would tell Alexa to change fan level to 80%. And that’s the level I’m in - I cannot change with the 3 speed button within the app. I hope this makes sense.

Current States
switch: on
level: 60 %
indicatorStatus: when on
checkInterval: 1920
currentState: HIGH
currentSpeed: HIGH

switch: on
level: 60 %
indicatorStatus: when on
checkInterval: 1920
currentState: LOW
currentSpeed: LOW

switch: on
level: 60 %
indicatorStatus: when on
checkInterval: 1920
currentState: MED
currentSpeed: MEDIUM


(Chris) #192

@johnconstantelo, been using this for close to a year, love it! Thanks for your work on this :slight_smile:

I also love being able to set Low/Med/High in webCore vs choosing random percentages


#193

What do you have set in preferences in the Thing for Low, Medium and High? By default I believe these are blank and the handler then uses 33, 67 and 99. Have you by chance got something set in prefs?

And @johnconstantelo, it’s your handler that doesn’t have the slider right? I’m using @ChadCK’s which does keep the slider and maybe the prefs are different - I can’t remember,


#194

That’s a good point @peterlin71 that’s been made. Can you go into the device’s preferences and double check those values and then tap on Done?


#195

Correct, but mine still has the device preferences in case they need to be tweaked for some reason.