Fire HD 10, ActionTiles, FKB Challenges

Look on forums. I just saw many threads on this there.

Do you know what process you followed for your Fire 10? It also appears as if we rooted, but left Fire OS 5.6 on the device. It seems to me that has to go. Just getting rid of that outdated webview message would be an improvement and maybe my other issues will go away as well.

That could also be an answer for ActionTiles: Perhaps the people with this issue are rooted, but ONLY rooted and not running a vanilla Android OS. Just a guess, but I’ll know soon enough.

I think you’re definitely right, if you get a vanilla Android OS on there, you’ll see everything run much smoother. I did mine a couple of years ago, I had smarttiles on there, so I’m out of date. It’s definitely half a days work to do it, finding the thread on XDA, reading through the thread, checking the correct instructions for the Fire OS firmware version you have, but if you’re already rooted, you’ve done the hard part already.

Thanks for the video share, Ron…

What type / model of tablets are these?

When you get a moment, could you PIN Protect a Tile, assign a 6-Digit PIN to the Panel, and then share a new video showing the responsiveness (or lag) of PIN entry?

For the video, you do not need to input the correct PIN. Just input 1,2,3,4,5,6 please. Please do it at least twice in the video.

Our testing experience shows this is just a tad slower than we’d like, but there is no consistent significant lag.

I really believe the recent reports of significant lag - particularly on Fire HD10 with Fully: But we absolutely have not been able to replicate this poor experience. So frustrating!

You can also share the video with first for verification.

Super thanks!

1 Like

You are more than welcomed.

The one on the desktop is a Fire HD10 (7th Gen-

The one on the wall is a Fire HD8 (7th Gen-

1 Like

Terry, I also checked Firefox, per your request, on my rooted Fire HD 10 (with FireOS 5.6) and it ran ActionTiles GREAT. So both Firefox and Chrome ran it with no problem.

One other oddity to mention: From time to time I have been getting the smaller pin dialog box instead of the new, bigger one. NO idea what the trigger is between them. It just sort of happens.

Once I completely wipe the device I’ll see if that too stops happening.

Just now seeing the new bigger pin dialog box and what an improvement!

1 Like

Yup… @625alex went all-in to replace the bottom drawer with full-screen “Glass UI”. It’s implemented for dimmer and color too. Thermostat - not yet.

1 Like

Just a quick update note: I’m in a holding pattern on this as the 7th Generation of the Fire HD 10 has a locked bootloader currently so completely wiping it is not an option at this point. That means the only current hope is for a code change from Fully Kiosk Browser or an alternate kiosk browser solution.

There are two teams working to unlock the device and, if that happens, the thinking is that it will behave as flawlessly as the other Fire devices have that have been wiped.

Have you seen this? This shows how you root and install Superuser.

I think I may have lost track of this thread.

@625alex and I have been absolutely unable to reproduce the responsiveness issue so far; regardless of which browser we test with.

But we only test with stock FireOS - no rooting or Play Store.

You may want to contact Fully and ask for an older version of the APK, since the timing of this issue seems to coincide with the latest Fully update - but, again, we don’t have any reproducible cases.

Yep. My device has been rooted for quite some time, but that still doesn’t allow for installing stock Android on the device which is what a few teams are working on at this point.

Completely understood and agreed. I would contact Fully, but I have yet to find a reliable means to do so. Their posted e-mail address ( just bounces back errors if you e-mail it.

We’ve exchanged emails with that address many times with never a problem. Alexey could be on extended travel, I guess; or your email client is having problem with the “-”. I dunno.

There’s been a lot of talk about rooting the HDs but I’ve actually found that not to be necessary. There are instructions on these forums and the XDA forums (see post #28) on how to remove the lockscreen using the Settings Database Editor. I’ve done it on an HD8 and so far have been happy with it.


Wish I saw that before I rooted. Too late now. Thanks for posting that. It may help someone down the line. Also, my e-mail finally reached Fully Kiosk Browser (the first two attempts bounced so it must have been a temporary situation). Alexey responded that they’ve never heard of this situation and asked me to take a video. Terry, you may want to ping him. I’ll send the video to him shortly.


I think you can still factory reset and/or install a stock ROM, etc., in order to revert.

Well - My Fire HD10 just arrived. I don’t know if it has an old enough System to be rooted (because I wanted to mimic Customers’ environment to see if that is the cause of performance issues) - though with only one Tablet, I’d have to revert to Factory afterwards anyway in order to confirm that resolution.

Or get 2 identical Tablets.

My tablet collection is taking up more room than a bookcase :neutral_face:.

This did not work to remove the mandatory lockscreen on my new (v5.6.0.1) Fire HD10 (though there is a GLOBAL setting to disable Ads/Offers and that works, but it may reset upon reboot. The link above includes an “Automate” (like Tasker…) Flo, which resets ads to off after every boot, if required.

Also tested on Fire HD8 (Fire OS I can successfully disable ads/offers, but cannot disable the lock screen upon power-on.

For me, the key was to change the setting in the Global Table “device_provisioned” = 0 and then reboot the device. If that doesn’t work, then something has changed in the 20198 version.

I too was looking to use a Fire HD 10 with ActionTiles and found this useful thread. Having set it up last night, I thought an update here might be useful for others trying to do the same.

Having read threads about running scripts to clean up the tablet and then the conversation here about rooting, I was concerned this would all be very difficult. But I found this very helpful blog post by Andrew Cornell, clearly a ST super user though I can’t find him as a user here. @tgauchat has commented positively on the blog though and I thought he might appreciate the update here.

The setup process worked perfectly for me and is essentially (to quote from the blog):

  1. Reset Kindle to factory default settings
  2. Connect to WiFi without registering the device with Amazon
  3. Install the Google Play Store (which will replace the Kindle store) & Prerequisites
  4. Install a Custom Launcher, Kiosk Browser & Home Button Hijacker
  5. Configure the kiosk browser [to run an ActionTiles panel]

No scripts, no rooting, pretty easy setup and no problems yet (though less than a day in).

In case of interest, I used the Amazon Show Mode Charging Dock for as a mount for the tablet. I like the cradle with magnetic docking so I can easily remove the tablet when necessary. I replaced a now unused mains powered thermostat on the wall with a USB socket/outlet to power the dock.