Actiontiles and displaying embed video

Tried posting in actiontiles forum but it’s awaiting moderation now for over a week so not holding my breath.

Basically, all of my fire tablets running actiontiles could display and have displayed my embedded videos for yrs now using my nvidia shield as a server running TinyCam. Now all of a sudden they are not getting displayed for whatever reason. Not sure if it’s an actiontiles, browser, fire tablet issue.

Edit. Forgot to say. This is running through fully kiosk browser.

Has anyone else experienced this lately.

Tagging @625alex

1 Like

I would bet money the fire tablet took an update that results in a codec problem. Do you block Amazon updates on that tablet in any way? What do you get from another machine that is not this tablet - does the video play?

Yes it’s true in that the same set up worked on my iPads. But what really struck me was that I don’t think it’s a fire tablet update issue because some has the same version yet one works and the other doesn’t.

Though, on the ones that have issues. Actiontiles video embeds don’t work in any browser at all on that particular fire tablet (silk and chrome ) so it’s not an actual actiontiles issue as far as I know but I’m not tech savvy enough to begin to understand how all this works.

Same version of what?.. There’s a chain of software that goes together on a fire tablet to make stuff work. If I’m not mistaken the relevant stuff is in the Android Webview component in the tablet.

Unfortunately for you Android Fire Tablets are always woefully behind those system components…

Given what you have if you review the bill of materials for what you have installed (updates, show system updates, look at everything in the list. Particularly, Android Webview) on the tablet that works v. The tablet that doesn’t your evidence points to something being different between the two. Find that it’s probably your culprit.

Can you roll back system updates on fire tablets because I suspect now it’s a system update that messed things up. :frowning:

EDIT. Actually think now it’s system webview as you said. I can’t roll that back or even uninstall it but it’s a different version on the ones that work and the ones that don’t work. Seems some may have updated automatically.

1 Like

Nope system webview is the devil on those things.

You’re going to have to start troubleshooting the codec v. Webview support angle.

Looks like version 110 works fine. Anything above that doesn’t.
Though on the fire tablets it’s Amazon system webview and not Android system webview.

The Android system webview can be installed via apk but I can’t do any roll backs etc on Amazon system webview so looks like I’m stuck.

Other folk must be having this issue on fire tablets surely?

I don’t view video on my tablets… so maybe?

More and more browsers nowadays do not permit Mixed Content, which is the mix of HTTP and HTTPS. The immediate effect of this is the failure to load local video streams that are served over HTTP.

We did some work to try to work around this issue in the ActionTiles mobile app, which will be re-released next week or so.

For some workarounds and discussion, follow this thread on ActionTiles Support forum.

Thank you. I’ve just tried these solutions and still doesn’t work. Actiontiles works within Firefox still but doesn’t work within chrome. Also doesn’t work within fully kiosk browser so I suspect fully uses chrome some way. So you guys are working on a solution on your end? Is there anything the end user has to do?


EDIT. : also, some of my fire tablets still show video within chrome and within fully kiosk browser but these ones haven’t updated their FireOS to the latest version. I also suspect it’s something to do with Amazon system webview but I’m not tech savvy enough to know this for 100% certainty