SmartThings Community

Fibaro Dimmer 2 Integration


(Stephen Hill) #27

Can anyone help with a bit of wiring advice? The switch on the left is the one I want to use for my Fibaro Dimmer, but I’m unsure as to the best / correct way to wire it up. Anyone able to help?



(John Crighton) #28

That looks bog standard to me, and everything you need should be in the instructions.

If you’re at all unsure or not confident, you should use an electrician. Taking these things on yourself is one thing (although technically against the law, even in your own house if you’re not an electrician). Advising others on internet forums is quite another.


#29

Every time I try to create a code I get this message below, and it won’t let me create it. I’m only trying to directly use one of the codes here. I haven’t changed anything as I’m unsure what to change but it seems I have the same setup as shazbot.

If anyone can help I’d be very grateful.

No signature of method: script14707559575621462335626.metadata() is applicable for argument types: (script14707559575621462335626$_run_closure1) values: [script14707559575621462335626$_run_closure1@4f85bd41] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)


(John Crighton) #30

You should be using @Rajiv 's code: Fibaro 2 Dimmer (212 not 211)


#31

Thank you for your help although when I tried this code, I had the same response. I’m a real novice so any help greatly appreciated. I literally copy and paste. Should I be changing anything specifically?


(John Crighton) #32

If you’re struggling, @JDRoberts ’ FAQ is worth a look:

Edited to add - this is a device handler rather than a smartapp, just in case you’re trying to create a smartapp with the code.


#33

That’s what I was doing! Thank you. I will try Rajiv’s code. In a previous post you mentioned you commented out a parameter. What does this mean? All I need to do is make S2 work and both on momentary switches.
Many thanks


(John Crighton) #34

There’s a parameter section in the manual for the module, well worth a look over as it explains a lot about what it can do. Previous to Rajiv’s code, it was necessary to go into the development interface to set (or comment out) parameter settings.

Now these can be accessed directly through the ST app on your phone (cog icon). You will need to play around with these to get S2 to do what you want it to do.


#35

I will have a read through that tonight. Could you just tell me, the cog icon just takes me into a section that says the device name and ON, then Give your device a name and the name again and then two buttons saying replace and remove. Am I looking at the right thing?


(John Crighton) #36

You’re looking at the right thing, although it doesn’t sound like you’re using Rajiv’s code (or at least the most recent variation) as there should be a lot more in there.


(John Crighton) #37

Sorry! I’m getting my devs confused. Rajiv made the original, it was @hajar that made the much improved version.

Here you go…


#38

Thanks for your help. Still working through it all but I feel more knowledgable than I did yesterday so it’s going the right way!


(Ciaran Lacey) #39

Hi, any news on the official ST certification on the Fibaro Dimmer 2? - I have the latest SmartThings Hub and the Fibaro FGD-212 installed - but not sure how to pair it to my hub as there is no such device listed in the app. Have others got this working? How do you pair it up?


(Ciaran Lacey) #40

I discovered that you can pair the Fibaro Dimmer 2 through flicking the light switch on/off three (3) times - whilst selecting the clicking on “Add a thing”, “Start looking for Things” … and eventually it paired. This is great to know as the unit was installed behind a wall and not easily accessible.


(Ciaran Lacey) #41

Hi,

I have installed three (3) Fibaro Dimmer 2 (FGD-212) switches in my home.

Number 1 dimmer is in my front room
Number 2 dimmer is in my hall (with immediate <1 Meter proximity to dimmer 1)
Number 3 dimmer is in my master bedroom (top of stairs) ~15 Meters away from the hub controller

I am using a Smartthings Hub 2 controller.

All devices have been found/discovered and are paired to my Smartthings hub and visible on my Smart phone app.

All devices operate (on/off/dim) as expected using the physical switches connected to the dimmers, so they are all fully functioning as expected.

I can connect to and control dimmer 1 from my smart phone via the Smartthings app and I have full range of control and dimming as expected.

When I view the logs on my account I can see clean messages being sent during successful operation.

e.g. 7:35:38 PM: debug UNHANDLED COMMAND Crc16Encap(checksum: 6, command: 5, commandClass: 49, data: [4, 34, 0, 122, 166])

However I CANNOT control dimmers 2 & 3 at all via the Smartthings app (they are simply unresponsive to any control commands sent to them - e.g. on/off command or dimming level commands).

They are all installed (wired) identically in line with the first dimmer (1).

When I check the logs during attempted operation on these additional dimmers I get a security error:

e.g.:
7:31:46 PM: debug UNHANDLED COMMAND SecurityMessageEncapsulation(commandByte: [0], commandClassIdentifier: 38, commandIdentifier: 3, reserved13: 0, secondFrame: false, sequenceCounter: 0, sequenced: false)

So I am getting a log entry for each of these additional dimmers that are attempting to respond to my commands - they just simply are not working. At least I know that they are paired AND communicating with the Hub.

Any ideas how to resolve this? Could it be a firmware difference on the other dimmers? How can I check?

Note: This is not a range issue as I have physically moved the Smartthings Hub 2 to be in range (beside) each of the installed Fibaro dimmers.

Thanks

Ciaran


(Ciaran Lacey) #42

Hi, just an update to this. Thanks to this Community forum I have managed to get my devices to work. All the answers are in this great forum, it just takes the patience to read it through. So to answer my own question - the unhandled commands can be handled by creating a “device handler” for the unsupported Fibaro Dimmer 2 device and then altering the code (in my case a single digit) to get it to function the way I needed it. It’s not as scary as it sounds - all the help is over in this thread, so apologies for my newbee question above, and good luck to others that have this experience. Fibaro 2 Dimmer (212 not 211)


#43

First post and I’m kicking myself because I found my way through the difficult bit without having to ask any questions that had already been asked/posted!

Last night I finally got my Dimmer 2 working both via the app and using the existing toggle switch - Worked like a dream after using Rajiv code!

Today I have returned home with a momentary rocker switch and larger back box… fitted them, works on the app but not on the switch. Tried the old switch - Nothing. Changed the code to allow for momentary switch (param 20 = 0) and but still nothing.

Any help would be fantastic please.

oh also tried calibrating just incase.

FYI - Once working this all works SOOOOOOO well with Alexa! Just need to stop my 3 yr old turning lights on and off now:rage:


#44

reset the dimmer to factory default and the switch works. paired the dimmer once again with ST hub and linked it with the code… lights turn on/off with the app but only turn on with the switch now.


(Giles Houghton) #45

Are you using a 2-way momentary switch/roller blind switch? Just make sure you’ve set the right param. Sounds like the input on S2 is being ignored, if you are using a 2-way.


#46

No a 1-way normally open press to close switch, I think I was the problem and was adjusting the wrong digit in the parameters…

zwave.configurationV1.configurationSet(parameterNumber: 20, size: 1, scaledConfigurationValue: 0), // Enable Dimmer to work with 3 Position Momentary Switch

I was editing the size rather than the value. What does the size refer to? I assume the text after the // is a side note and not a command?

Sorry I don’t have much experience with coding. Thank you for your input