FAQ: Use Aeon Minimote for Inclusion

Just got an Aeon Minimote G1.1 (Older Version) and did the below and it was working perfectly in just mins… I have a 1D status and a v2 Hub and the minimote installed and works 100%, so don’t seem related.

I’ve only been experiencing an issue with the GE45600 on the v2 Hub with the below data:

zwaveControllerStatus: 1D
zwaveNodeID: 01
zwavePowerLevel: 0
zwaveRegion: 1
zwaveSerialVersion: 0
zwaveSucID: 00
zwaveVersion: 0000

GE45600 RETEST
Since it looks like we thought the minimote and GE45600 issues were related, I fully excluded my GE45600 with the 967 command via the ST App and that was successful, next did a factory reset on the GE45600 x2 with the 969 command, then a Connect New Device via App and a 967 inclusion command on remote, it recognized it as a Z-Wave Remote and completed config successful.

Tested the “All On/Off” from the remote, worked good. Next tried to program a button on the GE45600 (Hold Setup till double flash on leds, Add, Light, Select a button and the green light continues to flash till a zwave device on the network is cycled, unfortunately the remote does not recognize the cycling of any zwave device and just times out and quits.

AEON LABS AEOTEC MINIMOTE SETUP
(DSA03202W-ZWUS)

-Charge (Plug into USB Charger/Jack), red light will turn blue when complete.

-Reset the Minimote by holding down both bottom buttons about 10 secs till both leds go solid and drop out.

-Update Firmware via USB cable, latest ver is - minimote_US_1_19_A
(Download available from: http://aeotec.com/downloads/)

-To connect the Minimote to the Hub, in the SmartThings mobile app:

  1. Tap Marketplace (Bottom Right Star-Like Button on Home Page)
  2. Under Things, tap Entertainment
  3. Tap Remotes & Buttons
  4. Tap Aeon Labs
  5. Tap Aeon Labs Z-Wave Minimote
  6. Tap Connect Now
  7. The app will indicate that the Hub is looking for a device of that type or name
  8. While the Hub is searching, press the “Learn” button on the Minimote (Depending on your version, it may be labeled “Join”, either way it is the bottom right button under the sliding cover, see pic)
  9. The app will indicate that the Hub found the device and direct you to configure it
  10. Tap to name the device
  11. Tap Select a Room to assign the device to an existing Room or Add a Room
  12. Tap Next
  13. Follow the in-app prompts to configure the device under “Button Controller”
  14. When you finish configuring the device, tap Done.
2 Likes

The 1-4 buttons on the minimote still work with this issue, you just can’t use it to include other devices. As I mentioned, the GE remote is non-functional only because it uses inclusion (or re-inclusion) to assign devices to buttons (which is also why we can’t get it to send events to the hub).

yep

zwaveControllerStatus: 1D

zwaveSucID: 00

@duncan So, is this something I should open an RMA for to get an exchange on my hub? I know that a Z-Wave controller can assign a node as a SUC, but from what you are saying, this problem isn’t a high priority for SmartThings to fix (which I understand).

Don’t get me wrong, I really, really, really don’t want to re-do my SmartThings set up, but I also don’t want to hold onto a defective device (if that is the case).

Also, what do the different zwaveControllerStatus mean? Does 01 mean the controller is a SIS controller or what? I’m just curious.

zwaveControllerStatus: 1D
zwaveNodeID: 01
zwavePowerLevel: 0
zwaveRegion: 1
zwaveSerialVersion: 0
zwaveSucID: 00
zwaveVersion: 0000

This is what mine is showing

good question-

@duncan - I was under the impression it’s just a software issue and there’s some combination on my hub that triggered the issue.

BUT- is this possibly a hardware issue and i should get an exchange?

Understood it’s not a priority, and i already fixed my problem with a 100ft ethernet cable, so if it’s software then no worries, but if there’s a hardware issue with the chipset in this one I’d want an exchange so it doesn’t come back to haunt me in the months, years to come…

If you could confirm it’s just a software issue that would be great.

Yes it’s software. Worst case scenario would be needing to reset the network, but there won’t be a need for returning the hub. I’m quite optimistic that I can find a fix that won’t require rebuilding the network.

1 Like

Hey Duncan, any updates on this one? I am thinking about going back to my v1 since there seems to be very little benefit to the v2 and less functionality.

I haven’t had a chance to work on it, sorry. There shouldn’t be a need to go back to v1 – I’d expect resetting your z-wave network would suffice, which is the same level of effort. To reset a hub’s z-wave network, delete the hub or location while the hub is online. When you claim it again, make sure the zwaveSucID is 01, otherwise repeat.

1 Like

Will deleting a location and re-claiming it cause any issues to my existing set up and smart apps? Re-claiming would require the Welcome Code, I guess?

I think I figured out what is causing this, though in order to be sure the fix works I need to try it on an affected hub (internal to SmartThings, no volunteers please). Unfortunately it wasn’t in time to make it into the latest firmware release, but it will be in the next one whenever that comes.

Ashutosh, I replied to your question in the other thread, but just to have the answer here: yes, if you delete the location you will have to set up everything again. I would suggest waiting for the next update instead.

4 Likes

@duncan Got today’s update to my v2 hub. Looks like the SUC ID issue has been fixed. I had to remove and then add my secondary controller, but it now seems to be functioning normally. Thanks for sorting this out!

3 Likes

Awesome I hope mine is working after the update as well!

My minimote just arrived. Does the minimote need to be added to the SmartThings list of things first?

Nope, it’s supported by default. Just discover new device and hit the pair button on the minimote.

1 Like

If it’s a v1 minimote, make sure to download and update the firmware for it!

But, it just requires you to discover new device and go.

1 Like

Keep in mind you use the Learn or Join button to add it to SmartThings, not the Include or + button.

Did you manage to pair your devices with smartthings then with the minimote also?

I have a GE Zwave Fan Switch and Aeon light module which I use to control a single fan. I have both zwave devices paired to ST. Can I use the Aeon minimote as a secondary control in the event I loose internet so I can still control my fan?

6 posts were merged into an existing topic: Sudden problem with (2) Aeon Minimotes since yesterday