Embarrassingly failing at the first hurdle

So I treated myself to an Echo for Christmas, and I’ve ordered my Hue lights and Smartthings Starter kit (with an extra Presence sensor), due to be delivered in the next few days, and Ive been reading up on the types of automations I want to run.

From what I’ve seen here, CoRE is vital to creating really “smart” routines.

I’ve created an account on the UK IDE site, and created a GitHub account, but the link “Enable GitHub Integration” isn’t displayed for me.

Am I missing something blindingly obvious?

Did you click device type handlers? or smart apps? should be there on top right below menu. maybe this helps

Some community members have had to ask support to enable this for them. I never heard the details on why this happens to some people and not others. But support should be able to help.


@aaron might know why this block only seems to affect some people in the UK.

I had a live chat with support, and decided to do the manual install in the end! He explained that it is US only at the moment, and although it can be done, can cause problems.

So, now to get started with CoRE…