[EDGE] Universal Enhanced Z-Wave Lock Driver for Schlage, Yale, Kwikset, IDLock, Popp, Danalock, August Pro, Keywe, Philia, Samsung

Thx Il look into that.
Have you done this your self?
An example would be perfect if so :slight_smile:

Cool this method delivers the rfid chip number.
Sometimes it returns “Id-lock lock is unlocked” even if i use a rfid.
I never get the slot number 1 if i use the keypad thoug. is that another value?

It does show “1” when code is used.
Whats confusing is that it is not stable in what it reports.
Lots of times it gives a “null” and sometimes it returns the slot number.
End edit

FYI Solved @RBoy and @ady624 regarding the “null” on [data.usedCode] WebCoRE [$args.usedCode]
Found out the following.
When my lock has reduced battery capacity. (Show 100% in the DH, so the lock probably reports 100%)
it does not report correct user code for the most.
The lock it self started reporting low voltage, and i changed it.
Then i reports right user slot close to 100% of the times.
Thought it might was a useful finding.

1 Like

@RBoy I’m planning to buy the Yale push button zwave deadbolt. Is there a good way to run a goodbye routine when a certain code is pushed to Lock the door when leaving?

Yes, very much so. Disable the one touch locking feature and using the Lock User Management app below you can configure actions for each user when the lock using their code.


I did download this smartapp, but don’t have a lock yet to test that feature. I assume it lives in the “Click here to define actions and notifications when doors are opened/closed” as nothing is visible in that tab.

Once I do get the lock, is it also possible for the one touch locking feature to run a routine? Thanks

1 Like

No that’s for door open/close actions (like relocking etc, they will show up once you select a lock)

The user lock and unlock routines are on the users page and for each user

You can define it per user or globally by default, when you’ve enabled the one touch locking it will use the global settings (since there isn’t a specific user when using one touch locking)

1 Like

I have 2 yale locks and since i installed this app my batteries drain pretty fast… In notifications every minute i keep getting…

Requesting lock to add permanent code xxx to user 1 code xxx

I think this is my issue… Any thoughts?

Did you run the Clear Codes procedure on the website after installing the DH/App? If not do that first.

Second the lock should be no more than 10-15 ft from the nearest active z wave repeater device or hub.
Basically your lock isn’t confirming back to the hub that the codes were added which is why it’s requesting the lock to add the codes.
That is either a corrupt database (which clear codes will clear up) or a communication issues which means you need a stronger z wave mesh.

If you do not want the verification feature you can turn it off. Open the SmartApp and on the first page at the bottom under code programming advanced settings enable the option to ‘Enable incremental updates only and disable code verification’

After installing this, I noticed my device’s execution location switched from Local to Cloud. Can this device handler not run in with execution location of local?

All custom Device Handlers run in the cloud. Only SmartThings Device Handlers specifically added to firmware run locally.


So I had the MSR is null error others have had, but I fixed it in a relatively unique manner. I noticed my lock began reporting a valid MSR later on in the day, so I just changed the lock’s device to the generic Z-Wave lock device handler and then switched back to the Enhanced Z-Wave lock device handler and it picked everything up without error. Didn’t have to remove/re-add the device or anything.

1 Like

Any idea why my Kwikset 914 is showing MSR: 0063-4944-3034?

I’d hate to have to exclude/pair and loose all my app associations…

Pairing issues, the hub firmware has some bugs, it happens sometimes. I’ve seen this reported 2 times in the past week with Kiwkset locks, don’t know if it’s related to the Schlage MSR firmware bug (@nastevens ), exclude and repair is the best fix for correct the MSR.

If you’re on the latest code, try this, it will force the lock to resend the MSR. Click on the gear icon on the top right to get to the device configuration page. Then click on Done. Now click on Refresh (watch your Live Logs), it will force a MSR request from the lock. If that fixes it great, otherwise you’ll have to exclude and re pair it.

As suspected, an exclude and re-pair was required to correct the MSR. All is well now. Thanks sir.

1 Like

@Duncan FYI - seen a few reports of kwikset lock having reported the wrong MSR

Schlage lock is showing locked but it isn’t. Also no smartthings lock commands are working. Pressing ‘schlage’ on the outside is working to lock.


Is there a recommended way to remove lock then add without losing all the associated webcore/routines/smart lighting automation?

Your lock has lost it’s connection with the hub, reboot the hub, exclude and repair or add some Z-Wave repeaters between the lock and the hub.

Unfortunately there’s no way to remove locks in ST without losing the SmartApps, it’s a real pain I know. You can only replace a lock with another lock.

One trick is to reset the device so it resets it’s connection also (i.e. forgets the pairing), then click on Replace in the device removal page and then pair the device. SmartThings will think it’s a new replacement for the existing devices and pair it and move all the SmartApps to the new device.

1 Like

As Requested by Rboy i moved my conversation to this one.

Now my Kwikset lock is showing as online and health is showing healthy but the app is showing the door as unlocked but its not. no response to any controls(unlock or lock) but the hub is recognizing and logging the lock activity when manually unlocked/locked.

I have tried to run a zwave repair and get the following:
Network repair for Front Door Lock [03]: Failed to update route

Any thoughts or suggestions would be great.

@RBoy I removed the lock from my hub…i tried to remove it from the app but it failed. so i deleted it from my devices on the web but first removed it from the Lock multi user code management application . Now I cant add the lock back. my codes programmed are still working. any ideas on how to reset the lock or am i missing a step. I appreciate your help or anyone elses. thanks. My model is a kwikset 910. I may add an extender but not sure this is my issue.