Edge Shelly drivers for Gen1 and Gen2 Devices

@TAustin , I installed the driver for my Shelly PLus Uni, and using the v. 1.5 driver. (The 1.9 version will not go online) The driver installed normally, and went online after inputting the IP address. The on/off buttons on the interface appear to work when pressed, but have no effect on the Shelly state, and none of the input functions seem to be receiving any data either. Do you have any suggestions on getting this driver to work?
Thanks for your excellent efforts on this project.

Hi there. You’ll definitely need the Gen2 driver (Shelly Gen2 Device Driver V1.5), however that I hadn’t included support for the Plus Uni yet. I will add it in my next update, which I hope to have out shortly.

Can you please do me a favor and in a browser address bar type in the IP address of your Plus Uni device followed by ‘/shelly’? For example:

192.168.1.150/shelly

I need to see the shelly id value they are using for the Plus Uni device.

FOLLOW-UP:

After looking at the specs for the Uni device, I see it has something new: a counter input field. However the API docs don’t show how the value is actually sent. So can you do me another favor and try this from a browser address bar (substituting your own device’s IP address):

http://192.168.1.150/rpc/Input.GetStatus?id=0
http://192.168.1.150/rpc/Input.GetStatus?id=1
http://192.168.1.150/rpc/Input.GetStatus?id=2

Let me know the results. Thanks.

1 Like

Thanks for responding. The results you asked for are as follows:{“name”:null,“id”:“shellyplusuni-d48afc79f8d0”,“mac”:“D48AFC79F8D0”,“slot”:0,“model”:“SNSN-0043X”,“gen”:2,“fw_id”:“20240223-142029/1.2.2-g7c39781”,“ver”:“1.2.2”,“app”:“PlusUni”,“auth_en”:false,“auth_domain”:null}

{“id”:0,“state”:false}
{“id”:1,“state”:false}
{“id”:2,“counts”:{“total”:0,“by_minute”:[0,0,0],“minute_ts”:1712332320},“freq”:0.00}

1 Like

– DRIVER UPDATE NOTICE –

Driver Name: Shelly Gen2/3 Device Driver V1.6

If you already had the Shelly Gen2 Device Driver V1.5 installed, then it will automatically get upgraded to this new version.

The Shelly Gen2 driver has been updated to be able to support Gen3 devices as well. I’ve started by adding support for the Gen3 PM Mini (@William_Kaper), but can add additional devices as the community requests.

Additionally, Gen2 Shelly Plus Uni support has been added (@garhun).

Also for awareness: A change was made to the SmartThings platform & mobile apps that has broken the ability to display tables of information such as what is used in the wifi and device components of the Gen2/3 devices. So unfortunately, with the latest mobile app, you’ll only see HTML gibberish in those device fields right now. I’m hoping that SmartThings will provide some kind of alternative for displaying multi-line text, but in the meantime you’ll have to ignore those fields. If it looks like a solution from SmartThings is not forthcoming, I may have to remove or modify those fields.

4 Likes

Hi @TAustin , Gen3 appears to be working. Im going to test with some automations, but on the surface everything looks great!

Thank you for adding this!

-Bill

3 Likes

10 posts were split to a new topic: Can’t get Shelly Uni to work with taustin edge driver

Edit - I got one of the i4 working by uninstalling the driver and then reinstalling, rebooting the hub and adding the device. Still can’t get the second one connected.

Hi, I’m using the Gen 1 and Gen 2 Edge drivers for a number of devices without any issues. I recently installed two i4 devices and added them to the Shelly app no problem, I can add them via auto discovery with the Gen 2 driver, however they don’t link with the device. Tried resetting and re-discovering them a couple of time but same result. Any ideas??? Thanks.

@TAustin
On behalf of the whole community, I’d like to thank you for all your work! It’s incredible what you can and do, especially as you rely on the community for testing and your fixes are based on this!

I’ve been one of your Shelly Gen1 drivers users for a long time. Back then there was the device creator to add a device and allocate the IP address. All working good there.
I recently bought three Shelly 1 Mini Gen3 for some other lights and despite your new Gen2 Gen3 driver installed, auto discovery can’t seem to find it.

I’ve read several posts above and not sure what am I missing or doing wrong, unless your driver doesn’t include the JSON for these new relays? If so, please find the below and hope it helps!

{“name”:“OutsideGarden”,“id”:“shelly1minig3-5432045f6680”,“mac”:“5432045F6680”,“slot”:1,“model”:“S3SW-001X8EU”,“gen”:3,“fw_id”:“20231121-110944/1.1.99-minig3prod1-ga898543”,“ver”:“1.1.99-minig3prod1”,“app”:“Mini1G3”,“auth_en”:false,“auth_domain”:null}

Thank you in advance!

1 Like

For what its worth, I was using a Smartthings Wifi hub when I had these issues. I ended up updating to a V3 Aeotec hub and this has resolved all the issues I was seeing.
Love the driver. Thanks!

1 Like

Hey Keith, thanks for the answer. I’ve been using the ethernet V3 hub since the beginning, so perhaps a red herring this time?
I wonder what’s @TAustin opinion if perhaps the mini gen 3 are too new for this driver?

Hi,
I added the 1.6 driver to use with shelly plus 2pm.
I can see the modules, open/close the window shutter but if I open it partially by pressing the open button and stopping it, I can’t see the open percentage.
Can you help me with this please?