(EDGE Driver-Mc): Zigbee Light Multifunction Mc

This coincides with the diagnosis of yesterday’s logs.
turn On, level and color temperature change have been resolved.

I have put this TS0505A model back to color x,y like all the others and this should solve the color change problem.

Install with the CLI this version of the driver and try

───────────────────────────────────────────────────
 Name         Zigbee Light Multifunction Mc              
 Version      2023-05-23T17:44:17.40335671
───────────────────────────────────────────────────
1 Like

Superb, Mariano
Now it works.
Thank you so much

1 Like

I’m glad it works, these Tuya devices have many traps, depending on the version of each manufacturer.

Could you please delete the logs, they are no longer needed. It’s a very long thread

thank you

1 Like

Superb, Mariano

Could you add below device? It is tuya RGB downlight.

Device Information:

Manufacturer:_TZ3210_s9lumfhn
Model: TS0505B
FingerPrinted_EndPoint.Id:0x01
App Version: 0x70
ZCL Version: 0x03
Network ID: 0x7206
Zigbee EUl: A4C1386A90FA8DF1
Device ID: c803da54-f442-473d-95f2-eb6184beb53f

Server Cluster:
Ep: 0×01={
0000,0003,1888,0004,0005,0006,0008,0300,000A,1000,FFEE }

Client Clusters:
Ep: 0x01={ 0019,1000,FFEE }

Very thanks,
Jay

Hi @Jay_Bae

Added to this driver version

───────────────────────────────────────────────────
 Name         Zigbee Light Multifunction Mc            
 Version      2023-05-26T10:52:43.859437424        
───────────────────────────────────────────────────
- id: "_TZ3210_s9lumfhn/TS0505B"
    deviceLabel: RGBW TS0505B
    manufacturer: _TZ3210_s9lumfhn
    model: TS0505B
    deviceProfileName: rgbw-level-colortemp-2000-6500
1 Like

Could i bother you to add these lights to the driver?

Manufacturer: GLEDOPTO
Model: GL-G-002P
Endpoint: 0x0B
Device ID: 0x010D
Network ID: 0xB1B6
Profile ID: 0x0104

Server Clusters:

0x0B

0x0000, 0x1000, 0x0300, 0x0003, 0x0004, 0x0005, 0x0006, 0x0008

Client Clusters:

OTAUpgrade: 0x0019 - 0x0B
?: 0x0021 - 0xF2


Manufacturer: GLEDOPTO
Model: GL-G-001P
Endpoint: 0x0B
Device ID: 0x010D
Network ID: 0xAD6C
Profile ID: 0x0104

Server Clusters:

0x0B

0x0000, 0x1000, 0x0300, 0x0003, 0x0004, 0x0005, 0x0006, 0x0008

Client Clusters:

OTAUpgrade: 0x0019 - 0x0B
?: 0x0021 - 0xF2

Thank you :slight_smile:

Hi @Axsim

Added to this driver version

───────────────────────────────────────────────────
 Name         Zigbee Light Multifunction Mc          
 Version      2023-05-31T14:22:40.116781976        
───────────────────────────────────────────────────
- id: "GLEDOPTO/GL-G-002P"
    deviceLabel: GLEDOPTO GL-G-002P
    manufacturer: GLEDOPTO
    model: GL-G-002P
    deviceProfileName: rgbw-level-colortemp-2000-6500
  - id: "GLEDOPTO/GL-G-001P"
    deviceLabel: GLEDOPTO GL-G-001P
    manufacturer: GLEDOPTO
    model: GL-G-001P
    deviceProfileName: rgbw-level-colortemp-2000-6500
1 Like

Amazing, thank you so much for what you do for the Smartthings Community :slight_smile:

About how long does it take before the driver updates?

1 Like

12 hours max

2 Likes

Hello
Could you add the following Track magnetic light

manufacturer: _TZ3210_x8ay4yvz
model: TS0502B
FingerPrinted_EndPoint.Id: 0x01
App version: Unknown
ZCL version: Unknown
Network ID: OxDAF0
Zigbee EUI: A4C138E4F44669B0
Device ID: f060842c-4e39-4081-93a6-81bc537838ac

Server Cluster: Ep: 0x01{0000,0003,1888,0004,0005,0006,0008,0300,000A,1000,FFEE}
Client Cluster: Ep: 0x01={0019,1000,FFEE}

Thank you very much!

Hi @dotksh and @abdiel.im, manufacturer: _TZ3210_pgq2qvyv, model: TS0502B

Added to this driver version

───────────────────────────────────────────────────
 Name         Zigbee Light Multifunction Mc            
 Version      2023-06-03T15:39:31.463352105        
───────────────────────────────────────────────────
- id: "_TZ3210_x8ay4yvz/TS0502B"
    deviceLabel: TS0502B LED
    manufacturer: _TZ3210_x8ay4yvz
    model: TS0502B
    deviceProfileName: level-colortemp-2000-6500
  - id: "_TZ3210_pgq2qvyv/TS0502B"
    deviceLabel: TS0502B LED
    manufacturer: _TZ3210_pgq2qvyv
    model: TS0502B
    deviceProfileName: level-colortemp-2000-6500

Hi, @Mariano_Colmenarejo
During my recent stay in Germany, I brought to Spain a Zigbee mood light from LIDL:


If you could take the time to add this model to your light controller, I would be very grateful.
It has a built-in battery, but I don’t know if it is possible to attach a battery status report function to the controller? If it’s not possible, just being able to control the light would be great.

Mil gracias!!!

Hola @norberto_bcn

Added to this driver version

───────────────────────────────────────────────────
 Name         Zigbee Light Multifunction Mc            
 Version      2023-06-05T08:37:24.507396657        
───────────────────────────────────────────────────
- id: "_TZ3210_r0xgkft5/TS0505B"
    deviceLabel: RGBW TS0505B
    manufacturer: _TZ3210_r0xgkft5
    model: TS0505B
    deviceProfileName: rgbw-level-colortemp-2000-6500

It doesn’t use the standard 0001 cluster, it may use the EF00 custom cluster to report battery, but I’m not sure and I don’t know how to handle it either.

2 Likes

Eres un crack! Gracias!!!
Thanks!!!

1 Like

Hello
Could you add the following Track magnetic light

manufacturer: _TZ3210_8evra4gu
model: TS0502B
FingerPrinted_EndPoint.Id: 0x01
App version: 0x65
ZCL version: 0x03
Network ID: Ox239B
Zigbee EUI: A4C138B1C2323C26
Device ID: 2d185cc8-9aff-4d61-8f3d-122cc20fb219

Server Cluster: Ep: 0x01{0003,0004,0005,0006,1000,0008,0300,EF00,0000}
Client Cluster: Ep: 0x01={0019,000A} EP: 0xF2:{0021}

Signal Metrics: LQI:202 … RSSI:-77dbm

Thank you very much!

Hi @dotksh

Added to this driver version

─────────────────────────────────────────────────── 
 Name         Zigbee Light Multifunction Mc            
 Version      2023-06-07T15:59:31.37896335
───────────────────────────────────────────────────
- id: "_TZ3210_8evra4gu/TS0502B"
    deviceLabel: TS0502B LED
    manufacturer: _TZ3210_8evra4gu
    model: TS0502B
    deviceProfileName: level-colortemp-2000-6500

@Mariano_Colmenarejo I have been using your drivers to run all my lights and I am very happy with it.

However, I have one issue with them: if they are turned on by a routine, the bulbs don’t take the new colour settings in the routine. They start with the correct brightness, but always retain the colour settings from the previous time it was on.

I have tried using On/Off in the routines, as well as not using On/Off at all and only using the dimmer settings (dimmer 0 for off, dimmer 70 for on, etc., with no selection in on/off). But the colour is not changed from the previous time unless I manually set it again, or another routine runs when the light is already on.

How can I fix this? Thank you! :slight_smile:

Hi @rowschank

I don’t know what your routine is like.
It works well for me like this, it always lights up in the color of the routine, regardless of the previous color in the bulb

This is what my routine looks like and it is activated when the bulb is not on.

Brightness and colour changer settings apply directly but not colour settings and always starts with the previous colour…

I’m sorry, I don’t know if you’re talking about color or color temperature.

In your routine you are not sending any command to set a color, you are sending a command to set a color temperature of 3500k.

I have tried it and it works fine for me, it finds 70% and 3500k and previously bulb was in red color

1 Like