(EDGE Driver-Mc): Z-wave Remotec ZRC-90 Scene Master and Namron Button Remote Mc

Everything working perfect.

I ordered 3 ZRC-90 remotes and ofc i missed this post and added it using old DTH method which never worked and are very complicated, my ftrst remote kind of screwed and i could not figure out how to reset it, but as soon as i added fresh out of box 2nd and 3rd remote everything installed correctly and as expected, all buttons working and response time about 0.5 seconds. Thanks !

Hi @Mike_Se

Here the web for manual download.


ZRC-90​ – Remotec Technology

I think you must press R key to enter in remove Mode and R+L or W+L Keys to inclusion mode.

1 Like

I tried device reset and exclusion from wave network multiple times for this specific device. I believe it’s some type of fingerprinting inside ST hub itself. Hub memorizing unique device ID and keep adding it the same way without edge driver

Not sure what’s different today , but after waiting overnight and restarting ST Hub, my 3rd controller finally installed correctly.


Hi there. I have this installed and working now, thank you! But showed up as executing in the cloud instead of local. How do I change that?

Hi @abangalore

All edge drivers work local.
Run in your hub

The IDE info for edge drivers is bad

1 Like

Thank you. Anyplace where the correct info is available now?
Also, any idea if the sengled zigbee smart switch has an edge driver? Can’t find any reference to it

Only in the API and in the routines you will see the symbol of a small house, which is local execution

1 Like

I have Enrolled this driver and tried to Add a new ZRC-90.
It came in with the previous NonEdge Device Handler [erocm123 : Remotec ZRC-90 Scene Master]
1 How do I remove it from the Hub (ie do I need to exclude it somehow)? and
2 Do I have to remove the Older DTH first
This would be an issue as I want to get this one on Edge so I can add it into the Routines before I remove my older DTH unit.

If it is a custom DTH then you have to delete it before or comment with // the fingerprints on the DTH and republish it

If you just comment out the fingerprint in the DTH then older devices using that DTH will still work, but any new device you add will use the Edge Driver instead.

1 Like

@Mariano_Colmenarejo and @JDRoberts , I will try and comment out the fingerprint, otherwise will just remove DTH and start again.

However, this is my only Zwave device so unsure about whether, and if so how, I will need to β€œexclude” the zrc-90’s first?

I have installed this driver and added the zrc-90. There are, however, several issues.
1 pressing any of the 8 buttons only cause the β€œmain” button to light in the driver screen.
2 setting a routine on any button 1-8 therefore does nothing.
3 if I set a routine for the β€œmain” button, pressing any button 1-8 will operate that routine
4 so there are in effect 8 of the same button.
5 also I see that each button can have multiple presses as well as mutiple ToggleUps and multiple ToggleDowns - what is the relevance of this for a zrc-90 which simply has 8 buttons?

PS each button shows
Double pressed
Pressed 2, 3, 4, 5, 6 times
Toggled Down and toggled Down 2, 3, 4, 5, 6 times, & Held Down
Toggled Up and toggled Up 2, 3, 4, 5, 6 times, & Held Up

This is the same for all 3 zrc-90s I have attached
Driver is β€œZ-Wave Button Mc”

Hi @Geoffs

This worked fine, I don’t know why it doesn’t work for you

Try this version of the driver

 Name         Z-Wave Button Mc
 Version      2022-10-27T11:45:13.716185987        

Today the driver shown in ST matched the new one.
Still displayed same behaviour.
Force zwave removed one zrc-90 and Scanned nearby again and still get exactly same behaviour as my last post.

Hi @Geoffs

It’s strange, no one else has complained about these devices

Please, could you switch to the Z-Wave Thing Mc driver to send me the fingerprints? it could be that it is a different model and or it is configured well

1 Like

Have removed the Zwave Button Mc driver and installed the Z-Wave Thing Mc driver.
From the IDE I get :
Raw Description zw:S type:0106 mfr:5254 prod:0002 model:8510 ver:1.01 zwv:4.05 lib:02 cc:5E,85,72,21,84,86,80,73,59,5A,5B ccOut:84,5B
It may be different model variant as I am in Australia!?

Hi @Geoffs

Added productType 0002 in this driver version

 Name         Z-Wave Button Mc
 Version      2022-10-29T09:42:59.036484979        
1 Like

Thank you very much for that.
Quick tests indicate working well, will test further a little later.
Again thanks for All the work you are putting in!