(EDGE Driver-Mc): Z-Wave Edge Drivers and others with FIBARO devices:

Yes it works fine.

1 Like


Try to heat the probe to see if it emits any temperature event, since the refresh of the app does not work.
You can also do a refresh from my.smartthings.com

Please send logs with </>
looks much better:

2022-09-27T16:29:58.212926010+00:00 TRACE Z-Wave Switch and Childs Mc Found ZwaveDispatcher handler in zwave_switch β†’ Inovelli 2 channel smart plug
2022-09-27T16:29:58.216379135+00:00 INFO Z-Wave Switch and Childs Mc <ZwaveDevice: 357c880b-8013-4f84-9b66-5b2b25422d5f [B9] (Show Home Outlet)> emitting event: {β€œattribute_id”:β€œswitch”,β€œcapability_id”:β€œswitch”,β€œcomponent_id”:β€œswitch2”,β€œstate”:{β€œvalue”:β€œoff”}}
2022-09-27T16:29:58.227151260+00:00 INFO Z-Wave Switch and Childs Mc <ZwaveDevice: 357c880b-8013-4f84-9b66-5b2b25422d5f [B9] (Show Home Outlet)> emitting event: {β€œattribute_id”:β€œswitch”,β€œcapability_id”:β€œswitch”,β€œcomponent_id”:β€œmain”,β€œstate”:{β€œvalue”:β€œoff”}}
2022-09-27T16:29:58.237766677+00:00 DEBUG Z-Wave Switch and Childs Mc Show Home Outlet device thread event handled

Mariano wants them the other way. So I send them unformated.

1 Like

Tried but nothing to do as before not showing signs of life … the state does not work and neither does the temperature

Are these settings okay?

Hello @Mariano_Colmenarejo

Thank you very much for your work, very useful drivers.

Any idea to implement β€œFibaro Smart Implant FBGS-222”


Mariano, maybe the Smartthings Edge Developers are addressing some of this, but, I excluded and then included the Vision Z-Wave Dual Relay Switch I own using the ZWave Switch Mc driver and I have a couple of issues.

  1. After installing the driver, it creates a dual switch with Multi-Tile capability and the switch works well when using the Smartthings app.
    For switch 1, it is using the β€˜Main’ switch designation and for switch 2, it is using the β€˜Switch-1’ switch designation. I renamed β€˜Main’ to β€˜Foyer Lights’.
    a. Previously, when using the old DTH, it allowed me to (re)name each switch (relay). I could rename β€˜Main’ and β€˜Switch-1’. In my old scenario,
    I had β€˜Foyer Lights’ as the parent and had β€˜Foyer’ and β€˜Front Porch’ as children that I could control separately.
    b. The issue is when using Alexa to control the lights. The only device showing in Alexa is β€˜Foyer Lights’. I no longer have the ability
    to control both lights (Foyer’ and β€˜Front Porch’) separately. Please let me know if there has been any progress on correcting this issue with dual switches/relays.

  2. This issue is more informational and I do not think this is an issue with your driver. I had two ST Edge drivers installed on my hub. Your driver, ZWave Switch Mc
    and the Zooz Double Switch driver created by other developers. The issue is when I excluded and then included the Vision Z-Wave Dual Relay Switch which was the only device
    discovered during the Smartthings Hub Scanning process, both drivers where installed. Now, I am trying to figure out which device the Zooz Double Switch driver is β€˜attached’ to.
    I thought that each driver had a fingerprint of the devices it was supposed to be installed for. I know you already added my fingerprint to the ZWave Switch Mc driver. Should I uninstall a ST Edge driver once it has been installed for a device(s), preventing this issue? Thanks you for your assistance.

Question 2 see image

Also if you try to delete the driver and it deletes then it was not attached/used by any device. It will not allow drivers to be deleted if they are in use.

NickA, the Dual Relay is using the correct driver, ZWAVE Switch Mc. I do own 5 Zooz Zen30 switches, but, they were not in Inclusion Mode at the time. That is why I was surprised that the Zooz driver was even installed. I was not testing them at this time. I had simply downloaded the Zooz driver to my Hub to test at a later date. I am not expecting any one on this thread to answer issue #2. I am most concerned about issue #1. Thanks for your input.


I have modified many things in the driver and subdrivers, I don’t know if I have broken something in others that I can’t test.

With what I can test everything works and the others should work, but I may have been wrong

Try first without creating the child devices to see if everything still works the same. :crossed_fingers: :crossed_fingers:
If everything works fine, create the child’s devices one by one and try.
This one is a bit different because main turns everything on and off.
Switch1 and switch2 are endpoints 0 and 1.

 Name         Z-Wave Switch and Childs Mc
 Version      2022-09-27T19:57:56.76255866

Try change the Sensor Operation Mode setting

Hi @matiasjg

There are community developers with this device.
It is better not to duplicate drivers for the same

I forced the update several times and I am still getting the old version.

Hi @Cleon
To solve the secondary devices I am making the Z-Wave Switch and Childs Mc driver, I am trying to get users to test it to see if it works with all multi-component devices


Sorry, I forgot publish it

Published now

Tried everything but nothing … then it doesn’t work in any case not even the open or closed state and neither the temperature does not fit us :triumph:

I have it now.

With the stock Z-Wave Sensor driver works the open/close?

When I physically push the button on the Plug the state change shown up instantly in the app.

I created the 2 child devices for the plug and as expected they don’t work, but they do change state when the physical button on the plug is pushed.