[Edge] Driver for CASA.IA/OWON Temperature sensor


I wrote an Edge driver for the following remote temperature sensor:

You can install it from my channel:

The source code is available as well:

Hope it helps,


Hello Yann Konnichy,
It works like a charm!
I have 2 casaia CTHS-317-ET and 4 Owon THS-317-ET. They look like a rebrand
The owon devices aren’t recognized and added as a thing.


Is it posible to add the owon to the driver?
It would help me alot!


I guessed additional fingerprints from this information and added them to the driver. They may very well not match the real ones though… Could you please try with the updated driver?


I removed and installed the new driver (maybe not necessery) and the date is te new one.
Unfortunely the devise is still added as a thing.

It was working with the eZEX Temp & Humidity Sensor groovy dth (the OWON and the CASIA)

Maybe this info helps?

Maybe it does. I tried something else. Could you please retry?

1 Like

Yessss! Perfect.

De driver auto updated and the thing device automatic transfered in the OWON temperature sensor.

Thank you very very much!!!

1 Like

Great, I’m happy it works for you.
Thanks for your inputs.

Thanks for the driver, it was what I needed to get the remote temperature sensor to work.

I am just wondering if it would be possible to add the other sensors to the driver also?

Hi, do you know where could I purchase either of these temp sensors in the US?

Yann, I need to do some testing, want to remove the device, reset the device, and then add the device back again. I have tried a few ways but been unsuccessful. Any help would be appreciated, thank you.

Konnichy, how would I remove this zigbee device, I need to do some testing, need to remove from ST, reset device, then install again. I have looked but no success. There is no REMOVE in the device settings.
Any help greatly appreciated.

Hello Michael,
It looks like a recent SmartThings app update removed the delete button from the parameters panel. You should still be able to remove the device with a long click on its icon.

Didn’t even know u could do that, thank you