[Edge] Driver for Aqara Switches and Remotes

When set to detached everything continues to function as before. I still do not see the on/off on the card and doesn’t show the switch status.

Looks like it now shows status and on/off button.

1 Like

probably you will need to install st cli, test and send me logs

Hi Andrew, following on from the other thread, i am getting cloud symbols when refeshing your Aquara temp humidity sensor driver

Recently ST changed the way refresh works, have you updated your drivers to accomodate the change ? Or is there no fix yet ?

Can you please share a link that describes the changes, I haven’t seen any mentions of this.

My bad, 2 ticks

Oddly, the driver seems partly ok now, earlier i got all cloud icons for each section, now i only get the cloud icon on the temperature alert section

And now the temp alert section has vanished ?

yeah , I just removed refresh and temp alarm capabilities. As Xiaomi rarely responds refresh requests.
And temp alarm breaks the tile view for most of the device types

1 Like

Understood, thank you Andrew, no idea what was going on last night for me, devices were checking or partly working, was just a weird unstable few hours, hopefully today will be more reliable, with our weather going up to 30deg c and above, i need the internal temp sensors to control my A/c although in reality ‘on costant’ is the order of the day i think

sometimes it’s battery or signal issues ,
press on the hw button forces the device to send the latest data,
or just re-pair the device

Was not just the Xiaomi device last night, it seemed to be across the board on multiple devices… just an odd night

Problem with * WRS-R02 Wireless Switch (Two Button). I cant pair it with hub... Every time I try it pairs with every zigbee device I have randomly. So it wont appear in Smartthings app and it controls every light I have.

in the settings there are two options: OperationMode and Group

is seems like your device has

  • Light Commands (Bind to Group) and Group 0

so it sends commands to all the devices you have in the network

It’s not that. The Switch does not appear in smartthings at all and it just controls all devices… Very frustrating

@veonua hello! I bought an aqara b1 curtain motor and successfully added them using xiaomi blinds edge driver. Everything works just that the status of the curtain seems to be reverse of what it actually is. For instant the app shows closed but in actual fact the curtain is opened. I tried configuring the setting by checking reverse true and false but there’s no difference to the status.

for battery powered devices , I’d recommend to wake up the device (press button/pull curtain) before applying settings.

But in general, I recommend calibrating the motor with an Aqara hub, since at the initial setup, calibration is not implemented in the ST driver and the motor does not gradually reduce power as it approaches the edges.

@veonua sadly I do not have a aqara hub with me. But it seems that the motor does gradually slow down when reaching the edge.
However, I tried countless time by pressing the button and toggling the reverse setting but don’t seems to have any difference. I looked at the event and only saw the B1 status

easy fix - just put the motor to the other side of the rail.
more advanced - please install CLI and provide logs when you apply the settings. there should be “Write attribute” lines.

Sorry for asking such a stupid question, as I’m still relatively new and learning my way around. How do I use the CLI to get the logs? Would appreciate if you could point me in the correct direction :slight_smile:

@nayelyz maybe it’s time to make logging/debugging easier for people. It would be great if developers can see error logs without long explanation about cli stuff


Can you elaborate, please?
What do you mean by “without long explanation about cli stuff”?