SmartThings Community

Ecobee and fan switch


(Joe m. ) #1

Is there a simple way to turn my ceiling fan on when ecobee calls for heat? Seems so basic and nothing in smartthings store. Closest I got was the too cold app but it only turns on a device if temp drops below a specified temperature. Not the greatest when ecobee changes temps throughout the day


(Joe m. ) #2

Even ifttt doesn’t have an ecobee trigger for call for heat


(jkp) #3

You should check out webCore. It do what you want and so much more…


(Joe m. ) #4

Yeah guess I’ll have to take the one step deeper into all this


(Joe m. ) #5

We core still beta tho eh


(jkp) #6

Definitely don’t let that stop you.


(Joe m. ) #7

Authorizing the community section isn’t lit up so kind of stuck. Maybe because I’m still waiting to receive my account from the community.


(Joe m. ) #8

Nvm just didn’t like my browser lol, worked in chrome tho


(Joe m. ) #9

Maybe not a cell phone task, maybe some other day when I have a pc nearby


(Yves Racine) #10

Hi, with My ecobee Device, you have the simple ecobeeStateTriggerHA smartapp, which allows you to turn on/off switch(es) based on the thermostatOperatingState (heating, cooling, fan only, idle).

For more details on all use cases available:

It’s available at my github:


Regards


(Joe m. ) #11

Thanks I’ll check it out, new to this and just setting up webcore. Is this for we core?


(Yves Racine) #12

My ecobee Device (custom Device Type Handler) exposes all thermostat capabilities & commands for webCoRE/CoRE/SmartRules.

The ecobeeStateTriggerHA is a simple smartapp for your simple use case.

There are many other smartapps available with My ecobee Device for your use cases. So, you don’t need to use a rule engine like WebCoRE for your simple use cases.

My Ecobee device is only available at my store:

www.ecomatiqhomes.com/store

Regards


(Joe m. ) #13

Nothing showed up in myapps when I got to that stage.


(Yves Racine) #14

Hi, you’d need to contribute first at my store to start the download. Make sure that you deactivate your pop ad blocker (if any) in your browser.

www.ecomatiqhomes.com/store

Regards.


(Joe m. ) #15

I mean for webcore install sorry


(jkp) #16

Did you publish all 4 of the webcore apps in IDE and enable OAuth for the webcore one?

Then look for Webcore under Automation: SmartApps not in the marketplace.

Then sign up for an account at https://community.webcore.co/ There are lots of great example pistons to be found and the folks over there will help you with anything needed in regards to webcore.


(Joe m. ) #17


(Joe m. ) #18

Nothing in myapps still


(Joe m. ) #19


(Joe m. ) #20

Think may e because I used na01 and not na02, will redo the work and try