Echo Speaks Stopped working afrer password change

SO had to change my password recently as it seems like my smartthings account may have been compromised. I changed my amazon account password in the process of doing so which has rendered Echo speaks not to work, I tried to re-sync my password via the echo speaks smart application but it still said invalid. I removed the server that was set up under EchoSpeaks and started a fresh server install.

I get to step 8 in the guide.

I then put in my amazon account details (Correct username & Password) and get the following screen.

A few seconds later and it redirects me back to the log in page asking me to enter my details again

I never see the authentication good page

I have tried multiples times today but just seem to be in a loop and ends up with invalid login, I did set up 2 factor authentication and was wondering if this might be why so removed 2 factor authentication from my account but still have the same issue.

Anyone any ideas what else I could try to correct it? I have a lot of Automations that rely on Echospeaks so would be good to get it working again.

Check-out this thread for all the details. Issues still for United Kingdom users.

echo-speaks issues with Amazon Updates

1 Like

Thanks Scott, never spotted the thread but seems its a well known issue!

Will just need to wait and hope the dev’s find a fix for the issue, Thanks again!