SmartThings Community

Echo Naming Quirks

“Engage Kitchen Lights” doesn’t work for me but “Engage the Kitchen Lights” does. It seems that the “the” is important.

1 Like

I setup @DarcRanger’s thermostat app to control my thermostat through the echo. I called the dimmers “cooling dimmer” and “heating dimmer” and planned to make a group and just place the appropriate “dimmer” depending on heat or cool and name it something easy.
So far the only one that seems consistent is “the thermostat”.
I tried:
The a .c.
The air
The temperature

The temperature worked sometimes but I need consistency so I will just stick to thermostat for now.
I wonder if some of these works are already blocked out for future use by Amazon, actually I hope that’s the case :smile:

“Alexa, set the thermostat to 75” works great!

2 Likes

I have virtual buttons for my AC split system. I called them
"AC Cool" “AC Heat” “AC Dry” and they all work perfectly.

Alexa turn on AC Cool…OK

1 Like

I am using the “set” command as opposed to the “turn on” command, I wonder if that matters.
The app seems to see what I am saying correctly, “Alexa, set the a.c. to seventy five” but I just get the 2 tones bad command sound from the echo.
Maybe I should set the group as “the AC” instead of “the a.c.”, for some reason I thought I read you should use the dots.
I’ll try it later.

I would get rid of “the” Mine is just AC I would bet Echo ignores the.

I’m my setup, I originally used The AC, but when I checked Alexa, the card used The a.c.

“Everything” seems to have issues, though I’m pretty sure it worked when I initially set it up. I have an Echo group with a bunch of switches in it called “Everything” mainly so I can say “Alexa, turn everything off” and it turns off all the lights in the house, the TV, etc. when I’m walking out the door. Now when I do that she says “Sorry, which device did you mean?” to which I reply “everything” and she does it. Not sure why she doesn’t get it the first time but it never works now.

1 Like

First, check the history in the echo app and see what echo thought you said.

If it was in fact “everything” and that used to work but now it doesn’t, it’s possible that you’ve added a group name, or a device name, which is being parsed as similar to “everything” and that’s why echo is asking for the clarification.

Or it could just be a quirk. :wink:

1 Like

That’s the exact same this that happens to me. It sees me as saying turn off everything then asks me what device and I say everything and it works.
I wonder if Amazon “blocked” that word out for something in the future. Since everything is done through the cloud I assume they can make these changes/updates whenever they want.

It has started happening to me today when I say “Alexa, turn on All lights”. I have to reconfirm by saying “All lights”.

Glad to know it’s not just me. I changed my group name to ‘house’ today so I can ‘turn off the house.’ Not what I prefer but it’s hard to complain. :slight_smile:

@jdroberts - I noticed in my history that it does not show when I am sending ST commands, though the previous ASK integration, which I use to change modes, does show in my history along with everything else that is not ST related.

My echo connected device commands do show up in my history: all of the following are for smartthings switches.

I’ve noticed that I sometimes have problems when I don’t pause for a beat after saying “Alexa.” When the history shows “Alexa, turn on the ________”, It’s not as consistent as when I pause and it shows two separate entries in the History…one for “Alexa” and the other for the command, “Turn On _____”.

1 Like

I hadn’t seen that history area, the history is in fact there. I was just looking at the home page where it shows the cards with info from your previous commands.

Yeah, card history and voice history are two different things. Voice history is under settings. That’s where you see the connected device commands.

I have found that “T.V.” works very reliably while “TV” rarely works if ever. Using an intermediate proxy I can send the command to turn on the TV to Harmony and send volume commands to Sonos. With this, “set the T.V. to 50%” will work for volume control, but if you include the world “volume” in the device name it will bypass the HA control and set the Echo volume instead.

I don’t have any problem with “TV.”

I have found that some things do improve over time. The first few days I had it set up for “Roku” it never understood that. If I was lucky, it would ask me which device. But often I just had to repeat the whole thing.

10 days later, it’s perfect with “turn on the Roku.” So that was nice.

That may explain why one command works perfectly for one person and not at all for another, right?

Could be a learning/training issue, could be the specific set of device or group names that you’re using, could just be a quirk.

I’m pretty sure echo processes the group names first, I fixed some problems by adding a new group name.

2 Likes

Just this week, echo started giving me ESPN radio when I said “turn on ESPN.” So I changed the group name to “ESPN TV” to contain my virtual switch, and now “Turn on ESPN TV” is working fine to turn on that switch.