Echo Naming Quirks

OK, it looks like now we know why the list of reserved words has gotten longer.

Sometime in December 2015, Amazon changed the phrasing for connected home devices. You now no longer have to say “turn on…” Or “turn off…” You can just say the name of the connected home device/group and then on or off.

So if you have a device called “ceiling” you can just say “Alexa, ceiling on.” Or if you have a switch for a harmony activity and you called it “Disney channel” you can just say “Alexa, Disney Channel on.”

This is probably why they pulled words like “power” and “TV” because without the “turn” in the front of it, echo can’t tell the difference between turning off a switch named power and turning off the echo itself.

Interestingly, this comes very shortly after the iOS update that changed HomeKit scenes so that now a scene name takes precedence over other Siri commands and if you just say “hey, Siri, good night” Siri will run your good night HomeKit scene if you have one.

The point is that both systems seem to be dropping some of the natural language approach in favor of shorter phrasing with more customization. :sunglasses:

1 Like

One more point about choosing names if you intend to use both Echo and HomeKit…

With the latest iOS update, HomeKit has now given both scene names and device classes priority in Siri commands. This is why you can tell
Siri “lock all doors” and it will work, because “door” is a device class (for lock).

“Light” is another device class for HomeKit.

This lets you say “Siri, turn off bedroom lights” and any device which is a light in the bedroom will turn off.

This can cause a conflict in HomeKit if you also named a specific subset of devices “bedroom lights.” Because “Hey, Siri, turn off bedroom lights” may turn off more lights than you expect due to the new prioritization.

All of which is to say if you want to use the exact same verbal commands with Echo and Siri, it’s probably best to avoid HomeKit device class names except for a group including all of the devices of that class in a room. So “kitchen lights” group in Echo should include all devices of HomeKit class “light” in room “kitchen” (and only those devices) if you want to get the same results from both systems.

Same with me. Anything that starts with “all” for me. “All shades” does the same thing. If I open/close individually (e.g. “Alexa, close living room shades”) it works every time- even when I’m mumbling from across the room. When I confirm “all shades” or whatever, it accepts the command fine.

I’m just glad that it seems the Echo server update last week seems to have fixed the issue of “her” making you repeat commands 2-3 times and then still failing 60% of the time or replying on/off was not a valid command for a light. Of course Echo supports boiler plate response to every email and phone call was that there was no server issues. . Even though all the issues started the Monday/Tuesday after Thankgiving , right when all those $95 Echoes would have been delivered following the overly successful Thanksgiving week sale

@JDRoberts,

How do you get the Echo to turn on ESPN?

-Todd

Use Harmony as the tv controller.

The following method uses the official SmartThings integrations.

Or you can just use IFTTT, since both echo and harmony have IFTTT channels. Or you can use any other TV control device that has an IFTTT channel. :sunglasses:

1 Like

I have echo controlling harmony through if, but that can only start activities. Not tell it to tune to a channel.

We’re getting sort of off topic for this thread, so please direct follow-ups to my projects thread. That discusses in detail choosing a channel. But basically you just set up a Harmony activity and you use a step in the starting sequence of that activity to set the starting channel for the activity. Works very well.

1 Like

I just came up with a new naming issue. I replaced the lights above my kitchen sink and named them “left sink” and “right sink”. Alexa keeps hearing “left sync” and “right sync” and hence replies there is no device by that name. Yet if I say turn off/on the sink lights she understands and turns them both on/off.

1 Like

“Alexa, Turn on Netflix” does not work even though she understood me perfectly.

I’ve noticed that I can say the word “TV” again instead of “television” and Alexa understands.

Yah… poor Alexa is sick today :mask: (or for the past few days?). I also have a Netflix Virtual Switch.

My Echo is working fine with both Yonomi and IFTTT. But there’s no SmartThings involved in those. Or any virtual switches. :wink:

2 Likes

Thanks, but earlier this week I decided to cut ST out of my Echo integration in favor of Yonomi. I am trying to weed myself of ST dependencies for obvious reasons :slight_smile:

1 Like

And you checked to make sure Netflix is the name of a Yonomi " device" in your Alexa app?

I created a group called “Netflix” in the Echo app which is tied to my Harmony activity via Yonomi. For my Harmony-Echo integrations I use the Echo groups which are named “NBC”, “Nick Jr”. etc.

Maybe it’s a new reserved word.

1 Like

That would be annoying. (And a tiny bit unusual for Amazon.); but certainly a logical possibility.

1 Like

If that’s the case, they should prevent you from naming groups with it :slight_smile:

2 Likes

For me, at least, “Netflix” is not working and putting it in a group named Flix doesn’t work, but putting it in a group named “Flicks” does work. I didn’t change the activity name in harmony, just the group name in Echo.

On the other hand, if you are using the IFTTT method, “Alexa, trigger Netflix” still works just fine.