Duplicate SmartThings network to Cooper Aspire controller


(gmschwartz) #1

I have mostly Cooper Aspire switches, and since I have a number of auxiliary switches, I went ahead and purchase the Cooper Aspire controller to be able to direct associate the auxiliaries with the primary. I have the Cooper Wiring RFTDCSG Tabletop Controller. When I first got it, I somehow (don’t remember how) duplicated the network from the SmartThings to the Cooper RFTDCSG so that it a secondary controller.

Everything is set up and working pretty well (except that sometimes I have to hit the auxiliary switches twice to get them to turn off the associated light), but I’ve since added a couple of new switches and I’m not sure how to have those switches added to the Cooper Aspire controller. Most of the instructions seem to indicate that I might have to clear the entire Cooper RFTDCSG and then recopy everything back from the SmartThings. Since I will likely be added new devices a few times over the next year, that seems the be less than optimal. (And I’m afraid it will mess up the Cooper switch associations that I have).

Is there a way to get the Cooper RFTDCSG to just add in the two new switches without rebuilding from scratch?


(Duncan) #2

I haven’t used this device, but I looked at the manual online.

Have you tried “Network Discovery” and “Scan for Devices” in the settings?

If those don’t work, go to the device searching screen in SmartThings (the plus button, then Connect New Device) and on the Cooper, go to Settings > Replicate > Receive > From Unknown Controller

There’s also the option of adding the devices to the Cooper controller after adding them to SmartThings. That shouldn’t mess anything up because the controller are both on the same network.


Cooper Aspire RF Handheld Controller as Secondary Controller, HOW?
(Gautam Desai) #3

Thanks. I did try all of those things and it did discover two of the 2 dozen devices I have. I just ended up including them again with the Device —> Install option and then named each and it worked fine. A little extra work, but now I can quickly and easily create scenes for my, until now useless, Cooper Aspire 5-button Scene Controllers.


#4

Kindly confirm, since i am getting mixed messages from ST tech support.

I want to set up a cooper lighting system, with dimmers and 5 button controllers. I also want to be able to control those same dimmers with ST. Can I do that?


(gmschwartz) #5

I was (somehow) able to get it to work on my v1 hub, but on the v2 hub, my Aspire controller knows that it is a secondary controller and doesn’t allow assignment of scenes to the 5-button switch. (I haven’t had/won’t have the time to try switching back to the v1 hub and confirming if duplicating from the v1 lets me do such an assignment from the Aspire controller, but it is definitely not working on the v2.)

And I’ve tried what Gautam (see message thread) got to work, i.e. using the Aspire controller to Device/Install the switches, but the controller won’t allow it because it knows its a secondary.

If anyone figures out how to use the Cooper 5-button switch within the SmartThings ecosystem, I’d love to know. Right now I just have a useless 5-button switch on my wall, which is testing the patience of my wife who has been otherwise flexible in dealing with this home automation journey.


(Gautam Desai) #6

Yes. However, the 5 button controller has zero interaction with ST. It operates as two different systems that both work, but independently.

Another annoying thing is that I have 3 x 5 button controllers downstairs and none relate to each other so if I turn on a zone button one one, the others which are configured to the same exact scenes don’t know I set that scene. But it is what it is.


#7

I fear that’s what my future looks like…I told my wife we didn’t need Control4 because “I got this.”


#8

Gautam–is your hub a v2, per gmschwartz’s comment?


#9

Gautam,

i just bought the handheld controller, the 5 button controller, and a dimmer RF9540–but I can’t get the dimmer to be recognized by both ST AND handheld/5button.

If I install the dimmer from ST, the handheld can’t install it.
If I install the dimmer from handheld, ST can’t see it.
If I install from either, and then set the handheld as a secondary to ST (receive from unknown controller), the 5button stops controlling the dimmer and the handheld gets errors on all scenes.

Any ideas?


(Gautam Desai) #10

Hi there. I didn’t really do anything special. I already had the dimmer added to SmartThings Hub v2. Then I just did an include on the Cooper and pressed the switch and it added. I don’t think I ever added the Handheld to SmartThings at all. I already have all my devices in both SmartThings v2 and Cooper Handheld using the technique I described (manually one switch or device at a time). After that I had no issues creating scenes with the handheld and sending these scenes to specific buttons on various 5-button controllers. I do have to add some lamp dimmers to the network later this week. When I get the devices I’ll be careful to document the process and let you know what I did (if it works). Sorry I can’t be more help immediately.


(gmschwartz) #11

I was all exciting last night in reading your email, but had no luck today.

I had previously included the Cooper controller into my ST v2 hub, so this morning, I reset it (Menu/Settings/Reset), so that it showed none of my existing devices and showed a “P” in the bottom left corner of the Cooper screen, indicating that it saw itself as a primary controller.

I then went to Menu/Devices/Install and tried to add some of my Cooper switches to the Cooper controller. The Cooper controller screen read “Install Device: Press the install button on the device” and I hit the switch a number of times, but it did not add itself to the Cooper controller. (I’d imagine that it knew that it was already assigned to a network???) I tried this with a number of switches to no avail.

For what it may (or may not) be worth, I’m using the Cooper tabletop controller (model RFTDC) and it indicates the following version information (under Menu/Settings/Version):

  • Application 1.1.5
  • Protocol 2.40

Any other suggestions from anyone would be appreciated.

I’d love to be in the position that Gautam is in and having the Cooper controller do something useful!


(Gautam Desai) #12

I’m not home to post my version number, but I have the Handheld remote and it does show the P as well. I did try to add a lamp module this morning to both ST v2 and the Handheld Controller (one at a time with ST going first) and it worked.

I kinda hate how they implemented z-wave, it’s just a pain.


(Duncan) #13

There was a bug fixed in yesterday’s hub v2 update that might fix some of these problems.

To be clear, you do have to add the remote to SmartThings first, just so it’s on the same network. If you already did before you might have to do it again now that the hub is updated with the fix. The switch/dimmer should also already be added to SmartThings, and to get the remote to see it you may have to add it to the remote too.


(gmschwartz) #14

Duncan:

You just MADE MY DAY!!

(For the sake of everyone else on this thread):

I just reset my Cooper controller and added it to my ST v2 hub ( Connect New Device in SmartThings and on the Cooper, go to Settings > Replicate > Receive > From Unknown Controller). For the first time since my switch to v2, the Cooper controller still shows the “P” in the bottom left of the screen.

Most importantly, once all of the ST data transferred to my Cooper Controller, I was able to create a scene with a single switch, and actually transfer that scene successfully to my Cooper Aspire 5-button Scene Controller!!!

I can finally use that 5-button controller!!

Thank you VERY much!!


#15

It worked for me too–Duncan, you’ve help secure my confidence in ST!