Does SmartThings work with RedLink?

Are you able to post it / put on github?

I setup my 3 Redlink thermostats. 2: VisionPRO 8000 and 1 ComfortNet CTK03 (Its a Honeywell IAQ prestige 2.0 with a interface to communicate with my central AC)

Marketplace->Climate Control->Thermostats->Honeywell->VisionPro WiFi-> Connect Now-> Log In.

One you login using your Total Connect Comfort credentials, your Redlink connected thermostats will be listed. You can select them and connect them to your hub.

I had to disconnect two of mine from the WeatherBug Home app.


samsung’s support faq still says ‘All Wi-Fi are supported. RedLINK is also supported when coupled with a RedLINK Internet Gateway’; however, from this thread, if i am understanding correctly, i can have ST communicate DIRECTLY with ST sans the RedLINK Internet Gateway. is this correct?

If you’re using thermostats that require a redlink gateway then you need a redlink gateway. I have four of them that speak RF to the Redlink, up to the cloud and ST connects to them there.

As for wifi direct units, then you wouldn’t need a Redlink for them.

I think you’re still talking to the Honeywell cloud though, with or without the Redlink.


Hi… It’s really good to know that mhk1 stats works with ST. Can you confirm which thermostat, within ST app, did you choose to link the ST with Mhk1? Thanks

Ok, so after talking to honeywell support if you have the MFH1 thermostats hooked to the mitsubishi heads, after you connect them to your honeywell redlink internet gateway and to the total connect comfort website, you can then add it to smartthings. You add a device and select thermostat then the honeywell wi-fi focuspro 6000 thermostat. Once you have selected that it will ask for your credentials to the total connect comfort website. Then you can select which thermostats to add. Hope this helps anyone trying to figure this out.

Another approach to this is the PAC-WHS01WF-E, which lets you plug WiFi directly into the Mitsubishi indoor unit. You then use Kumo Cloud to control the HVAC via your phone.

Here’s a thread about attempting a ST integration for Kumo Cloud; no real progress: Kumo Cloud (Mitsubishi Electric Heat/Air)

And I’m interested in the ESP8266 approach mentioned later in that thread.

Hi, having mitsubishi units controlled by ST through mhk1 and redlink gateway is great but it could be nice if we can control the fan speed within ST routines. Has anyone succeed in doing this? Thank you

1 Like

Anyone know if this has been accomplished? I’m in the same boat. Insane that the thermostat provides this but the redlink/totalconnect UI omits it.

edit: to be clear, I’m responding to Mohamed_Berrada above.

I just talked to Honeywell’s support about this and they said that fan speed is not supported by Total Connect at this time. The person said they would pass my suggestion to add it along to the development team. I guess we’ll see what happens… I’m not expecting much because that app is pretty :poop:

1 Like

“Pass it along” is tech support code for “yeah, whatever loser” so you can see how much hope I have. I don’t know how many devices Total Connect works with but there isn’t any other option unless someone wants to take on some serious coding. They did come out with a terrible Echo/Alexa skill. I haven’t been able to get the skill to do anything, and I’m the IT guy for my company…

So, did anyone end up getting the Mitsubishi units working over RedLink connect? I can connect to it using the official Honeywell integration and the device that gets created partially works. I can see the current status, and changes get pulled in (it seems to poll every 5 minutes). However if I try to change the temperature or take any actions, it fails. When that happens, in the logs I see:

4:42:34 PM: error Error updateSetpoints, restoring to state.oldHeatingSetpoint:null, state.oldCoolingSetpoint:null
4:42:34 PM: debug updateSetpoints: parentBusy:false, currentMode:null, data:[targetCoolingSetpoint:75, targetHeatingSetpoint:56]

And each time it polls for the latest values, I see this error:

4:43:45 PM: error java.lang.NullPointerException: Cannot invoke method toInteger() on null object

@paullsoucy @HDGuy

I have them same issue since beginning of November… until now I can’t find any fix or suggestions to control the heating setpoint.

I reported to support and they said they are looking into it. It might help if more people report the same issue so that they may be inclined to spend time on it.

After reporting this issue to support they replied that MHK1 thermostat are not supported. So, if they make any changes to the Honeywell integrations or DTH’s I may notice that thermostat gain control again or their change may completely break it on my end.
Do you know if anyone has created anything that is made to get that thermostat working with SmartThings?

Oh no. That’s no good. I still have not found anything that works. Their device seems like it is so close to working… if the source was available, we may be able to figure out what is going wrong.

Good news! In mhk1 settings, I changed System changeover to auto instead of manual and everything is back to normal.


YES! Thanks Mohamed! That is awesome. It works for me too.

In case anyone else sees this and needs help, here are the steps:
1 - Press and hold the FAN and :arrow_up_small: buttons until you see “WAIT” on the screen
2 - You should see the number “101” on the left side of the screen. Press next until you see that number change to “144”
3 - Use the up/down arrows to set the number on the left side of the screen to a “1”
4 - Press “Done” to save and exit.

For details, checkout the full documentation here -

Thank you for sharing Ron. Been looking for this connection. Just applied to my Mitsubishi 2 zone system and works perfectly.

so I have an Honeywell TH6320R1004. Looks the same as your picture of the mhk1 but holding the 2 buttons does not cause the same effect. Any idea how to get it working, it used to work fine