Developers site down


#1

Cannot connect to developers site right now.

Actually my SmartApps stopped working last night as well.
Simulator produced strange error message about Spring framework and then crashed.


Filtrete 3M-50 Wi-Fi Thermostat. Version 2.0 Released 12/17/2016
#2

I’ve been in and working for the last 30 minutes or so. No problems on my end yet (East Coast).


#3

Now running fine (Seoul, Korea)


#4

Still seeing strange behaviors.

  1. When trying to set the location and install, I get the following error:

“org.springframework.security.access.AccessDeniedException: Access is denied” on the error message console, and
"Simulator is not currently running…" on the simulation section.


#5

That’s odd because I’ve been using the site since well before your post without issues, so I recommend contacting support for more help.


(Beckwith) #6

I get this error when attempting to change device types:

500: Internal Server Error
URI
/device/update
Reference Id
e8cb50da-9f84-4fdd-9972-ad2645e51139
Date
Tue Nov 18 00:53:49 UTC 2014
Class
groovy.lang.MissingPropertyException
Message
No such property: show for class: physicalgraph.device.DeviceController

I contracted support.


(Todd Wackford) #7

I’m good here. Just edited some code and even submitted for review and release. No problem-o

twack


(Beckwith) #8

I’ll try rebooting my hub since motion is not triggering some devices…


(Beckwith) #9

After rebooting my hub, I still get the 500 error when attempting to change device types. Sent another e-mail to support in hopes they have an answer.


(Nate Schwartz) #10

I thought I was doing something wrong. I am getting that exact same springframework error. It only happens if I try to test a smartapp using a virtual device. If I select an actual device everything works fine. This was my first attempt playing with the IDE so I just assumed I was screwing something up.


(Linda Thomas-Fowler) #12

I tried to create a device from the ide this morning and while it created it it also gave me an http 500 error.


Simulator Not running for example apps
(Beckwith) #13

@Linda

Please contact support. I sent two e-mails to support with no response.


(Linda Thomas-Fowler) #14

@beckwith, I have. Hopefully they can resolve this soon.


(Darc Ranger) #15

I sent a ticket in a few minute ago,and receive a response that they see a few reports and are investigating. They hope to have it resolved ASAP and will let me know via email.

I glad this is not a issue just for me, thinking I screwed something up.


(Aaron) #16

I’m also having trouble but I’m a newb so I don’t know if I am just doing something wrong. Support asked for steps to reproduce and a screenshot . . . which I provided just now.


(Ron S) #17

Just tried creating a SmartApp and get the error:

org.springframework.security.access.AccessDeniedException: Access is denied


(Beckwith) #18

Support got back to me and say they are working on it.


(Aaron) #19

has anyone heard any updates? I have not. I am sitting on my very first SmartApp and anxious to give a go on the simulator. Might just have to just test it on the metal :wink:


(Andrew Mager) #20

Give it a shot and let us know if you run into any issues. I just successfully created a test SmartApp.


(Mike Maxwell) #21

500 errors on device creation are now gone…

I take that back, went back and updated the same device, still getting this:
Error500: Internal Server ErrorURI/device/updateReference Id3e9ae085-a687-4b9e-af56-c81a52343741DateTue Nov 18 20:34:51 UTC 2014Classgroovy.lang.MissingPropertyExceptionMessageNo such property: show for class: physicalgraph.device.DeviceController