[DEPRECATED] Neato Botvac Connected + Raspberry PI + ST

Naturally. There are no brackets and as mentioned show up just fine in the env.

Sorry, just covering any bases. I uninstalled the gem and reinstalled from github to see if I could recreate your issue. I could recreate it when I replaced my actual SERIAL for an incorrect one so it must be something in that area. Triple check that your SERIAL and SECRET are correct and echo $SERIAL is showing the right serial number beginning with OPS``.

No worrires.

I did check and recheck the values. I also added them to the baserc just to make sure something funky wasnt going on when the web server launched. The values were copied and pasted, so hard to make an error there. I also tried with the dash removed. No luck.

I also went on to the neato site to make sure everything was good there. There was a value missing on their registration page, so i filled that in, but it had no impact. I can use the android app without issue, and the Mr. Robot code library looks pretty straight forward, in terms of the interface.

I will give it one more check tonight when i get a chance. I wonder if there is some variance having to do with the models.

Is your botvac serial in the format OPS#####-############ ?

Willing to share what the name of your vac is? I am just trying to figure out what might be causing the value to not come back.

SERIAL - OPS#####-############
SECRET - 32 characters long

So all of that is correct. Running out of ideas. I see he did a recent build of the mrrobot, but I am not sure what the issue is that he resolved is.

I might just have to call this one quits, as I dont see any other paths for me to chase.

{“message”:“Could not find robot_serial for specified vendor_name”}

This usually means the robot is offline.

Thank you for the help. The unit is online and is reporting. I get updates from it often.

Does anyone know if instead of a Raspberry PI there is a way to do it with a home server? Like run a small web server in the background on my WHS 2011? Im already doing this with Alarm server for my wired home security system thanks to @joe64.

If you still haven’t fixed this, I just had the same issue this morning. To fix it, on the Botvac I went into Settings --> WiFi and selected ‘Remove Network’. I then disabled Wi-fi and reenabled it. I removed the vacuum from the neato phone app and created a new robot within the app to re-add the Botvac. This fixed it by generating a new secret that I used with the PI Botvac server. To find the new secret, I used the ‘botvac robots’ command on the Pi. Now it works again.

That did the trick. Thanks!

Haven’t tried it, but this might help? http://stackoverflow.com/questions/18908708/installing-ruby-gem-in-windows

Sweet thank you I will try this out this weekend. If it works that will be one more thing controlled through Smartthings.

OK, so now that I have the integration working and everything seems stable, I would love to figure out what commands are available via the Amazon echo system. Is there any way for me to figure this out? It responds to turn on and turn off, but I dont know what else to try or where to figure out what it might understand.

thoughts?

Hi,

thanks for this project.

I only get an error with the commands “send_to_base”, “disable_schedule”, “enable_schedule” and “get_schedule”:

{“version”:1,“reqId”:“1”,“result”:“ko”,“error”:“ui_alert_invalid”}

Any idea? The rest seems to work

,“result”:“ko” - this means the command is invalid at this moment (not available), for example sending robot command to “location where it is started from” at the moment when cleaning is not paused.

“error”:“ui_alert_invalid” - means there is no error displayed on robot’s LCD.

Ok, I have been working this most of the night. I have the PI server purring like a kitten. Server tests fine and reports values noted in instructions. I followed the SmartThings instructions to a tee. My Neato isn’t connecting to the Smart Things app. I checked and rechecked my IP address for my PI and the port. Tested them on PI using curl and they work fine. All Neato commands work fine. I am getting the Bad Link icon inside the app itself. Tried the actual IP. Tried using localhost. Nothing works Current States says network not connected. Am I missing the way it should be entered? I am just putting the IP address without the http:// and still nothing. Noob at this stuff so any help would be awesome.

Have you tried a hub reboot? Sometimes I get an issue where local LAN calls don’t appear to get a response in the SmartThings logs. A reboot usually sorts this out.

I could never get it to work. I was using an emulator on Windows 7 versus an independent PI machine. What was strange that is it worked in the emulator. I don’t see how the emulator would be an issue if it is a fully functioning Raspbian OS. When I attempted to use the same settings in the app, it was no joy. I am using a Netgear router inside of a FIOS router, so that may be the issue as well. Thoughts?

Finally got it to work. A dedicated Pi machine and having everything on the same network was the solution. So now hoping someone gets this to work with Amazon Echo. :slight_smile: