SmartThings Community

[Deprecated] Lutron Caseta Connect V1.5

Interesting, I’ve found the Pi Connect to be the same speed. That said, since I don’t have a Pro I’m probably going to switch over to the official integration … at least until I find a great deal on a pro. I got sniped on eBay on my last attempt…

For the last 10 minutes I’ve been turning the lights on and off. My neighbor probably thinks I need help if hes watching. Lol I wonder if its slower do to with running the python script on windows? A couple tenths of a second isn’t noticeable unless you look for it.

Im waiting for the wifey to finish streaming a movie so I can unplug the modem and test if the lights still work

I read the official lutron integration will be cloud-to-cloud but, with speed like what I’m seeing, it has to be local control! Is it?

Had the same question myself but as per Tyler himself…it’s cloud to cloud.
There is a difference in speed but you have to really be looking for it…and I mean really looking. It’s imperceptible to most people. I pick up on very subtle speed differences (why I can’t use Sonos soundbar for tv) so I noticed it myself but it really doesn’t matter for this function.

1 Like

Well, I tried to come up with the answer but I’m coming up short. Sorry if this is taking the thread off topic.

My tests results are that, without internet, neither the official or the Pi will work for me. I tried with smartapps (I thought) run locally but, I am still learning so I am not really sure where it is breaking.
-tested with CoRE (simple door contact/motion)
-tested with Smart Lighting (again, just simple contact/motion)
-tested with Smart Home Monitor (I thought for sure this ran local)

I guess I just need to accept that without an internet connection, ST is useless. :sob: How do I explain to the wife that the lights won’t work if the internet goes down hahahaha?! (I live in the mountains/woods and it goes down a dozen times per year). She got spoiled quickly by all the motion lighting.:grin:

Only a few ST device handlers and smartapps work locally. If there are any non compatible devices in an automation, then the entire automation is run through the cloud. No custom device handlers or custom apps can run locally at this point.

So…if your internet goes down your going to have to use them old fashioned switches on the wall my friend :slight_smile:
Or a pico remote that you connected directly to the switch of course.

See this list:
https://community.smartthings.com/t/faq-confirmed-local-processing-working-device-handlers/?source_topic_id=78965

1 Like

The only SmartThings-controlled stuff that runs locally at the present time is devices using device handlers that are eligible to run locally (see the link @stephack just posted) accessed through the official SmartLighting feature or a few bits of the official Smart Home Monitor feature. And…that’s it.

No LAN integrations run locally at the present time even if they don’t have to touch the cloud. In fact, your official SmartThings mobile app can’t talk to your ST hub if the ST cloud is not available, even if the phone is connected to your WiFi.

And just to keep things exciting, there’s no way to arm/disarm Smart Home Monitor if the ST cloud is not available. So you can have it set up so that a locally operating sensor will trigger your locally operating siren–but you won’t have anyway to disarm the system locally. :cold_sweat:

So no local operation for any custom code (including the stuff in this thread) or any lutron devices at this time.

To avoid hijacking this thread, further discussion of SmartThings local processing should be taken to the following topic:

Thank you (and to Stephen, also) for taking the time to clarify that for me… I was under the wrong impression about local control. I thought cloud-to-cloud obviously wouldn’t work but, njschwartz’s would because the “middle man” is local.

I learned two things:
1.) I completely understand how and why local control is mostly non existent for any super user.
2.) How patient you are with the same question being asked a billion times :joy:

3 Likes

Anyone else having an issue with the Pico remotes? I got this set up last night and it seems to work, but there is no response when pressing buttons on the pico. I can see the button press in the log on the ST dev portal and I see the remote as a device in ST. I can even “press” buttons on the smartthings app and it works with my automations, but no response from physically pressing the pico. I do have a pro bridge.

A few things to check.

  1. make sure you didnt fat finger any of the ip addresses in the lutron.py file. Did this once and had weird things like u r describing happen. If your hubs and raspberry pi are on dhcp, verify that none have changed ip’s and create reservations if possible.
  2. Verify that you have telnet enabled on your pro hub.
  3. Ensure u r using the latest device handlers and latest pi script.

If none of these apply, please post logs after pico button press.

Thank you Nate, and the community for supporting this. After having to change subnets, all my automation broke and instead of backtracking and reentering hardcoded IPs, I’ve used the official Lutron Caseta SmartApp instead which works out of the box. I don’t use Picos (don’t have Pro) so seems to work fine for me.

If anyone has a link to where I can buy Nate a coffee, let me know. I asked and didn’t get a response in a PM about it. Thanks!

1 Like

Thanks! IPs are static and correct, Telnet is enabled, and I’m using the latest script. Strange, the signal is getting to the smartthings hub, I can see the button press in the logs, but it doesn’t do anything!

Has anyone tried using the Pico Remotes to control LIFX bulbs? Assuming this works since I see a comment above for GE Link bulbs

Once configured the picos can control any device you have integrated with smartthings. You will just need a button device smartapp (button controller ++, etc) to make the connection.

Hey sorry for such a late reply. Been working on another project and must have missed this post. Are you still having the issues described?

Not sure I can help but I worked a bit with @njschwartz on this so I might be able to point u in the right direction.

Thanks I would really appreciate the help!

Hey I am finally back from my prolonged absence and may be able to assist as well. It looks like all the of commands for button presses are making it to ST fine so that is good. The issue seems to be the link between the smartapp and the device. Which smartapp are you using? ButtonController+? Do you see any response in the logs for the button controller smartapp?

1 Like

same issue here as @bperrella - physical button presses on the picos aren’t doing anything. I’ve tried programming the buttons with a few different smart apps as well as CoRE, but no love in any regard. Pico button presses within the smartthings app do yield the expected results, however. The physical button presses show up in both smartthings IDE live logging as well as in the actual LutronPi.py script. I’ve blown out all the device types, caseta service manager smartapp, removed and re-added my github integration with LutronPi and re-added everything to be sure everything was current, attempted to run the script on a different machine…nothing I’ve tried seems to remedy the situation. I would add that I do indeed have the Pro bridge as well.

do you see anything in the lutronpi.py terminal window when you press the physical button?
It should give you a string of numbers that represent the remote id and button pressed.

1 Like

Ok so let’s try to troubleshoot this from the top. So you say that you do indeed see feedback in both the terminal from the LutronPi script and in the IDE correct? So let’s start with what you see in terminal, it should look something like:

Listening
~DEVICE
3
4
3

~DEVICE
3
4
4

The important number there is the first one (in thiscase that top 3). This is the device number that the Lutron Hub has assigned to that Pico Remote. Go into the IDE >> MyDevices and select your Pico. Look and make sure your data section looks something like:

Data
deviceType: Pico3ButtonRaiseLower
device: 3
dni: 28595742

If those device number don’t match that is where the issue lies. If it does than we need to keep looking.

When you press a button with the Pico you should actually see a chain of events in the IDE. First you will see the Pi/Caseta at: XX device give a bunch of output which is just the data it recieved from the LutronPi script. You should then see output in the Lutron Caseta Service Manger with something like “Button X was pressed”. Then finally you should see output in the Pico Device itself with something like “In button event X”.

So I guess I need to know what you are actually seeing. Please post it or take screenshots and I can troubleshoot further. Thanks!

Nate

Thanks for following up so quickly @njschwartz
So I have grabbed some screencaps. It does look as though the data section for the pico remote is showing a different number than indicated in terminal and live logging. Any idea why thats happening or what I can do about it?